Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Upgrade-Problem
#1
Hallo,

ich habe nach einem Upgrade von 1.2.6 auf 1.2.13 das Logout-Problem. Ich habe vergessen, PHP5 vor dem Upgrade zu aktivieren. Das Upgrade-Skript hat jedoch keinen Fehler angezeigt. Ich habe PHP5 erst danach aktiviert.

Ich habe jetzt gesehen, dass z.B. das Template index_logoutlink noch den alten Inhalt

<a href="member.php?action=logout&amp;uid={$mybb->user['uid']}">{$lang->index_logout}</a> |

hat. Heißt das, dass überhaupt keine neuen Templates installiert wurden? Der Template Manager sagt allerdings: "There are currently no templates which have been updated since you last upgraded."

Wie gehe ich jetzt am Besten vor? Und was hat das Upgrade-Skript mit meiner DB angestellt bzw. nicht angestellt? Kann mir jemand helfen?
#2
Ändere den Link zu:
Code:
<a href="{$mybb->settings['bburl']}/member.php?action=logout&amp;logoutkey={$mybb->user['logoutkey']}">

Danach sollte das zumindest das Ausloggen wieder funktionieren Wink
(Die Suchfunktion hätte zu diesem Problem übrigens viele schöne Threads gelifert...)

Und was soll mit der DB sein? Wenn alles funktioniert, ist es doch gut, oder nicht?
Was ist der Unterschied zwischen der Politik und der Informatik?
In der Informatik ignoriert man führende Nullen...
#3
Danke für den Link, hatte ich in der Tat schon über die Suche gefunden Big Grin

Mein Problem ist: wenn alles funktioniert, ist vielleicht doch nicht alles gut. Ich hab ja unter anderem von 1.2.6 auf 1.2.13 geupgradet, um Sicherheitslücken zu fixen. Aber ich bin mir jetzt absolut nicht sicher, was ich von 1.2.13 überhaupt in meiner DB hab.
#4
blahfoon4t0r schrieb:Hallo,

ich habe nach einem Upgrade von 1.2.6 auf 1.2.13 das Logout-Problem. Ich habe vergessen, PHP5 vor dem Upgrade zu aktivieren. Das Upgrade-Skript hat jedoch keinen Fehler angezeigt. Ich habe PHP5 erst danach aktiviert.
Da MyBB 1.2 auch mit PHP 4 läuft, ist das kein Problem. Wink
blahfoon4t0r schrieb:Danke für den Link, hatte ich in der Tat schon über die Suche gefunden Big Grin

Mein Problem ist: wenn alles funktioniert, ist vielleicht doch nicht alles gut. Ich hab ja unter anderem von 1.2.6 auf 1.2.13 geupgradet, um Sicherheitslücken zu fixen. Aber ich bin mir jetzt absolut nicht sicher, was ich von 1.2.13 überhaupt in meiner DB hab.
Wenn du das Upgrade-Skript ausgeführt hast, sollte alles aktuell sein.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#5
blahfoon4t0r schrieb:Ich hab ja unter anderem von 1.2.6 auf 1.2.13 geupgradet, um Sicherheitslücken zu fixen. Aber ich bin mir jetzt absolut nicht sicher, was ich von 1.2.13 überhaupt in meiner DB hab.
Sicherheitslücken werden in den Dateien behoben und nicht in der Datenbank, denn dort liegen nur die Inhalte. Wenn du keine Probleme hast, hat alles geklappt.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#6
Naja, ich hätte erwartet, dass das Upgrade-Skript die templates auf den Stand von 1.2.13 bringt. Aber das hat's wohl nicht gemacht. Ich habe header_welcomeblock_member manuell aktualisiert und das Logoutproblem dadurch behoben und hoffe, nicht noch weitere Probleme zu finden.

Danke für eure Hilfe