Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
UTF-8 Zeichen zurück-umwandeln
#1
Hallo,
ich würde gerne wissen, was das MyBB macht, damit diese UTF-8 Zeichen für Umlaute, wie sie in der Datenbank gespeichert sind, zurück gewandelt werden.

Mit den UTF-8 Zeichen meine ich sowas:
Code:
äüößÄÜÖ

Das MyBB stellt die Sachen richtig da, meine Homepage leider nicht...

Danke schonmal für eure Hilfe!!!
[Bild: Nirgendssicher.jpg]
Zitieren
#2
Hallo Bimon,

Die Funktion mb_convert_encoding könnte dir eventuell weiter helfen.

...

Welchen Zeichensatz verwendet deine Seite denn?

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
Zitieren
#3
auch UTF-8 ich habe die ziemlich eng mit dem Forum verknüpft, daher bleibt mir da kaum etwas anderes möglich Wink

Arbeitet das MyBB auch mit dieser Funktion? Ich hatte nämlich schon die ganzen Funktionen bezüglich ouput_page() (oder so ähnlich) durchgeschaut, aber nichts gefunden, was mir helfen könnte...
[Bild: Nirgendssicher.jpg]
Zitieren
#4
Wo braucht das MyBB eine Funktion um das Encoding zu ändern? Wink
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Keine Ahnung, ich habe mich auf jeden Fall bemüht, dass Encoding in jedem Punkt auf Homepage und im Forum gleich zu halten (lasse auch den header senden) nur leider werden auf der Homepage diese komischen Zeichen, statt der Umlaute angezeigt...

Nun weiß ich einfach nicht woran das liegt...
[Bild: Nirgendssicher.jpg]
Zitieren
#6
Das MyBB hat dafür keine Funktion, da sowohl die Seite als auch die Datenbankinhalt UTF-8 kodiert sind. Eine Umwandlung ist nicht notwendig. Wenn du Probleme hast versuche es mal mit utf8_encode() bzw. utf8_decode. Evtl. sendet auch der Server ein falsches Encoding per HTTP-Header.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#7
Den HTTP-Header ändert man doch meines Wissens so oder?

PHP-Code:
header('Content-type: text/html; charset=utf-8'); 

Das habe ich ganz oben in meinem Script (schlimm wenn das mehrmals vorkommt ?? Big Grin).

Danach wird die global.php herangeholt. Ich hatte das auch mal ohne dem header (der wird ja mit der global.php gestartet), aber nun mit dem header(...) nochmal direkt davor.

Ich verwende noch das utf8 Plugin von hier, braucht man das bei den neuen Versionen evtl. nicht mehr? Aber dann würde es mich wundern, warum das Forum richtig angezeigt wird.

Wie auch immer...


Wie sorge ich dafür, das bei meiner Homepage auch alles mit UTF8 läuft?

Datenbank --> UTF8
Header --> UTF8
Anzeige --> kA (Firefox zeigt UTF8...soweit ich weiß^^)
[Bild: Nirgendssicher.jpg]
Zitieren
#8
Ohhh Gott verdammt, sorry das ich euch mit meiner Blödheit mal wieder beschäftigt habe Big Grin

PHP-Code:
ob_start();
#Ganz viele includes#
$seite ob_get_contents();
ob_end_clean();
$seite utf8_encode($seite);
output_page($seite); 

Das kann ja auch nichts werden^^

Naja sorry und danke für eure Unterstützung!!!
[Bild: Nirgendssicher.jpg]
Zitieren
#9
Bimon schrieb:(schlimm wenn das mehrmals vorkommt ?? Big Grin).
Einmal reicht! Wink Ich weiß nicht, ob es dann wirklich mehrfach gesendet wird. Aber wenn, könnte es manche Browser irrritieren.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren