Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Bannerproblem ,bzw. nicht mehr valide
#1
Hi,

habe heute ein neues Banner für unser Forum erstellt. Leider meldet der Validator nun 6 Fehler.

Original:
Code:
<!-- begin logostrip -->
  
    <tr>
      <td id="mklogostrip" width="100%">
          <a href="$mklib->siteurl/index.php"><img src="$mklib->images/logo.gif" border="0" alt="" /></a>
          </td>
    </tr>
    
<!-- end logostrip -->

meine Änderung:
Code:
<!-- begin logostrip -->
  
    
      
          <a href="$mklib->siteurl/index.php"><img src="$mklib->images/logo.gif"/> </a>
          
    
    
<!-- end logostrip -->

Ich will also nur den Banner über die ganze Seite weg zentriert haben.
Nachdem ich nun zig Änderungen gemacht habe werden mal mehr mal weniger Fehler gemeldet. Ich blicks grad nicht mehr... Sad

Danke schonmal
Gruß,
NixxusMinimax
Zitieren
#2
Wie lauten denn die Fehlermeldungen? Was mir auffällt ist, dass das alt-Attribut im img-Tag fehlt. Dieses ist Pflicht und wird auf jeden Fall angekreidet.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#3
der 1.:
Line 662, Column 56: document type does not allow element "a" here; assuming missing "caption" start-tag.
…http://www.xxxxx.de/index.php"><img src="./mkportal/templates/Forum/im

2.:
Line 662, Column 111: required attribute "alt" not specified.
…tal/templates/Forum/images/logo.gif"/> </a>

The attribute given above is required for an element that you've used, but you have omitted it. For instance, in most HTML and XHTML document types the "type" attribute is required on the "script" element and the "alt" attribute is required for the "img" element.

Typical values for type are type="text/css" for <style> and type="text/javascript" for <script>.

3.:
Line 670, Column 4: document type does not allow element "tr" here.
<tr>

The element named above was found in a context where it is not allowed. This could mean that you have incorrectly nested elements -- such as a "style" element in the "body" section instead of inside "head" -- or two elements that overlap (which is not allowed).

4.:
Line 718, Column 19: document type does not allow element "tr" here.
<tr align="center">

5.:
Line 2084, Column 13: end tag for "caption" omitted, but OMITTAG NO was specified.
</table>

6. und letzter:
Line 2084, Column 13: end tag for "table" which is not finished.
</table>

Most likely, you nested tags and closed them in the wrong order. For example <p><em>...</p> is not acceptable, as <em> must be closed before <p>.

Mir ist nur nicht klar warum er z.B. den 6. ankreidet obwohl ich da doch garnicht dran war???
Gruß,
NixxusMinimax
Zitieren
#4
Kannst du mal bitte einen Link zu der Seite posten?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#5
Ich nehme an, dass das in einer Tabelle ist. Nun hast du aber die tr- und td-Tags gelöscht, was nicht erlaubt ist.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#6
wusste nicht dass das verboten ist. Smile

es kann aber doch kein Problem sein den Banner über die ganze Breite anzuzeigen. Das funktioniert ja eigentlich auch, nur meckert er dann min. 5 Fehler an.
Die Seite ist http://www.haldernforum.de
Gruß,
NixxusMinimax
Zitieren
#7
Geht es um das Portal oder ums Forum?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#8
um das Portal
Gruß,
NixxusMinimax
Zitieren
#9
Zitat:Line 661, Column 56: document type does not allow element "a" here; assuming missing "caption" start-tag.
Der Link ist dort nicht erlaubt, weil davor ein table-Tag geöffnet wurde. Inhalt kann erst folgen, wenn eine Spalte durch <td> eröffnet wurde.
Code:
Line 661, Column 137: character ";" not allowed in attribute specification list.
Das Semikolon hat da nichts zu suchen. Die anderen angekreideten Sachen könnten Folgen der zuvor genannten Fehler sein.
Code:
Line 1255, Column 90: character "&" is the first character of a delimiter but occurred as data.
Das & muss durch &amp; ersetzt werden. Am besten wendest du dich mal an den Support des Portals, denn das sind ja keine Fehler des Forums.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#10
Hallo Michael,

mir ist schon klar dass das keine Fehler des Forums sind. Hier ist nur der Support viel besser. Wink
Mir leuchtet nur nicht ein warum da plötzlich Fehler kommen wenn ich doch "nur" die Anzeige des Banners ändern möchte. Ich werd mich da heute abend nochmal mit befassen.

Danke soweit
Gruß,
NixxusMinimax
Zitieren