Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Linkliste
#1
Hallo

Ich schon wieder... Sad
Bin kein so ein Kracker wie ihr hier... alles was ich gelesen habe (verstehe nur Bahnhof).
Danke für jede Hilfe.

Ich möchte gerne in meinem Forum einen Botton (Linkliste) erstellen wo wenn man draufklickt ein neues Fenster geöffnet wird, wo die Banner der anderen angezeigt werden. Ein weiterer Botton für meinen Link mit Banner. Wie geht sowas von statten.
Ich bekomme von anderen Foren immer dieses zugestellt:

<a href="http://www.forum.waranwelt.de" target="_blank"><img src="http://www.forum.waranwelt.de/images/banner/waranforum1.jpg" alt="Das deutschsprachige Waranforum" border="0" /></a>
Gruß Michael
#2
Hallo.

Erstelle Dir dafür entweder eine .html Datei, oder ein neues Template:

https://www.mybb.de/doku/haeufig-gestell...ellen.html

Dort kannst Du dann die Banner einfügen.
Bitte die Suche u. die Doku nutzen.
______________________________

mfg Murphy
#3
Das habe ich schon versucht... hat bei mir mal wieder nicht geklappt.
Wenn man dort die Banner einfügt also den Code: kann man dort dann auf die Banner klicken und man wird dort hingeleitet???
Was muss ich da eingeben???

<?php
define("KILL_GLOBALS", 1);
define("IN_MYBB", 1);
//define("NO_ONLINE", 1); //

require("global.php");

add_breadcrumb("Impressum");

eval("\$impressum .= \"".$templates->get("impressum")."\";"); // Hier wird das erstellte Template geladen
output_page($impressum);
?>
Hab das alles so gemacht...
https://www.mybb.de/doku/haeufig-gestell...ellen.html
aber da kommt nur ne weiße Seite???
...................................................................................................................
Das habe ich jezt gemacht:

Neues Template erstellt:

<html>
<head>
<title>{$settings['bbname']} - Links</title>
{$headerinclude}
</head>
<body>
{$header}

<a href="http://www.toplistenservice.de/generator.php?id=25711&sub_uid=287917" target="_blank"><img src="http://www.toplistenservice.de/images/vote2.gif" border=0></a>

{$footer}
</body>
</html>
...................................................................................................................
Im Header:
<li><a
<a href="{$mybb->settings['bburl']}/link liste.php">Impressum</a>
<li><a
...................................................................................................................
link liste.php erstellt
und gespeichert im Ordner Plugins.

<?php
define("KILL_GLOBALS", 1);
define("IN_MYBB", 1);
//define("NO_ONLINE", 1); //

require("global.php");

add_breadcrumb("Impressum");

eval("\$impressum .= \"".$templates->get("impressum")."\";"); //
output_page($impressum);
?>
.................................................................................................................
Weiterhin Error 404
was mach ich nur falsch...
Gruß Michael
#4
Bitte benutze die Editier-Funktion anstatt dreimal hintereinander zu posten!
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#5
Aber dann sieht doch niemand, das da was neues zugekommen ist? oder...
Gruß Michael
#6
Hallo Michael 72,

versuche es einmal auf diesem Weg
(den hier verwendeten Namen "Partner" kannst du entsprechend abändern - z. B. "Links" oder "link_liste"):

1. erstelle eine Datei "partner.php" mit diesem Inhalt
PHP-Code:
<?php
define
("KILL_GLOBALS"1);
define("IN_MYBB"1);
//define("NO_ONLINE", 1); // Wenn Seite nicht in Wer ist online-Liste auftauchen soll
 
require("global.php");
 
add_breadcrumb("Partner");
 
eval(
"\$partner .= \"".$templates->get("partner")."\";"); // Hier wird das erstellte Template geladen
output_page($partner);
?>
2. erstelle in deinem Template-Set ein Template "partner" mit diesem (Muster-)Inhalt
Code:
<html>
<head>
<title>{$settings[bbname]} - Partner</title>
{$headerinclude}
</head>
<body>
{$header}
<table>
<tr>
<td>
<a href="http://url_der_zieldomain_1.tld"><img src="{$theme['imgdir']}/banner_1.gif" border="0" alt="Partner_1" />Partner_1</a>
</td>
</tr>
</table>
<br />
<table>
<tr>
<td>
<a href="http://url_der_zieldomain_2.tld"><img src="{$theme['imgdir']}/banner_2.gif" border="0" alt="Partner_2" />Partner_2</a>
</td>
</tr>
</table>
{$footer}
</body>
</html>
Die Namen der Grafiken "banner_1.gif" und "banner_2.gif" musst du anpassen; ebenso musst du ggf. die Linkbezeichnungen "Partner_1" und "Partner_2" ändern (wenn du auch Text verwenden möchtest) oder entfernen (wenn du nur Banner verwenden möchtest).
Weitere Links kannst du entsprechend hinzufügen.

3. füge im Template "header" ein:
Code:
<li><a href="{$mybb->settings['bburl']}/partner.php"><img src="{$mybb->settings['bburl']}/{$theme['imgdir']}/toplinks/partner.gif" alt="" />Partner</a></li>

Die Seite kannst du dann unter "http://www.echsen-privat.de/partner.php" aufrufen.

Ich hoffe, dies hilft dir weiter.
#7
Tut mir leid das ich schon wieder nerve...

Aber das habe ich nicht verstanden? was muß ich da eingeben?

//define("NO_ONLINE", 1); // Wenn Seite nicht in Wer ist online-Liste auftauchen soll
..................................................................................................................
eval("\$partner .= \"".$templates->get("partner")."\";"); // Hier wird das erstellte Template geladen
output_page($partner);
..................................................................................................................
Und habe ich das richtig gemacht?

href="="http://www.forum.waranwelt.de/images/banner/waranforum3.gif"><img src="{$theme['imgdir']}/banner_1.gif" border="0" alt="Partner_1" />Partner_1</a>

Weil das ist das,was das andere Forum vorgibt:

<a href="http://www.forum.waranwelt.de" target="_blank"><img src="http://www.forum.waranwelt.de/images/banner/waranforum3.gif" alt="Das Forum für alle Waran- und Tierfreunde" border="0" /></a>

Ich habe das alles ersetzt aber es klapt nicht. Ich glaub ich bin Doo....

Meine Seite: http://www.echsen-privat.de
Gruß Michael
#8
Übernehme erstmal die Daten so wie von linwinman gepostet. Wenn dann eine Seite angezeigt wird kannst du die Inhalte immer noch ändern.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#9
Hab ich gemacht aber da passiert nichts oder muss ich warten, bis sich die Sache aktualisiert???
Gruß Michael
#10
Der Link im Header/Toplinks ist richtig; allerdings führt er zu einem "Error 404 - Objekt nicht gefunden!".

Hast du die Datei "partner.php" ins Hauptverzeichnis deines Forums auf dem Webserver kopiert?