Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[NG] Edit Problem!
#1
Hallo wenn ichversuch nen Thema zu editieren dann kommt jedes mal das hier...

Du hast vergessen einen Betreff anzugeben. Bitte korrigiere deine Eingabe.

woran liegt des?!
#2
Was steht den in dem Feld "Nachrichten-Betreff" wenn du den Beitrag bearbeiten willst? Steht dort der Betreff?

Welche MyBB-Version verwendest du?
Welche PHP/MySQL-Version verwendest du?
Seit wann funktioniert das nicht mehr? Hast du ein Upgrade durchgeführt oder von einem anderen Forum konvertiert?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
Ne da steht kein Betreff. Nach diesem hab ich aber auch gesucht. In den Templates kannst kaum liegen hab da nichts geändert!

1.02
PHP 4.8.3, MySQL 4
Nein Kein Upgrade
#4
Hast du irgendwelche Dateien geändert und/oder Mods eingebaut? Kannst du bitte die URL zu deinem Forum posten oder per PN schicken und einen Testaccount anlegen?

Danke!

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
Ja ich hatte Mods erstellt die auch mit der Thread Erstellung & Editierung zu tun hatte, aber habe diese durch die Orginalen wieder ersetzt da diese nicht richtig funktioniert hatten.

PN ist unterwegs.
#6
Bitte poste den Inhalt des Templates "Beitrag bearbeiten Templates" -> "editpost".

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#7
Bitteschö..,
Code:
<html>
<head>
<title>$settings[bbname] - $lang->edit_post</title>
$headerinclude
</head>
<body>
$header
$preview
$maximageserror
$attacherror
<form action="editpost.php" method="post" name="editpost">
<table border="0" cellspacing="$theme[borderwidth]" cellpadding="$theme[tablespace]" class="tborder">
<tr>
<td class="thead" colspan="3"><strong>$lang->delete_post</strong></td>
</tr>
<tr>
<td class="trow1" nowrap="nowrap"><input type="checkbox" name="delete" value="yes" tabindex="9"> <strong>$lang->delete_q</strong></td>
<td class="trow1" width="100%">$lang->delete_1<br /><span class="smalltext">$lang->delete_2</span></td>
<td class="trow1" nowrap="nowrap"><input type="submit" class="submit" name="submit" value="$lang->delete_now" tabindex="10"></td>
</table>
<input type="hidden" name="action" value="deletepost">
<input type="hidden" name="pid" value="$pid">
</form>
<br />
<form action="editpost.php" method="post" enctype="multipart/form-data" name="input" onsubmit="return checkForm();">
<table border="0" cellspacing="$theme[borderwidth]" cellpadding="$theme[tablespace]" class="tborder">
<tr>
<td class="thead" colspan="2"><strong>$lang->edit_post</strong></td>
</tr>
$loginbox
$subdesc_bit
$posticons
<tr>
<td class="trow2" valign="top"><strong>$lang->your_message:</strong><br /><p align="center">$smilieinserter</p></td>
<td class="trow2">
<table cellspacing="0" cellpadding="0" border="0">
$codebuttons
<tr>
<td colspan="2">
<textarea name="message" rows="20" cols="70" tabindex="3">$message</textarea>
</td>
</tr>
</table>
</td>
</tr>
<tr>
<td class="trow1" valign="top"><strong>$lang->post_options</strong></td>
<td class="trow1"><span class="smalltext">
<input type="checkbox" name="postoptions[signature]" value="yes" tabindex="6" $postoptionschecked[signature]> $lang->options_sig<br />
<input type="checkbox" name="postoptions[emailnotify]" value="yes" tabindex="7" $postoptionschecked[emailnotify]> $lang->options_emailnotify
$disablesmilies</span></td>
</tr>
$attachbox
$pollbox
</table>
<br />
<center><input type="submit" class="submit" name="submit" value="$lang->update_post" tabindex="3">  <input type="submit" class="submit" name="previewpost" value="$lang->preview_post" tabindex="4"></center>
<input type="hidden" name="action" value="do_editpost">
<input type="hidden" name="pid" value="$pid">
<input type="hidden" name="posthash" value="$posthash">
<input type="hidden" name="removeattachment" value="">
</form>
$footer
</body>
</html>
#8
Aus irgendeinem Grund ist das Template unvollständig. Bitte ersetze den Code im Template durch diesen:
Code:
<html>
<head>
<title>$settings[bbname] - $lang->edit_post</title>
$headerinclude
</head>
<body>
$header
$preview
$maximageserror
$attacherror
<form action="editpost.php" method="post" name="editpost">
<table border="0" cellspacing="$theme[borderwidth]" cellpadding="$theme[tablespace]" class="tborder">
<tr>
<td class="thead" colspan="3"><strong>$lang->delete_post</strong></td>
</tr>
<tr>
<td class="trow1" nowrap="nowrap"><input type="checkbox" name="delete" value="yes" tabindex="9"> <strong>$lang->delete_q</strong></td>
<td class="trow1" width="100%">$lang->delete_1<br /><span class="smalltext">$lang->delete_2</span></td>
<td class="trow1" nowrap="nowrap"><input type="submit" class="submit" name="submit" value="$lang->delete_now" tabindex="10"></td>
</table>
<input type="hidden" name="action" value="deletepost">
<input type="hidden" name="pid" value="$pid">
</form>
<br />
<form action="editpost.php" method="post" enctype="multipart/form-data" name="input" onsubmit="return checkForm();">
<table border="0" cellspacing="$theme[borderwidth]" cellpadding="$theme[tablespace]" class="tborder">
<tr>
<td class="thead" colspan="2"><strong>$lang->edit_post</strong></td>
</tr>
$loginbox
<tr>
<td class="trow2"><strong>$lang->subject</strong></td>
<td class="trow2"><input type="text" name="subject" size="40" maxlength="85" value="$subject" tabindex="1"></td>
</tr>
$posticons
<tr>
<td class="trow2" valign="top"><strong>$lang->your_message:</strong><br /><p align="center">$smilieinserter</p></td>
<td class="trow2">
<table cellspacing="0" cellpadding="0" border="0">
$codebuttons
<tr>
<td colspan="2">
<textarea name="message" rows="20" cols="70" tabindex="3">$message</textarea>
</td>
</tr>
</table>
</td>
</tr>
<tr>
<td class="trow1" valign="top"><strong>$lang->post_options</strong></td>
<td class="trow1"><span class="smalltext">
<input type="checkbox" name="postoptions[signature]" value="yes" tabindex="6" $postoptionschecked[signature]> $lang->options_sig<br />
<input type="checkbox" name="postoptions[emailnotify]" value="yes" tabindex="7" $postoptionschecked[emailnotify]> $lang->options_emailnotify
$disablesmilies</span></td>
</tr>
$attachbox
$pollbox
</table>
<br />
<center><input type="submit" class="submit" name="submit" value="$lang->update_post" tabindex="3">  <input type="submit" class="submit" name="previewpost" value="$lang->preview_post" tabindex="4"></center>
<input type="hidden" name="action" value="do_editpost">
<input type="hidden" name="pid" value="$pid">
<input type="hidden" name="posthash" value="$posthash">
<input type="hidden" name="removeattachment" value="">
</form>
$footer
</body>
</html>

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#9
Danke, funktioniert wieder!
Aber kkann mich nicht mehr Ausloggen! Woran liegt das?
#10
Das liegt daran, dass du die Cookie-Einstellungen geändert hast. Lösche die Cookies im Browser, dann klappt auch das wieder. Wink

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.