Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Attachments pro Beitrag
#1
Ich habe unter Foreneinstellungen --> Ändern --> Beitragserstellung die Option "Maximale Attachments pro Beitrag" auf 1 stehen. Und trotzdem können von den Mitgliedern mehrere Attachments hoch geladen werden.
Woran kann das liegen? Muss ich noch irgendwo anders etwas dazu einstellen?
VG,
Susanne
#2
Ich habe es gerade getestet und kann keinen Fehler feststellen. Wurde der Wert in der inc/settings.php in die Variable $settings['maxattachments'] übernommen? Hast du irgendwelche Modifikationen eingebaut, die den Attachment-Upload beeinträchtigen könnten?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
Ahaaaaaa! ich weiß wie die es machen! Und so darf es nicht gehen, wäre schön, wenn das geändert werden könnte. Sad
Also, man schreibt einen Beitrag und lädt ein Attachment dazu hoch. Den Beitrag schickt man ab. Dann geht man auf "Editieren" und kann dann ein weiteres Attachment hoch laden. Und so kann man das fortführen, bis man beliebig viel hoch geladen hat.
VG,
Susanne
#4
Versuche mal bitte folgendes: Öffne die Datei editpost.php und suche nach:
PHP-Code:
if($mybb->settings['maxattachments'] == || ($mybb->settings['maxattachments'] != && $attachcount <= $mybb->settings['maxattachments']) && !$noshowattach
Ersetzen durch:
PHP-Code:
if($mybb->settings['maxattachments'] == || ($mybb->settings['maxattachments'] != && $attachcount <= $mybb->settings['maxattachments'] - 1) && !$noshowattach

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
Ja prima, das klappt.
Danke!
VG,
Susanne
#6
(14.01.2008, 12:06)Michael schrieb: Ersetzen durch:
PHP-Code:
if($mybb->settings['maxattachments'] == || ($mybb->settings['maxattachments'] != && $attachcount <= $mybb->settings['maxattachments'] - 1) && !$noshowattach
Ich habe das bei uns nun auch mal probiert und den Code wie oben angezeigt geändert. Allerdings habe ich es auf -13 gesetzt. Wink

Wenn man dann aber irgendeinen Beitrag editieren will (kann auch ohne Attachments sein), dann erscheint die komplette Zeile mit der Auswahl "Neues Attachment" gar nicht mehr!?

Gibt es dafür evtl. eine Erklärung?

Dankeschön! Smile
viele Grüße
Jockl
übersetzte und eigene Plugins
#7
Du hast was auf -13 gesetzt?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#8
Nun antworte ich in Vertretung eines selig Schlafenden Big Grin

Ja, auf 13.
Hintergrund ist, dass bei uns ja durchaus einige Bilder gewünscht sind.
Eigentlich waren mal 10 Bilder pro Beitrag vorgesehen; da aber eine Userin genau das gemacht hat, was hier beschrieben wurde (nämlich editiert und dann 13 Bilder hochgeladen), haben wir im ACP auf 13 Bilder geändert und eben die editpost.php auch auf 13 gesetzt (wir wollten nicht riskieren, dass am Ende durch die bereits vorhandenen Bilder der Wurm drin ist).

Und nach dem Einfügen dieser Scriptzeile konnte man beim Editieren keine Bilder mehr hochladen.
#9
Die Zeile muss genau so, wie sie oben steht, übernommen werden. Die Anzahl der erlaubten Attachments ist davon unabhängig.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#10
Aaaah... *auf die Stirn patsch*; wir dachten, die "- 1" wäre die Anzahl der Bilder, da Susanne ja von 1 Bild pro Beitrag schrieb.
Ne... schon klar; war völlig falsch gedacht.

Danke schön!!

Gute Nacht und liebe Grüße

Anschi