Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Eigene Seite
#1
Hallo,

ich habe das alte Problem mit der eigenen Seite.

Ich habe alles gemacht wie es hier steht, bekomme aber trotzdem nur eine leere Seite zu sehen.

Meine php-datei ist nicht farbig in meinem Editor. Falls das vielleicht das Problem ist.

Wenn ich meinen Quelltext öffne, sehe ich auch immer etwas anderes als in meiner php-datei.

http://Osamu.os.funpic.de/Disclamer.php

Hier die php-datei:

Code:
<?php
//**** Eigene Seite *****
define("KILL_GLOBALS", 1);
define("IN_MYBB", 1);


require_once "./global.php";
require_once "./inc/functions_post.php";

add_breadcrumb("Disclamer");


eval("\$Disclamer .= \"".$templates->get("Disclamer")."\";");
output_page($Disclamer);
?>

und hier mein templates:

Code:
<html>
<head>
<title>$settings[bbname]</title>
$headerinclude
</head>
<body>
$header
<i>
mein text
</i>
$footer
</body>
</html>

Habe ich irgendetwas falsch gemacht?

Wollte es in ein anderes Thema schreiben, als Antwort bin dann ausversehen auf neues Thema gekommen.
Dieses Thema hab ich gelesen:

https://www.mybb.de/forum/showthread.php?tid=364&page=1
#2
Osamu schrieb:und hier mein templates:

Code:
<html>
<head>
<title>$settings[bbname]</title>
$headerinclude
</head>
<body>
$header
<i>
mein text
</i>
$footer
</body>
</html>

Bist Du sicher das Dein Template (unter default templates) auch wirklich "Disclamer" heisst?

Oder hasst du ein anderes Theme installiert und es nicht dort im Theme-Template
unter diesen Namen eingesetzt?

Einen anderen Fehler sehe ich nicht...
Grüsse aus Hamburg
Bernd alias BeeJayZZR

MyBB Version.: 1.8.6
PHP Version...: 5.3.18-nmm1
MySQL Version: 5.1.43


[Bild: signature_red_en_us.php]
#3
Hallo Osamu,

Variablen in Templates haben seit Version 1.2 in geschweiften Klammern zu stehen. (geschweifte Klammern = { })
Auch haben sich einige "globalen" MyBB Funktionen geändert. $settings existiert z.b nicht mehr.
Ersetze dein Template bitte hiermit:
Code:
<html>
<head>
<title>{$mybb->settings[bbname]}</title>
{$headerinclude}
</head>
<body>
$header
<i>
mein text
</i>
{$footer}
</body>
</html>

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
#4
Also ich habe jetzt den Disclamer so geändert wie es Garlant beschrieben hat.
Bekomme aber immer noch eine leere Seite.
Ich habe ein neues Theme installiert (Emolution) habe den Disclamer unter Global und Emolution gespeichert.
die php-datei besteht nur im upload ordner.
Muss ich ihn vielleicht auch in den Emolution ordner laden?

P.S. mein Seiten quelltext zeigt jetzt gar nichts mehr an. und mein Forum funktioniert auch nicht mehr. habe dort auch nur noch eine leere seite -.-. Gestern lief die Seite noch ausgezeichnet. Aber wenn ich Osamu.os.funpic.de/Admin eingebe komme ich in den Admin bereich.
#5
Hallo Osamu,

Zitat:die php-datei besteht nur im upload ordner.
Die Datei "Disclamer.php" muss direkt im root-Verzeichnis deines Forums liegen
-> "pfad_zum_forum/Disclamer.php".

HTH
#6
Ja mein ich ja ich glaube ich habe gar keinen Upload ordner.
Ich habe die php-datei mit smartFTP direkt nach Osamu.os.funpic.de geladen.
#7
Osamu schrieb:P.S. mein Seiten quelltext zeigt jetzt gar nichts mehr an. und mein Forum funktioniert auch nicht mehr. habe dort auch nur noch eine leere seite -.-. Gestern lief die Seite noch ausgezeichnet. Aber wenn ich Osamu.os.funpic.de/Admin eingebe komme ich in den Admin bereich.
http://wiki.mybboard.de/index.php/Seite_wei%C3%9F%3F
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#8
okay die eig. seite geht

DANKE
#9
Ich habe ein weiteres Problem.
Ich habe den Disclamer jetzt auf meinem Forum.

aber wenn man ihn öffnet kommt der text in 1. stück.

http://osamu.os.funpic.de/Disclamer.php

in meinem Templates aber steht der text mit absatz usw.

kann man das ändern?
#10
Du musst im Template HTML benutzen.
Vantage-Forum: http://vantage-forum.de/