Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehlermeldung beim Öffnen von "Install"
#1
Ich habe myBB 1.2.9 auf meinen Webspace geladen, dabei jeweils .htm, .html, .php und .css Dateien im Ascii Modus, den Rest im Binary Modus übertragen. Ich habe die Rechte von config.php und settings.php auf '666' gesetzt. Wenn ich im Browser in .../mybb/install/ wechsele (Forum ist im Ordner 'mybb'), erhalte ich folgenden Fehler:

Code:
Warning: require_once() [function.require-once]: open_basedir restriction in effect. File(/home/zendurl/public_html/u/uriuri/mybb/inc/class_core.php) is not within the allowed path(s): (.:/tmp:/home/zendurl/public_html/t/thefirewall/) in /home/zendurl/public_html/u/uriuri/mybb/install/index.php on line 16

Warning: require_once(/home/zendurl/public_html/u/uriuri/mybb/inc/class_core.php) [function.require-once]: failed to open stream: Operation not permitted in /home/zendurl/public_html/u/uriuri/mybb/install/index.php on line 16

Fatal error: require_once() [function.require]: Failed opening required '/home/zendurl/public_html/u/uriuri/mybb/inc/class_core.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/zendurl/public_html/u/uriuri/mybb/install/index.php on line 16

Ich habe auch schon die Rechte von config und settings auf '755' und auf '777' gesetzt. Hat auch nicht geholfen.

Nach langer Suche in dieversen Foren habe ich mich entschlossen, hier zu fragen. Ich habe bisher nur Posts im einglischsprachigen Forum gefunden, allerdings von Leuten, die auf Version 1.2.9 upgraden. Die haben den Fehler gemacht, ihr config.php mit der neuen (leeren) Version zu überschreiben. Danach haben sie einfach die neue durch ihre alte config.php ersetzt, dann ging alles. Ich jedoch habe keine ältere, beschriebene Version.

Any ideas what this means? Wink
#2
Okay, ich habe jetzt im Forum meines ISP gestöbert und zumindest herausgefunden, dass es an der Serverkonfiguration liegt. Steht ja im Grunde schon im Fehler selbst drin. Man muss nur was damit anfangen können:

Code:
open_basedir restriction in effect.

Die open_basedir restriction verhindert, dass ein php-file auf das darüber liegende Verzeichnis Zugriff hat. Da das aber für die Installation notwendig ist, klappt's nicht. Tja.

Ich versuche jetzt, über den ISP eine Lösung für das Problem zu finden. Wenn noch jemand was weiß, bitte posten.

Danke für eure Aufmerksamkeit. Wink


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Fehler bei Aufruf von .../install/ nulok 1 1.154 03.05.2008, 11:31
Letzter Beitrag: nulok
Question Fehlermeldung beim Abrufen der Install Mister-Gym 5 1.034 08.10.2007, 22:59
Letzter Beitrag: Mister-Gym