Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.11 veröffentlicht (04.04.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Theme-Installation bei MyBB 1.2.9
#1
Hallo,
ich habe MyBB in der Version 1.2.9 installiert und verschiedene Themes von MyBB-Design versucht zu installieren, z.B. MyBB Dream, Mac OS X, u.a. die alle kompatibel zur V 1.2.9 sein sollen (Angabe: für 1.2.x). Beim Hochladen des xml-Files gibt es jedoch immer eine Fehlermeldung, die besagt, dass das Theme nicht für die Boardversion geeignet wäre. Wenn ich auf "ignorieren" klicke, wird zwar hochgeladen, aber es treten dann verschiedene Fehler auf.
Zitieren
#2
Was treten denn für Fehler auf?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Nach nochmaligem Test ist das MacOS Theme ok bis auf eine leichte Verschiebung um 1px im Kasten der Forumsübersicht und darunter im Statistikkasten (der Mittelteil der Titelleiste oben ist gegenüber den abgerundeten Ecken um 1 px nach oben verschoben, s. Attachment), aber MyBB Dream zeigt diesen Fehler beim Ausloggen:
Deine Benutzer-ID konnte nicht verifiziert werden, um dich abzumelden. Ein Grund könnte sein, dass ein böswilliges JavaScript versucht hat dich abzumelden. Wenn du dich abmelden willst, benutze bitte den Abmelde-Button im Menü.


Angehängte Dateien Thumbnail(s)
   
Zitieren
#4
Eventuell hilft dir dies weiter: http://www.forum.mybboard.de/showthread....1#pid45201

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
Zitieren
#5
Offlimits schrieb:Nach nochmaligem Test ist das MacOS Theme ok bis auf eine leichte Verschiebung um 1px im Kasten der Forumsübersicht und darunter im Statistikkasten (der Mittelteil der Titelleiste oben ist gegenüber den abgerundeten Ecken um 1 px nach oben verschoben, s. Attachment),
Dieser Fehler ist im Theme drin. Das liegt nicht an der MyBB-Version.
Offlimits schrieb:aber MyBB Dream zeigt diesen Fehler beim Ausloggen:
Deine Benutzer-ID konnte nicht verifiziert werden, um dich abzumelden. Ein Grund könnte sein, dass ein böswilliges JavaScript versucht hat dich abzumelden. Wenn du dich abmelden willst, benutze bitte den Abmelde-Button im Menü.
Da gab es eine Änderung bei MyBB 1.2.8. Bei früheren Themes muss die Änderung in Garlants Link gemacht werden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#6
@Dragon
Danke für die detaillierte Auskunft. Wenn ich das richtig sehe, dann ist die Angabe bei MyBBDesign ("für V 1.2.x") zur MyBB-Version nicht korrekt.
Ich habe auch noch kein Theme "erwischt", dessen xml-File sich ohne die genannte Fehlermeldung hochladen ließe. Ich muss den Versionscheck immer ignorieren. *??*
Liegt das nun am MyBB 1.2.9 oder an den Themes?
Zitieren
#7
Eigentlich muss man die Version immer ignorieren. Nur selten gibt es bei Versionen, bei denen nur die letzte Ziffer geändert wird, Probleme. Allerdings gibt es fast immer Template-Änderungen. Das spielt fast nie eine Rolle, da die Themes meistens nicht die geänderten Templates enthalten, es kann aber trotzdem passieren. Die Entwickler gehen mit der Fehlermeldung kein Risiko ein. Die Theme-Autoren können aber auch nichts machen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#8
Dragon schrieb:Das spielt fast nie eine Rolle, da die Themes meistens nicht die geänderten Templates enthalten, ...
Meine Themes enthielten auch keine Templates, jedenfalls habe ich keine gesehen. Aber trotzdem hat die Funktion "Templates > Aktualisierte finden" im ACP Abweichungen in den Templates der installierten Themes zur Version von MyBB gefunden, bei allen, glaube ich.
Jedenfalls habe ich in dieser Liste den Button "Zurücksetzen" benutzt und das hat jetzt funktioniert: das betreffende Theme zeigt den Fehler von oben nicht mehr. Allerdings war es eine ziemliche Klickerei. Big Grin
Jetzt ist mir MyBB wieder etwas klarer geworden!
Zitieren