Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Plugin Forenansicht wird nicht angezeigt
#1
Hallo zusammen

Ich habe mir heute das "Plugin Board Message" installiert das ich auch anschliessend unter Plugin Manager aktiviert habe. Auch die Einstellungen unter Foreneinstellungen --> ändern --> Board Message Settings sind vorhanden. Aber in meinem Forum ist das "Board Message" nirgens sichtbar.

Ich habe mich darauf gefragt ob das Plugin Board Message sich evt. mit anderen Plugins nicht verträgt. Ist das möglch?

Hier eine Liste der installierten Plugins:
- Board Message / Aktiviert
- Downloads Section / Deaktiviert
- Email-Benachrichtigung bei Registrierung / Aktiviert
- Hello World! / Deaktiviert
- Wochenanfang / Aktiviert
- Übersicht / Aktiviert

Kennt jemand das Problem?
Computer helfen uns Probleme zu lösen, die wir ohne sie gar nicht hätten.
Zitieren
#2
Füge die Variable {$boardmsg} im Template header an der gewünschten Stelle ein.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#3
Habe das {$boardmsg} im header eingefügt und auch nochmal den Plugin neu gestartet aber da ist keine Forenansicht zu sehen.

Hier mein header:
Code:
    <a name="top" id="top"></a>
<div id="container">
<div id="header">
<div class="logo" align="left"><!-- ImageReady Slices (2007_b_2.psd) -->
<table width="978" border="0" cellpadding="0" cellspacing="0">
    <tr>
        <td>
<img src="../../images/myBulletin/images/logo_01.gif"  width="2" height="77" alt="Forum Startseite"/></td>
        <td>
            <a href="http://www.pc-tips.ch">
                
<img src="../../images/myBulletin/images/logo_02.gif" width="397" height="77" border="0" alt="Forum Startseite"/></a></td>
        <td>
            <a href="http://www.pc-tips.ch/member.php?action=register">
                
<img src="../../images/myBulletin/images/logo_03.gif" width="579" height="77" border="0" alt="Klick hier um dich zu Registrieren"/></a></td>
    </tr>
</table>
<!-- End ImageReady Slices --></div>
            <hr class="hidden" />
        </div>
        <hr class="hidden" />
        <div id="content">
                              {$welcomeblock}
            {$bannedwarning}
            {$bbclosedwarning}
            {$unreadreports}
            <br class="clear" />
<center>
<a href="http://de.wikipedia.org/">
<img src="images/myBulletin/wikipedia.png" border="0" width="468" height="60" alt="Wikipedia - die freie Enzyklopädie" /></a>
</center>
{$boardmsg}
<br />

und das ist die boardmsg.php:
Code:
<?php
/**
* Board Message Plugin for MyBB
* Copyright © 2005 MyBB Mods
* URL: http://mods.mybboard.com/
*
* By: Musicalmidget
* Website: http://www.musicalmidget.com/
*/

$plugins->add_hook('global_start', 'boardmsg');

function boardmsg_info()
{
    return array(
        'name'            => 'Board Message',
        'description'    => 'Allows administrators to add a global message to the forums header from the settings administration.',
        'website'        => 'http://mods.mybboard.com/',
        'author'        => 'Musicalmidget',
        'authorsite'    => 'http://www.musicalmidget.com/',
        'version'        => '1.0.1',
    );
}

function boardmsg_activate()
{
    require MYBB_ROOT.'/inc/adminfunctions_templates.php';
    global $db;
    
    $boardmsg_group = array(
        'name'            => 'boardmsg',
        'title'            => 'Board Message Settings',
        'description'    => 'Settings for the Board Message plugin.',
        'disporder'        => 3,
        'isdefault'        => 'no',
    );
    
    $db->insert_query(TABLE_PREFIX.'settinggroups', $boardmsg_group);
    $gid = $db->insert_id();
    
    $boardmsg_setting_1 = array(
        'name'            => 'showboardmsg',
        'title'            => 'Enable Board Message',
        'description'    => 'Display the board message in the forum header?',
        'optionscode'    => 'onoff',
        'value'            => 'on',
        'disporder'        => 1,
        'gid'            => intval($gid),
    );
    
    $boardmsg_setting_2 = array(
        'name'            => 'boardmsg',
        'title'            => 'Board Message',
        'description'    => 'Enter the message you would like to be displayed in the forum header when the board message is enabled.',
        'optionscode'    => 'textarea',
        'value'            => 'This is a global board message which administrators can modify from the \"Board Message Settings\" category of the Settings area in the Admin CP.',
        'disporder'        => 2,
        'gid'            => intval($gid),
    );
    
    $db->insert_query(TABLE_PREFIX.'settings', $boardmsg_setting_1);
    $db->insert_query(TABLE_PREFIX.'settings', $boardmsg_setting_2);
    
    $boardmsg_template = array(
        "title"        => 'global_boardmsg',
        "template"    => "<table border=\"0\" cellspacing=\"1\" cellpadding=\"4\" class=\"tborder\">
<tbody>
<tr>
<td class=\"trow1\">\$boardmessage</td>
</tr>
</tbody>
</table>
<br />",
        "sid"        => -1,
        "version"    => 120,
        "status"    => '',
        "dateline"    => 1134703642,
    );
    
    $db->insert_query(TABLE_PREFIX.'templates', $boardmsg_template);
    find_replace_templatesets('header', '#<navigation>#', "{\$boardmsg}\n\t\t\t<navigation>");
}

function boardmsg_deactivate()
{
    require MYBB_ROOT.'/inc/adminfunctions_templates.php';
    global $db;
    
    $db->query("DELETE FROM ".TABLE_PREFIX."settings WHERE name IN('showboardmsg', 'boardmsg')");
    $db->query("DELETE FROM ".TABLE_PREFIX."settinggroups WHERE name='boardmsg'");
    $db->query("DELETE FROM ".TABLE_PREFIX."templates WHERE title='global_boardmsg'");
    
    find_replace_templatesets('header', '#{\$boardmsg}\n\t\t\t#', '', 0);
}

function boardmsg()
{
    global $mybb, $templates, $boardmsg;
    
    if($mybb->settings['showboardmsg'] != 'off')
    {
        $boardmessage = $mybb->settings['boardmsg'];
        eval("\$boardmsg = \"".$templates->get('global_boardmsg')."\";");
    }
}
?>
Computer helfen uns Probleme zu lösen, die wir ohne sie gar nicht hätten.
Zitieren
#4
Hast du bei den Einstellungen eingestellt, dass es eingezeigt werden soll? (ACP -> Foreneinstellungen -> Ändern -> Board Message Settings -> Enable Board Message)
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Ja der Plugin ist auch eingeschaltet.
Computer helfen uns Probleme zu lösen, die wir ohne sie gar nicht hätten.
Zitieren
#6
Die Variable ist im richtige Template und im richtigen Template-Set, das Plugin ist aktiviert und es ist bei den Einstellungen eingeschaltet? Dann fällt mir nichts mehr ein. Überprüfe nochmal alles.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#7
Ich habe jetzt nochmals den Plugin neu installiert aber im Forum ist nichts sichtbar. Obwohl ich alles gemacht habe wie hier im Forum beschrieben.

Gibts den noch ein anderer Plugin der .html code unterstützt?
Computer helfen uns Probleme zu lösen, die wir ohne sie gar nicht hätten.
Zitieren
#8
Du könntest als Alternative einfach die gewümschte Box als HTML-Code ins Template header einfügen. Wenn alles gemacht wurde was Dragon gepostet hatte habe ich auch keine Ahnung warum es nicht geht.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#9
So eine Foreninfo Box hatte ich vorhin die auch recht gut funktionierte. Das habe ich mit einem .gif Bild realisiert.

Hier der .html code:
Code:
<center>
<img src="images/myBulletin/downloadbereich.gif" alt="Newsletter" />
</center>

Ich würde aber gerne in den oben geschriebenen code eine Link erweiterung einbauen, nur die Frage ist sowas möglich. Wenn ja wie realisiere ich sowas?

Es musste dann wie folgt aussehen, und rot geschriebenes anklickbar sein:
   
Computer helfen uns Probleme zu lösen, die wir ohne sie gar nicht hätten.
Zitieren
#10
Versuchs mal so:
Code:
<div style="padding: 5px; background: #FFFF99; text-align:center; border-top: 1px solid #000000; border-bottom: 1px solid #000000;">
Dein Text hier - <a href="#" style="font-weight: bold; color: #FF0000;">Linkname</a>
</div>

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Forenansicht wie Portal Alex76 2 480 11.02.2012, 15:34
Letzter Beitrag: Alex76
  Plugin UserAgent 1.4 wird nicht mehr angezeigt Pentagon 5 1.037 17.02.2010, 13:17
Letzter Beitrag: Pentagon
  plugin wird 2 mal angezeigt Hecktro 5 1.067 19.03.2009, 14:25
Letzter Beitrag: linwinman
  Prefix Plugin wird nicht angezeigt chris14465 3 1.091 08.09.2008, 12:34
Letzter Beitrag: Michael