Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
utf-8???
#1
Ich hab mal eine Frage^^

Neuerdings fällt mir auf das utf-8 ja sehr belibet zu sein scheint, aber was hat es damit auf sich bzw. was für einen nutzen zieht man daraus?

Ich erkenne da keinen Unterschied -.-
Zitieren
#2
http://de.wikipedia.org/wiki/Utf8
Vantage-Forum: http://vantage-forum.de/
Zitieren
#3
So wie ich das sehe soll der Vorteil daran liegen jegliche Zeichen ausgeben zu können, richtig?

Konnte man des normal etwa nicht?

Ich bräuchte mal nen konkretes Beispiel xD
Was für ein Vorteil habe ich denn durch utf-8?
Soll ich dann einfach meine PHP Dateien in utf-8 speichern?
Zitieren
#4
Die Vorteile liegen darin, dass möglichst viele (wenn nicht sogar alle) Zeichen benutzt werden können. Gerade in einem mehrsprachigen Forum macht das Sinn. Da das MyBB ja mit verschiedenen Sprachpaketen ausgestattet werden kann, muss mit einem einheitlichen Encoding gearbeitet werden.

Eigentlich müssen nur das Encoding der Seite und das der Datenbank stimmen. Die Dateien können als UTF-8 abgespeichert werden, das ist aber nicht nötig.

Beispiele: ΘΦΞξλζδ℗™Ω℮ℓ№⅝∑∏↙↕⅘◊

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#5
Wie soll ich denn das encoden *neugierig bin*
Ein Beispiel wäre nett^^

Sooo:
Code:
<html>
<head>
<title>Blub</title>
<meta http-equiv='Content-Type' content='text/html; charset=utf-8'></meta>
</head>
<body>
<?php
//utf-8 codierte php file
include(blub.php);
?>
</body>
</html>
Meine datenbank ist auch auf utf-8 ausgerichtet, reichen diese Schritte?
Zitieren
#6
Sollte funktionieren, allerdings kenne ich den Code deiner Dateien ja nicht. Du kannst das Ganze auch mit dem HTML-Validator prüfen, da er einen Fehler ausgibt, wenn etwas mit dem Encoding nicht stimmt.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#7
Der W3C Validator zeigt mir keine Fehler an^^(alles immer schön Valide^^)
Zitieren
#8
hey ich habe leider ein problem

seitdem ich das übersichtsplugin installiert habe, habe ich probleme mit den umlauten...


sieht so aus

http://www.tunisdeluxe.de/index.php

weiß jemand woran es liegen kann?
Zitieren
#9
Gehe in die Einstellungen des Plugins und wechsel von htmlentities() zu htmlspecialchars().

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#10
Danke das hat funktioniert!!!


Jetzt hab ich immernoch das Problem mit dem Chat....

es kommt diese Fehlermeldung:

Warning: require_once() [function.require-once]: open_basedir restriction in effect. File(/var/www/chat/src/phpfreechat.class.php) is not within the allowed path(s): (/var/www/web214/html/:/var/www/web214/phptmp/:/var/www/web214/files/:/var/www/web214/atd/) in /var/www/web214/html/inc/plugins/pfc_mybb.php on line 499

Warning: require_once(/var/www/chat/src/phpfreechat.class.php) [function.require-once]: failed to open stream: Operation not permitted in /var/www/web214/html/inc/plugins/pfc_mybb.php on line 499

Fatal error: require_once() [function.require]: Failed opening required '/var/www/chat/src/phpfreechat.class.php' (include_path='.') in /var/www/web214/html/inc/plugins/pfc_mybb.php on line 499



habe alles genau wie es in der readme steht in die verzeichnisse kopiert
Zitieren