Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Topmargin - Margintop Einstellungen
#1
Hallo zusammen

ich bin neu hier und habe MyBB soeben mit mittlerem Zeitaufwand installiert. Abgesehen von bekannten Problem wie
>>
( Login/Logout )
und
MySQL error: 1054
Unknown column 'fid2' in 'field list'
Query: INSERT INTO mybb_userfields (ufid, fid1, fid2, fid3) VALUES ('66', '', '', '')
<<
nach Felderweiterungen läuft jetzt eigentlich alles recht ordentlich. Man muss halt von Zeit zu Zeit alle Browser-Fenster schliessen, um die neue Konfiguration "wirken zu lassen"...

Meine drei aktuelle Fragen:

Ich möchte im <BODY....> mit Topmargin/Margintop oberen Rand definieren, da ich meinen anderen Webseiten den gleichen Randabstand habe. Allerdings habe ich noch nicht herausgefunden, wo ich diese Einstellung vornehmen muss, da Aenderungen des CSS Stylesheets keinen Erfolg gebracht haben.

Ich verhindere mit einem:
<table width=99% style=\"table-layout:fixed\" .....
dass überbreite Texte meine Tables sprengen, allerdings verschwindet damit gelegentlich ein Teil einer überlangen Zeile (ohne Leerschritte) im Nirwana , mindestens bei IE Browsern. Lässt sich dieses Linebreak Problem so lösen, dass auch NICHT-PHP-Freaks wissen, wo was einzubauen ist, dass es funzt und eine Zeile ganz einfach nach xx Zeichen einen <BR> macht.

Seit einiger Zeit glaube ich festzustellen, dass mein Firefox 2.0.0.1 mit Cookies Problemen hat, auf jeden Fall kann ich mich beim installierten MyBB nicht einloggen. Mit IE6 und meinem test Mozilla 1.7.13 funzt allerdings alles bestens. Das Gleiche püassiert mir auch bei meinem Auktionsscript, aber ich weiss, dass früher alles bestens lief. Muss irgend ein Update für den Firefox gewesen sein, der alles änderte. Hat jemand Gleiches erlebt ?

Anbei beide Links für Tester.

http://www.everyauction.info/forum/index.php
http://www.everyauction.info/cgi-bin/auc...action=new

Besten Dank

Ernie
#2
Das Problem mit Firefox kann ich nicht bestätigen. Kann es einfach sein, dass du Cookies deaktiviert hast?

Wenn du den HTML-Code anpassen willst musst du in die Templates im Admin-CP -> Templates -> Ändern/Entfernen -> *Templateset* -> Ausklappen.

Dinge wie das Topmargin für den Body kannst du aber auch im Theme eingeben. Füge folgenden Code in das Feld für zusätzliches CSS in der Box "Body" in den Einstellungen deines Themes ein:
Code:
margin-top: 0px;

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#3
@ Michael
besten Dank für Deine schnelle Antwort, ich habe festgestellt, dass ich irgendwo ein Feld nicht angeklickt habe, womit das Problem Linebreak gelöst ist. Sehr gut!!

Wollte letzte Nacht noch schnell das TopMargin Problem lösen, allerdings hatte ich dann plötzlich wieder 2 Header Sektionen als Resultat und musste wohl oder übel meine Templates löschen und nochmals aufbauen, damit der zweite Header weg war. Ich nehme an, dass der Script irgendwas vom Kopfteil, wennauch nicht völlig komplet, in der SQL Datei speichert, da ich nämlich meinen Header nur einmal abgelegt habe...

Wie gesagt, PHP und SQL sind schon noch etwas neu für einen alten HTML-Knüttel mit PERL Erfahrungen!!
Da muss ich offensichtlich nochmal so richtig ran an der Speck.

Ich habe keine Ahnung weshalb mein Firefox keine Cookies mehr handled, aber es könnte auch sein, dass irgend eines meiner Sicherheitsprogramme das zusätzlich unterbindet, allerdings spielt es nur insofern eine Rolle, wenn andere Firefox User das gleiche Problem auf meiner Website haben sollten.

Noch etwas lustiges, ich musste hier im Forum irgendwo eine USER.PHP Datei herunterladen, da ich beim Neu-Anmeldevorgang einen zuvor mehrfach beschriebenen Server Fehler hatte. Ich hatte angenommen, dass dieser Update in meiner Version bereits enthalten sei, aber wahrscheinlich war dem nicht so.

Werde sehen, ob ich irgendwo noch Kleinigkeiten finde, wenn es so läuft, bin ich zufrieden. Allerdings hätte ich noch einen Wunsch, nämlich, dass eine Art "ADMIN Forenankündigung" auch für nicht registrierte und nicht eingeloggte User sichtbar wäre, denn wie soll ich einem User erklären, dass er sich einloggen soll, um was zu sehen, wen er nirgendwo etwas darüber zu lesen findet, ohne bereits eingeloggt zu sein.

Bei mir können nämlich nur eingeloggte User überhaupt etwas von den Foren sehen.

Aber vielleicht gibt es bereits so etwas wie eine Frontseiten-Info, welche nicht an bestehende Foren gebunden ist, wie das original der Fall ist. Wäre dankbar für eine kleine Hilfestellung...

Ernie