Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Ungültige Zeichen im Nutzernamen
#1
Hi, ich bin admin in einem mybb. hab letztens vergeblich versucht, einen nutzer zu aktivieren über die bearbeitungsseite eines nutzers. jedes mal, wenn ich auf "benutzer aktualisieren" geklickt hab, kam der hinweis, dass keine gültige admin-session gefunden wurde. dann hab ich testweise einfach mal einen punkt, der sich in dem nutzernamen befand, herausgenommen, siehe da, jetzt meldete das board das nicht mehr.
meine probleme also:
a) warum kann ein nutzer nichtvewendbare zeichen eingeben?
b) warum wird ein admin nicht darauf hingewiesen, wenn ein nutzer nichtverwendbare zeichen benutzt hat?
c) warum bekommt man beim aktualisieren eines nutzers mit ungültigem nutzernamen eine völlig absurde mitteilung über eine nicht vorhandene admin-session?
d) warum ist der punkt nicht erlaubt in einem nutzernamen?

vielen dank und viele grüße
Tox
#2
Hi,

Wegen der Adminsession bist du auch dauerhaft eingeloggt ? Bei mir wird diese Fehlermeldung nicht angezeigt.

Oder verwendest du Proxys oder Programme die alle 30 Sekunden deine Ip-Adresse ändern ? Dann bist du ja auch nur mit der einen Ip - Adresse eingeloggt.

Mfg Crasher und noch einen schönen Weihnachtsabend euch allen.

#3
nee nee, wie gesagt die fehlermeldung über eine nicht vorhandene admin-session kommt ausschließlich dann, wenn ich versuche, einen user, der einen punkt im nick hat, zu bearbeiten.

edit: a) das problem besteht nich nur bei nutzernamen, sondern auch in beiträgen, dann bekomm ich die fehlermeldung "ungültiges forum" o.ä.
b) und eines ist sehr merkwürdig, das problem tritt offenbar nur dann auf, wenn im text ".Ru" auftritt und noch etwas ist merkwürdig... in diesem board scheints nich aufzutreten...
#4
Hast du irgendwelche Modifikationen eingebaut, die das Problem verursachen könnten?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#5
nein, gar nicht, ich habe das board rein nach anleitung installiert und seitdem gibt es das problem...
#6
Also das kommt nur wenn du einen Benutzer mit ungültigen Zeichen bearbeiten willst.

Was willst du denn genau machen ? Willst du den Benutzernamen ändern oder diesen Benutzer löschen ?

Beides kannst du auch im Datenbankmanager (PhpMyAdmin) machen. Dazu dann mehr wenn du gesagt hast was du mit dem Benutzer machen willst.

Mfg

#7
nja, wie gesagt, das tritt im prinzip überall auf, wenn ".Ru" eingegeben wurde in einem Text, entweder im Nutzernamen beim Berbeiten eines Nutzers oder in einem Beitrag...

ich möchte weder den Bentuzernamen ändern noch möchte ich den Nutzer löschen. Dem Nutzer, bei dem mir das aufgefallen war, wollte ich einfach nur ne andere Benutzergruppe geben.
#8
ok, der thread kann geschlossen werden. offenbar liegt es, so unglaublich es klingt, an der internet-verbindung.
ich benutze privat umts vom provider vodafone. es ist nicht unbekannt, dass die dazu neigen, webseiten zu manipulieren, bevor sie gedownloadet werden. es liegt meiner meinung nach im bereich des möglichen, dass es beim upload von daten durch deren verkorkste software teilweise zu problemen kommt.
ich hab es von mehreren rechnern und mehreren browsern aus bestätigen können. nirgendwo anders tritt das problem als bei mir zu hause an sämtlichen rechnern mit sämtlichen browsern auf.

mfg, danke für die bemühungen