Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.29 veröffentlicht (30.10.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Upgrade von 1.8.5 auf 1.8.29 steckengeblieben
#1
Guten Abend in die Gemeinschaft an diesem Silvesterabend. Ich habe mich registriert, weil ich Hilfe benötige. Der Klassiker. Habe die Fehlermeldung in die Suche eingegeben und die Treffer der ersten beiden Seiten durchgesehen. Falls das Problem hier schon gelöst wurde, bin ich dankbar für einen Link und akzeptiere die Löschung.

Ich habe 2010 für eine Freizeitgruppe das SMF-Forum installiert und bin 2014 zu MyBB gewechselt, das Merging-System war zauberhaft. Bei meinem Webhost stand mir Softaculous zur Verfügung, seit Febr. 2021 nicht mehr (dafür ist er sauteuer geworden). Dazu kommt, daß ich MyBB (1.8.5) nicht mehr aktualisiert hatte und diese Nacht alte PHP-Versionen abgeschaltet werden. Ich habe nun also das entsprechende ZIP (1.8.5 zu 1.8.29) heruntergeladen und mit den neuen Dateien die alten ersetzt. Das war zeitaufwendig. Bei Aufruf von …/install/upgrade.php bekomme ich die folgende Fehlermeldung:

Zitat:Fatal error: require_once(): Failed opening required '/home/customer/www/basis-web.net/public_html/forum/inc/db_.php' (include_path='.:/usr/local/php56/pear') in /home/customer/www/basis-web.net/public_html/forum/install/upgrade.php on line 66

Ich habe ein anfängerhaftes Verständnis dafür, wie DHTML funktioniert, aber das hier geht schon in die Tiefen.

Habe alles gesichert, insofern hoffe ich inständig, daß nichts verlorengehen kann aus fast elf Jahren. Aber nun würde ich es gern wieder zum Laufen bringen.

Was muß ich tun?

Kann ich auch MyBB komplett neu installieren und an die vorhandene Datenbank anbinden? Geht dabei was verloren?

Guten Rutsch schon mal!
Zitieren
#2
Kannst du bitte prüfen, ob die Datei inc/config.php noch vorhanden ist? Diese ist eigentlich nicht in den Paketen enthalten, sollte beim Hochladen daher nicht angerührt werden.
Sollte dieses irgendwelchen Gründen fehlen, Stelle diese aus einem Backup wieder her.

Ich wünsche dir und allen anderen natürlich auch einen guten Rutsch.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Hallo StefanT, vielen Dank für die umgehende Antwort. Das hat geholfen. Ich habe die alte Datei inc/config.php wieder eingesetzt, dann lief das Upgrade. Sehr schön.

Nun ist mein Forum wieder aufrufbar, aber ich bekomme bei dem Versuch, mich einzuloggen, die Fehlermeldung 

Zitat:Falscher Autorisierungscode! Greifst du auf diese Funktion auf die übliche Weise zu? Bitte gehe zurück und versuche es erneut.

Woran könnte das liegen?

Ich habe es mit meinem Nutzernamen und mit meiner hinterlegten e-mail-Adresse versucht.

Zum Glück ist mir das Admin-CP zugänglich. Ich habe dort mein Nutzer-Paßwort erneut hinterlegt. Der Login als Nutzer funktioniert aber trotzdem nicht. Auch die Zusendung der Zugangsdaten mit „Paßwort vergessen” erfolgt nicht.
Zitieren
#4
Leider genügt es nicht, nur das Upgrade-Script laufen zu lassen, da eigenhändig geänderte Templates vom Update ausgeschlossen werden.
In deinem Fall dürfte das Login-Formular nicht auf dem aktuellen Stand sein.
Schau dir bitte mal das Template "header_welcomeblock_guest" an.
In diesem Template, aber auch in mehreren anderen befindet sich das Formular.
Es muss folgende Input-Elemente enthalten:

Code:
<input name="action" type="hidden" value="do_login" />
<input name="url" type="hidden" value="" />
<input name="quick_login" type="hidden" value="1" />
<input name="my_post_key" type="hidden" value="{$mybb->post_code}" />

Je nach Theme kann dein Login-Formular aber auch in anderen Templates stecken. Dafür müsste man aber mal dein Forum sehen können.
Bei deinem großen Versionssprung werden es viele Templates sein, die jetzt noch händisch auf den neusten Stand gebracht werden müssen.
Das betrifft nicht nur das Login-Formular.
Zitieren
#5
Eine Übersicht der seit 1.8.5 geänderten Templates (inkl. der Änderungen) kannst Du hier finden.
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#6
Vielen Dank für die wichtigen Hinweise. Dann weiß ich, was noch zu tun ist. Ich melde mich wieder.

Da wird gerade verschüttetes Wissen wieder freigelegt bei mir. Also im ACP, scheint mir, werden Templates, die der Überprüfung bedürfen, in Dunkelgrün angezeigt, richtig?
Zitieren
#7
(01.01.2022, 14:04)Der Alte schrieb: ...werden Templates, die der Überprüfung bedürfen, in Dunkelgrün angezeigt, richtig?

Nein, nicht ganz.
In grün sind alle Templates markiert, die nicht mehr den originalen MyBB-Master-Templates entsprechen, also irgendwann mal händisch geändert wurden. Das ist je nach deinen eigenen Anpassungen völlig normal.
Richtig ist aber, dass diese (grünen) Templates nicht updated werden.

Es kann also bei dir viel Handarbeit nötig sein.
Prüfe die Templates so, wie Jockl es beschrieben hat.
Es ist an der Stelle allerdings wichtig, dass du deine eigenen Änderungen in den Templates erkennst.
Die Templates einfach per se in den Originalzustand zurück zu setzen, ist nicht die Lösung.
Damit würdest du dir u.U. das gesamte Layout zerschießen.

Viel Glück! Wink
Zitieren
#8
Soviele Templates wie dunkelgrün angezeigt werden, habe ich niemals von Hand geändert. Ich kann mich an fast keine manuelle Änderung erinnern.
Zitieren
#9
Schau dir die Differenzanalyse der Templates an. Dann siehst du, was nicht original ist.
Da du hier immer noch keine Url zum Forum preisgegeben hast, kann man auch keine Rückschlüsse auf das verwendete Theme ziehen.
Somit kann ich nur vermuten und wenn du meine Vermutungen als falsch ansiehst, dann ist das eben so.
Zitieren
#10
Ich nutzte bisher 1point8 als Theme.

Aber unabhängig davon ist es eine allgemeine Frage, woher Dutzende von Differenzen kommen, wenn ich seit Erstinstallation von was auch immer von einem Theme an vielleicht drei seiner Templates manuell etwas geändert habe. Und nach der Erstinstallation des Themes (so etwa 2015) hatte ich es nicht mehr geupdatet.

Unser Forum ist hier: https://basis-web.net/forum/

So, ich habe jetzt sämtliche dunkelgrünen Templates von 1point8 auf Originalzustand gestellt. Das Layout ist nicht gerade zerschossen, aber bißchen angeschossen schon. Wurde aber auch lange nicht mehr aktualisiert. Ich werde jetzt mal ein anderes, aktuelles Theme probieren.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  upgrade von 1.8.21 auf 1.8.21: nur von 1.8.20 im Dropdownmenü möglich Humba 8 208 14.01.2022, 20:51
Letzter Beitrag: Humba