Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.29 veröffentlicht (30.10.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Cookie Talk
#1
Hallo ihr Lieben,

aber irgendwie komme ich mit meinen Cookies nicht klar. Ich probier jetzt seit 3 Wochen alle möglichen Einstellungen aus, aber entweder geht gar nix mehr oder nur temporär. Ich habe schon zig mal die Cookies im kompletten Browser und auch nur vom Forum gelöscht.

Nach einer gewissen Zeit bekomme ich im ACP "Ungültige Adminsession" angezeigt. Der Accountswitcher im Forum geht nicht, ausloggen dann auch nicht mehr. Gegen all das hilft es, wenn ich die Cookies lösche - bis es dann wieder von vorne anfängt. Das ist natürlich nicht des Rätsels Lösung 3 Mal am Tag die Cookies zu löschen.

Ich habe die Seetings und ACP-Einstellungen mit meinem anderen Forum vergleichen, sie sind identisch und trotzdem hat es irgendwo Schluckauf. Kann bitte einer mit mir schauen?

In den Settings sind die Cookie-Einstellungen so:
$settings['cookiedomain'] = ".gth.tintlinge.de";
$settings['cookiepath'] = "/";
$settings['cookieprefix'] = "";

$settings['cookiesamesiteflag'] = "1";
$settings['ip_forwarded_check'] = "0";
$settings['cookiesecureflag'] = "0";


Anbei ein Screenshot der Seiten-Details.

Ich kann es mir nicht erklären. Das Forum hat auch seine eigene Datenbank und seine eigene Subdomain.

Sieht jemand wo der Fehler liegt?

Danke & LG


Angehängte Dateien Thumbnail(s)
   
Zitieren
#2
Hi,

liegen die unterschiedlichen Foren zufällig auf dem gleichen Webspace?
Wenn ja, dann sollte für jedes Forum ein eigener Cookie-Prefix angelegt sein. Anderenfalls wirst du immer wieder Probleme bekommen. Wink
Zitieren
#3
Hey du,

ja, der Webspace ist der gleiche - halt eigenr Ordner uns so.
Wie legt man denn einen Cookie-Prefix an? Sad

LG
Zitieren
#4
ACP ---> Konfiguration --> Seiten-Details --> Cookie-Präfix

für die richtigen Cookie-Einstellungen gibt es zudem noch diese Seite:
https://docs.mybb.com/tools/cookie-settings
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#5
@ Fiji

Deine Cookie-Settings sind soweit korrekt.
Füge jedem Board noch einen eigenen Cookie-Prefix hinzu.
z.B. "top1_" und "top2_"

(13.11.2021, 08:21)Fiji schrieb: Wie legt man denn einen Cookie-Prefix an? Sad
Siehe auf deinem angehangenen Bild ganz unten.

Danach nochmal Cookies löschen und testen. Wink
Zitieren
#6
Oh, mehr nicht? Nur da im ACP? Nirgendwo sonst? Bisher sieht's gut aus, ich danke euch Zwei Heart
Zitieren
#7
alles wird über das ACP gesteuert, du musst nirgendwo in der Datenbank oder in Dateien rum schrauben Wink
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren