Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
MyBB 1.8.27 und MySQL 8.0
#1
Hallo zusammen,

unser Hoster plant ein Update der MySQL-Version von 5.7 auf 8.0
Ist MyBB für diese Version tauglich?

vielen Dank im voraus
bv64 / Lu
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#2
MySQL 8.0 gibt es seit 3 Jahren, daher sind alle Kompatibilitätsprobleme längst behoben.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
danke Smile das beruhigt doch sehr Wink

wenigstens ein Projekt, das mir nicht um die Ohren fliegt Big Grin
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#4
(04.08.2021, 11:10)bv64 schrieb: danke Smile das beruhigt doch sehr Wink

wenigstens ein Projekt, das mir nicht um die Ohren fliegt Big Grin

Warte mal ab wenn PHP 7 bald nicht mehr unterstützt wird und einige Hoster dieses deaktivieren. Es gibt zwar keine extremen Änderungen zu PHP8 (somit wäre eine Umstellung für das Team durchaus machbar) aber der Entwicklungsfortschritt welchen es seit Jahren gibt bei MyBB ist nicht dürftig sondern absolut katastrophal. Ich habe seit Ende 2018 gehofft dass etwas passiert, mittlerweile haben wir 2021… da kann sich jeder selber sein Bild zu machen aber das Projekt wie auf kurze oder lange Sicht sicherlich sterben. MyBB ist nicht mehr konkurrenzfähig und wird es so schnell auch nicht mehr.
Zitieren
#5
(04.08.2021, 19:39)itsmeJAY schrieb: Warte mal ab wenn PHP 7 bald nicht mehr unterstützt wird und einige Hoster dieses deaktivieren.

Jetzt machst du mir aber Angst Was passiert denn dann mit MyBB und PHP 8?
Ich frage nur, weil ich eines meiner Foren seit einer Weile unter PHP 8 laufen lasse. Nicht, dass es irgendwann kaputt geht.
Zitieren
#6
(04.08.2021, 20:32)doylecc schrieb:
(04.08.2021, 19:39)itsmeJAY schrieb: Warte mal ab wenn PHP 7 bald nicht mehr unterstützt wird und einige Hoster dieses deaktivieren.

Jetzt machst du mir aber Angst Was passiert denn dann mit MyBB und PHP 8?
Ich frage nur, weil ich eines meiner Foren seit einer Weile unter PHP 8 laufen lasse. Nicht, dass es irgendwann kaputt geht.

Lese ich hier Ironie raus? Toungue

Offiziell wird es noch nicht supported lt MyBB.com - und wenn wir uns ansehen wie der Prozess der Entwicklung ist, bin ich gespannt ob da überhaupt noch was passiert. Wenn dein Forum unter 8 läuft, weiss ich nicht, weshalb es offiziell als < 8 angegeben wird.

https://www.php.net/manual/de/migration8...atible.php

https://www.domaintechnik.at/handbuch/php-8.html
Zitieren
#7
Ich weiß nicht, wie du zu dieser Einschätzung kommst. MyBB 1.8.27 hatte schon umfangreiche Anpassungen für PHP 8.0 und es wurde vor der Veröffentlichung zum Testen aufgerufen. Für danach gefundene Inkompatibilitäten gibt es ebenso schon Pull-Requests, die wohl ins kommende Update einfließen werden: https://github.com/mybb/mybb/issues/4138
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#8
Habe gerade mal ein Forum von PHP7.4.19 auf PHP 8.0.6 umgestellt.
Fehlermeldung bei Aufruf der Startseite:
   
Auf Grundlage der vorstehenden Ausführungen blicke ich bzgl. MyBB jedoch unter PHP8.0 positiv in die Zukunft.

Wo ich meine funktionellen Zweifel habe, ist die Lauffähigkeit von eingebundenen PlugIns unter PHP8.0.x, da werden mri gleichfalsl Fehlermeldungen generiert. Aber da warte ich erst mal ab bzw. ist dann eine andere Baustelle.
Jammer nicht rum ...Du musst (k/m)eine Hilfe (nicht) annehmen!
MyBB: 1.8.27 | PHP: 7.4.19 | SQL: 5.7.34
Tools [Unixzeit ⇔ Realzeit] ♦ [BOM-Finder] ♦ [301] ♦ [SQL-Prefix-Changer] ♦ [USV-Rechner]
Zitieren