Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.22 veröffentlicht (31.12.19)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Themenbewerung ausschalten -> Error 403
#1
Hallo

Ich versuche gerade das Themenbewertungs System auszuschalten. Wenn ich dies in einem "Oberforum" mache (Häckchen bei "Themenbewertung erlauben" raus, dann speichern) geht es, aber ich sehe die Bewertung immer noch.
Wenn ich es in einem Forum selber mache, dann bekomme ich beim Klicken auf den Button "Forum speichern" einen Error 403 Forbidden

Was läuft oder mache ich falsch?

Grüsse
Rolf
Zitieren
#2
Das hört sich für mich nach mod-security auf Deinem Server an.
Wenn dem so ist, solltest Du dazu auch Hinweise in der Server-Error-Logs haben.
Solltest Du bei Deinem Hoster keinen Zugriff auf die Firewall haben, must Du Dich wohl oder übel an den Support wenden.
Eigentlich sollte die htaccess von MyBB die Filterengine deaktivieren, was aber offensichtlich nicht immer möglich ist.
Zitieren
#3
Dann bedeutet das, dass auf eine Datei geschrieben werden soll?
Der Check aus dem ACP zeigt ja keine Fehler
Zitieren
#4
In dem Fall wird in die Datenbank geschrieben.
Es ist nur ne Vermutung von mir. Schau Dir die Server-Log-Daten an. Dann solltest Du mehr wissen.
Die Filterregeln der Hoster sind so verschieden, dass man hier nichts verallgemeinern kann.
Zitieren
#5
Ich habe ein sehr kleines und "flaches" Forum:

https://www.rfnet.ch/forum.html

Bei den ersten 2 kann ich die Bewertung NICHT ausschalten, bei den folgenden 3 schon. Das leuchtet mir in keinster Weise ein, denn das müsste doch IMMER oder NIE gehen.

Jetzt gefunden.
Mein Hoster hat ModSecurity, irgendwie hat die bei 2 Foren geblockt, bei 3 nicht. Warum auch immer.

[Tue Feb 18 12:37:09.128548 2020] [:error] [pid 40902] [client xx.xxx.xxx.xxx:50804] [client xx.xxx.xxx.xxx] ModSecurity: Access denied with code 403 (phase 2). String match "<" at ARGS_POST:description. [file "/etc/modsecurity/02_comodo/30_Apps_OtherApps.conf"] [line "7497"] [id "242402"] [rev "1"] [msg "COMODO WAF: XSS vulnerabilities in the MyBB (aka MyBulletinBoard) before 1.8.4 (CVE-2015-2149)||forum.rfnet.ch|F|2"] [severity "CRITICAL"] [tag "CWAF"] [tag "OtherApps"] [hostname "forum.rfnet.ch"] [uri "/mybb/admin/index.php"] [unique_id "XkvMZX8AAAEAAJ-GGmAAAAAI"]

ModSec Regel ausschalten und es ging
Zitieren
#6
(18.02.2020, 13:39)rfurrer schrieb: ModSec Regel ausschalten und es ging

Sag ich doch Big Grin Toungue
Zitieren
#7
(18.02.2020, 13:43)Schnapsnase schrieb:
(18.02.2020, 13:39)rfurrer schrieb: ModSec Regel ausschalten und es ging

Sag ich doch Big Grin Toungue

Mein Hoster hat meine Seiten auf einen neuen Server migriert, mit mehr Möglichkeiten. ModSec ist eine davon, die gab es vorher noch nicht. Damit muss ich mich erstaml "anfreunden"  Confused
Zitieren
#8
Normalerweise wird über die mybb-eigene htaccess die Filterengine deaktiviert.
Code:
<IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
 </IfModule>

Entweder, Du nutzt die htaccess nicht, oder Dein Hoster findet trotzdem einen Weg, um Dich auszusperren. Wink
Zitieren
#9
Das Forum habe ich über den SW Katalog des Hoster installiert, nur noch das Deutsch Paket habe ich nachgeschoben.
Muss die htaccess selber aktiviert werden? Ich habe da nix unternommen. In welchem Verzeichnis wäre die zu finden/erstellen/aktivieren?
Zitieren
#10
Eine "vorgefertigte" htaccess liegt bereits im Root-Verzeichnis des Forums als "htaccess.txt" vor.
Umbenennen in ".htaccess" und ggf. nach Wunsch anpassen.

Mal etwas offtopic: Wenn unbedingt einen iframe, dann geht der auch mit etwas JS einigermaßen responsive zu machen, sodass keine Weißräume oder Scrollbalken entstehen. Wink
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  403 Forbidden nach Neustart Shalowain 17 2.169 05.10.2014, 21:41
Letzter Beitrag: Shalowain