Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Anmeldeprobleme
#1
Hallo zusammen,

nach der ersten Anmeldung als normaler User (Benutzer CP) bekomme ich folgende Fehlermeldung:

Warning: gmdate(): Windows does not support dates prior to midnight (00:00:00), January 1, 1970 in C:\Inetpub\wwwroot\Forum\forum\inc\functions.php on line 1062

Warning: Cannot modify header information - headers already sent by (output started at C:\Inetpub\wwwroot\Forum\forum\inc\functions.php:1062) in C:\Inetpub\wwwroot\Forum\forum\inc\functions.php on line 1076

Bitte um Abhilfe!
Danke im Voraus!

vg
balu68
#2
Hallo balu68,

Hier hast du mal die Linien 1058 bis 1062 meine functions.php

PHP-Code:
    // Versions of PHP prior to 5.2 do not support HttpOnly cookies and IE is buggy when specifying a blank domain so set the cookie manually
    
$cookie "Set-Cookie: {$name}=".urlencode($value);
    if(
$expires 0)
    {
        
$cookie .= "; expires=".gmdate('D, d-M-Y H:i:s \\G\\M\\T'$expires); 

Schau bitte mal ob das alles so da steht.

Hier nochmal die Linie 1062 einzeln.

PHP-Code:
$cookie .= "; expires=".gmdate('D, d-M-Y H:i:s \\G\\M\\T'$expires); 

MfG

#3
Das kann mehrere Gründe haben. Spontan würde ich sagen, dass die Zeit oder besser das Datum des Servers nicht stimmt. Überprüf das mal.
Ansonsten würde ich mich an den Hoster wenden, das Problem liegt nicht an der Software, sondern an der Konfiguration von Windows bzw. PHP.
Vantage-Forum: http://vantage-forum.de/
#4
Ich denke das du einen XAMPP verwendest richtig ? Hast du da PHP richtig Konfiguriert ?

MFG

#5
Erst mal großes Danke für das rege Feedback, Smile

.....also

-->der Server läuft als XAMPP
-->die Zeit wird via Braunschweiger Zeit am Sytem syncronisiert und ist im Lot
-->ich denke daher auch das es an PHP liegt, bin leider an PHP 4 gebunden
-->welche Konfigs kann und muss ich anpassen?

P.S.: Die Anmeldung geht genau 1 mal nach der Installation, dann wars das Sad
#6
Es handelt sich um einen bekannten Fehler in MyBB 1.2.1, der auf Windows-Systemen auftritt. Bitte ersetze die Datei inc/functions.php mit der angefügten Datei.


Angehängte Dateien
.php   functions.php (Größe: 85,73 KB / Downloads: 1)

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#7
Hallo Michael,

großes Danke für deine rasche Hilfe. Der Tausch der function.php war von Erfolg! Klasse!! Big Grin

Viele Grüße und ein Schönes WE

Balu68