Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.22 veröffentlicht (31.12.19)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Plugin-Schwierigkeiten nach Update auf 1.8.22
#1
Hallo ihr Lieben! 

Ich habe heute auf Mybb 1.8.22 geupgradet und hatte vorher 1.8.20 ... soweit so gut, es hat alles funktioniert, nur bei den Plugins scheitere ich gerade. Wie in eurer Anleitung beschrieben, habe ich alle vor dem Update deaktiviert. Danach konnte ich auch alle soweit wieder aktivieren, bis auf 2 Stück, bei denen im Anhang angehängte Meldung erscheint, wenn ich auf aktivieren gehe. Leider habe ich keine Ahnung was genau ich da machen soll. 

Kann mir jemand helfen? 
Das wäre super lieb!  Big Grin


Angehängte Dateien Thumbnail(s)
   
Zitieren
#2
Die Plugins verwenden ein Wort, dass von MySQL (nun) intern genutzt wird. Ohne Angabe der Plugins kann ich dir leider keinen Fix vorschlagen. Dies wäre aber besser in den Support-Threads der betroffenen Plugins aufgehoben.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Okay, also das eine Plugin funktioniert wieder, brauchte nur ne aktuellere Version. Das zweite Plugin:

Last Post (1.0.2)
PayPal - The safer, easier way to pay online!Show Last posts via the header of index and portal pages
Erstellt von Hamed & updated by Vintagedaddyo

möchte leider gar nicht mehr funktionieren, mir der oben genannten Fehlermeldung, auch nicht nachdem ich ne aktuellere Version drauf gespielt habe. Support gibt's dort glaub nicht mehr, trotzdem danke <3
Zitieren
#4
Ich bin leider derzeit nicht in der Lage Programmiercode anzusehen, aber Stefan hat doch bereits einen Tipp gegeben. Du musst doch nur einen SQL Query anpassen und das interne Wort umbennen. Eventuell muss noch im Laufe des Codes Rücksicht darauf genommen werden aber das lässt sich doch recht leicht beheben.

Nicht immer direkt aufgeben Wink
My  Plugins: See all
Zitieren
#5
(09.02.2020, 13:28)Carie Ma schrieb: Okay, also das eine Plugin funktioniert wieder, brauchte nur ne aktuellere Version. Das zweite Plugin:

Last Post (1.0.2)
PayPal - The safer, easier way to pay online!Show Last posts via the header of index and portal pages
Erstellt von Hamed & updated by Vintagedaddyo

möchte leider gar nicht mehr funktionieren, mir der oben genannten Fehlermeldung, auch nicht nachdem ich ne aktuellere Version drauf gespielt habe. Support gibt's dort glaub nicht mehr, trotzdem danke <3

Das Plugin solltes du komplett raus nehmen....es ist suboptimal programmiert bzw. überarbeitet.
Zitieren
#6
(09.02.2020, 14:15)SvePu schrieb: Das Plugin solltes du komplett raus nehmen....es ist suboptimal programmiert bzw. überarbeitet.

Darf ich fragen wieso? Hab mir den Code noch nicht angeguckt - aber was hat der Entwickler da denn gemacht? Big Grin
My  Plugins: See all
Zitieren
#7
Problematisch sind vor allem die Datenbankabfragen innerhalb einer WHILE-Schleife und die mögliche unsichere Ausgabe von DB-Einträgen mit HTML-Tags (XSS).

Auch ist die Verwendung von Inline-CSS-Styles nicht mehr zeitgemäß. Wink
Zitieren
#8
Okay, alles klar. Gibt's ein Ersatzplugin für das Erwähnte?

P.s.: Das Meiste funktioniert inzwischen wieder, danke <3
Zitieren
#9
(09.02.2020, 14:15)SvePu schrieb: Das Plugin solltes du komplett raus nehmen....es ist suboptimal programmiert bzw. überarbeitet.

Suboptimal überarbeitet? Es hat doch seinen Paypal-Button reingesetzt, was verlangst du noch mehr? Toungue
Zitieren
#10
Man muss da auch Prioritäten setzen...schließlich hat er hunderte von "seinen" Plugins & Themes aktuell zu halten. Rolleyes
Zitieren