Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.21 veröffentlicht (11.06.19)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Aktualiserung von 1.6.7 auf 1.8.21
#1
Hallo, meine Aktualisierung von 1.6.7 ist bisher gescheitert. (Mein Hoster hatte noch bis 30.11.2019 PHP 5.6 unterstützt, jetzt nur noch Version 7.)
Ich wollte noch vor der PHP-Umstellung auf MyBB 1.8.21 aktualisieren entsprechend Anleitung. Habe den entpackten Upload-Ordner (deutsch) auf den Webspace hochgeladen. Im Firefox ..../forum/install/upgrade aufgerufen. Keine sichtbare Reaktion bzw. kein neues Fenster.
..../forum/install aufgerufen. --> neues Fenster mit der Auswahl Installation oder Upgrade. Nach Upgrade wieder keine weitere Reaktion. Install führte zur Neuinstallation von 1.8.21, wobei natürlich die alten Daten weg waren.
Import des SQL-Dumps (voher erzeugt mit MyBB - 'Datenbank sichern') führt zur Fehlermeldung:
Error 1050 (42S01) at line 5: Table ..._adminlog already exists. (ist auch verständlich, da die Tabellen für 1.8.21 neu angelegt wurden)
Import des SQL-Dumps in eine neue (leere) Datenbank: ok.
Kann die neue Datenbank (mit den rückgespeicherten Daten von 1.6.7) durch einfache Änderung der Datenbank-Infos in  .../inc/config.php angesprochen werden? Das funktionierte jedoch auch nicht:
Error Type: MyBB Error (44) Error Message: MyBB was unable to load the SQL extension. Please contact the MyBB Group for support.
(wegen Inkompatibilität zwischen  1.6.7  und  1.8.21 oder nicht mehr laufendem PHP 5.6 ?? )
Ich hatte mal im MyBB-Forum gelesen, dass von 1.6.x erst mal auf die letzte 1.6.x (=1.6.18) aktualisieren soll, bevor man auf 1.8.x aktualiseren kann. Ist das noch so?
Brauchte ich dann noch unbedingt mein laufendes 1.6.7 -MyBB mit PHP 5.6  ??
Besten Dank für die Hilfe.
Zitieren
#2
(02.12.2019, 13:42)Humba schrieb: Hallo, meine Aktualisierung von 1.6.7 ist bisher gescheitert. (Mein Hoster hatte noch bis 30.11.2019 PHP 5.6 unterstützt, jetzt nur noch Version 7.)
Ich wollte noch vor der PHP-Umstellung auf MyBB 1.8.21 aktualisieren entsprechend Anleitung. Habe den entpackten Upload-Ordner (deutsch) auf den Webspace hochgeladen. Im Firefox ..../forum/install/upgrade aufgerufen. Keine sichtbare Reaktion bzw. kein neues Fenster.
Mir ist kein solches Problem bekannt. Möglicherweise waren nicht alle Dateien korrekt aktualisiert oder noch inkompatible Plugins aktiv. Hier wäre es sinnvoll gewesen das eigentliche Problem zu analysieren (z.B. Logs), anstatt ohne groß nachzudenken die Datenbank zu überschreiben.
(02.12.2019, 13:42)Humba schrieb: Kann die neue Datenbank (mit den rückgespeicherten Daten von 1.6.7) durch einfache Änderung der Datenbank-Infos in  .../inc/config.php angesprochen werden?
Die Datenbank-Konfiguration kann in der Datei inc/config.php angepasst werden. Warum dies nach dem Einspielen eines Backups nötig ist, verstehe ich allerdings nicht.
(02.12.2019, 13:42)Humba schrieb: Das funktionierte jedoch auch nicht:
Error Type: MyBB Error (44) Error Message: MyBB was unable to load the SQL extension. Please contact the MyBB Group for support.
Mit PHP 7.0 ist die schon seit PHP 5.5 als deprecated gekennzeichnete mysql-Erweiterung entfernt worden. Es wird nur noch die mysqli-Erweiterung unterstützt. Der Typ kann ebenfalls in der Konfigurations-Datei geändert werden (von "mysql" auf "mysqli").
(02.12.2019, 13:42)Humba schrieb: Ich hatte mal im MyBB-Forum gelesen, dass von 1.6.x erst mal auf die letzte 1.6.x (=1.6.18) aktualisieren soll, bevor man auf 1.8.x aktualiseren kann. Ist das noch so?
Das war meines Wissens nie so. Welchen Vorteil soll dieses Vorgehen haben?
(02.12.2019, 13:42)Humba schrieb: Brauchte ich dann noch unbedingt mein laufendes 1.6.7 -MyBB mit PHP 5.6  ??
Nötig ist das nicht, allerdings ist es ratsam mit einem funktionierenden Forum zu starten.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
danke, Stefan.
Mein Hoster hat nochmal die Nutzung von PHP 5.6 kurz verlängert. Das Forum mit dem Stand 1.6.7 ist nun zurückgespeichert und läuft. (allerdings beim Versionstest steht da: verwendete Version ist 1.6.7 neueste Version 1.8.6. -  Verbindung zum externen Server nicht möglich. später nochmal versuchen.)
MyBB 1.8.21 -Upload-Dateien hochgeladen. Dann PHP5.6-Unterstützung entfernt. ... Upgrade-Routine - Willkommen-Fenster endlich da.   1.6.7 war voreingestellt.   Weiter.  -->  Updating Database.  Weiter.    --> Performing necessary upgrade queries. Click next to continue with the upgrade process.   - Der Button "Automatically Redirecting" bleibt dauerhaft (ausgegraut) stehen.
Bei Forum-Aufruf kommt natürlich Error 43 (lock noch vorhanden). Nach lock-Entfernung: Error 42 (Upgrade noch nicht fertig).
Was am besten tun?
Zitieren
#4
Welche PHP-Version wird verwendet? Erscheint eine Fehlermeldung?

Das Upgrade kann schon einige Zeit dauern, besonders falls das Forum größer ist.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Ich habe das gerade einmal ausprobiert und den wahrscheinlichen Grund für das Problem gefunden. Bitte ersetze in den Dateien install/resources/upgrade30.php und install/resources/upgrade35.php:
Code:
$footer_extra = "<script type=\"text/javascript\">$(function() { var button = $('.submit_button'); if(button) { button.val('Automatically Redirecting...'); button.prop('disabled', true); button.css('color', '#aaa'); button.css('border-color', '#aaa'); document.forms[0].trigger('submit'); } });</script>";
mit:
Code:
$footer_extra = "<script type=\"text/javascript\">$(function() { var button = $('.submit_button'); if(button) { button.val('Automatically Redirecting...'); button.prop('disabled', true); button.css('color', '#aaa'); button.css('border-color', '#aaa'); document.forms[0].submit(); } });</script>";
Die Zeile kommt in beiden Dateien mehrfach vor.

Bug-Report: https://community.mybb.com/thread-225596.html
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#6
danke.
PHP 7.2, nur wenn MyBB 1.6.7 laufen soll, wird über .htaccess 5.6 aktiviert.
Beim Hägen kommt keinerlei Meldung oder sonst etwas. Ich habe über 4 Stunden gewartet. Es ist ein recht kleines Forum.
Im Augenblick habe ich die rückgespeicherte Version noch nicht wieder am Laufen wegen: MyBB-Error 44 (unable to load the SQL-Extension). SQL-Dump-Import wieder auf neue DB und in der config.php den Namen in 'database' und 'username' angepaßt.
Wenn es wieder läuft, probierere ich es mit den geänderten upgrade Scripts.
Zitieren
#7
Hallo,
mit den geänderten Scripts in upgrade30 unnd upgrade35 ist nun alles durchgelaufen. Ich habe jetzt erfreulicherweise 1.8.21. Prima.  -  aber: im Admin wird mir angezeigt: PHP 5.6.40 (und SQL-Engine 5.6.44).
Offensichtlich lief das ganze Upgrade mit php5.6 erfolgreich durch (darf das überhaupt sein? Mein Hoster hatte den ganzen Webspace zur Verlängerung der php5.6-Nutzung auf php5.6 eingestellt).
Die MyBB-Admin-Tools zeigen bei PHP-Info auch die 5.6-ini von meinem Hoster an.
Wenn ich .htaccess (mit er Einstellung auf php5.6) entferne, - wenn also PHP 7.3 genutzt wird - geht das Forum nicht mehr (Error 44: Error Message: MyBB was unable to load the SQL extension.) Meine Datenbank bietet 2 Einstellungen: MySQL oder Postgres-SQL. 
Was ist zu ändern?  Vielen Dank.
Zitieren
#8
Das habe ich bereits in der ersten Antwort beantwortet: Wink
(02.12.2019, 17:52)StefanT schrieb: Mit PHP 7.0 ist die schon seit PHP 5.5 als deprecated gekennzeichnete mysql-Erweiterung entfernt worden. Es wird nur noch die mysqli-Erweiterung unterstützt. Der Typ kann ebenfalls in der Konfigurations-Datei geändert werden (von "mysql" auf "mysqli").
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#9
Hallo Stefan,
nun habe ich begriffen, dass ich nur in meinem Forum die .../inc/config.php die Database-Zeile auf mysqli zu ändern brauche (ich suchte erst in der Datenbank selbst).
Dank Deiner guten und raschen Hilfe ist nun alles bestens und in der MyBB-Admin-Übersicht stehen die Versionen:
MyBB: 1.8.21
PHP: 7.3.11
SQL-Engine: MySQLi 5.6.44
Zitieren