Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Probleme beim Login im Forum und ACP
#1
Hallo liebe MyBB Gemeinde,



habe folgendes Problem:



Ich habe mein Forum auf eine neue Domain auf dem gleichen Server umgezogen. Hierfür habe ich einen Unterordner auf dem Server erstellt und die neue Domain dahin umgeleitet. 



Die Datenbank habe ich um sie vom "alten" Forum zu trennen gesichert und in eine neue DB importiert via PHPmyadmin und alle Verknüpfungen in der inc/config.php angepasst.



Die Foensoftware habe ich von 1.8.12 auf 1.8.21 aktualisiert.



In der inc/settings.php und inc/config.php habe ich alles nach den hier gefundenen Anleitungen gemacht.

Ausserdem habe ich in der DB die Cookieeinstellungen nach diversen Anleitungen hier und auf der englischen Webseite richtig gestellt.



Browsercache wurde mehrfach geleert.



Dennoch kann ich mich weder im neuen Forum einloggen noch im ACP.

Im Forum kommt die Meldung "Falscher Autorisierungscode! Greifst du auf diese Funktion auf die übliche Weise zu? Bitte gehe zurück und versuche es erneut."



Im ACP kann ich mich anmelden, aber sobald ich etwas anklicke kommt wieder die Loginmaske.



Ich bin so langsam ratlos, warum ich nicht in das neue Forum komme und was ich noch machen könnte.

Kann es daran liegen, dass beide Foren auf dem seben Server liegen?



URLs sind übrigens:



Altes Forum: gardasee-forum.com (MyBB 1.8.12)



Neues Forum: gardasee-portal.eu/forum (MyBB 1.8.21)



Ich würde mich über Hilfe bei meinem Problem freuen.
Mit besten Grüßen,

Stefan
Zitieren
#2
Hallo Stefano,

hast du auch alle Templates auf den neuesten Stand gebracht beim Update? Stichwort "Finde aktualisierte Templates". Hier noch mal ein Link speziell für deine Fehlermeldung: https://www.mybb.de/forum/thread-35757-p...#pid235089
Cheers
Zitieren
#3
Dem ersten Anschein nach liegt es daran, dass Dein Board Cookies nur über https setzt, dein Board aber auf http läuft.
Ändere in der settings.php wie folgt:
Code:
$settings['cookieSecureFlag '] = "0";
Das sollte erstmal das Login-Problem lösen.

Sollten auf dem Server beide Boards aktiv bleiben, so müssen künftig bei beiden unterschiedliche Cookie-Präfixe gesetzt werden.

Edit:
"The Incredible" hat recht...Die Templates sind nach dem Update auch nicht aktualisiert worden!
Zitieren
#4
Hallo,

ich kann die Templates nicht auf den neuesten Stand bringen, da ich mich nicht im Admin CP einloggen kann.
Oder gibt es dafür evtl. einen anderen Weg?

Wenn ich mich im ACP einlogge komme ich auf die "Startseite", sobald ich aber einen Link anklicke kommt wieder die Anmeldemaske vom ACP, wo ich mich dann aber nicht erneut einloggen kann.

(18.10.2019, 09:53)Schnapsnase schrieb: Dem ersten Anschein nach liegt es daran, dass Dein Board Cookies nur über https setzt, dein Board aber auf http läuft.
Ändere in der settings.php wie folgt:
Code:
$settings['cookieSecureFlag '] = "0";
Das sollte erstmal das Login-Problem lösen.

Sollten auf dem Server beide Boards aktiv bleiben, so müssen künftig bei beiden unterschiedliche Cookie-Präfixe gesetzt werden.

Das habe ich nach langem Nachlesen auf 0 geändert. Leider ohne Erfolg. Sollte ich es mal mit https versuchen vielleicht? Ein SSL Zertifikat wäre demnächst wieder vorhanden.

Das alte Board soll Ende des Jahres abgeschalten werden.
Mit besten Grüßen,

Stefan
Zitieren
#5
(18.10.2019, 09:54)Stefano schrieb: Das habe ich nach langem Nachlesen auf 0 geändert. Leider ohne Erfolg.

Nachdem, was ich im Quellcode sehe, hast Du das nicht getan...
Zitieren
#6
(18.10.2019, 10:05)Schnapsnase schrieb:
(18.10.2019, 09:54)Stefano schrieb: Das habe ich nach langem Nachlesen auf 0 geändert. Leider ohne Erfolg.

Nachdem, was ich im Quellcode sehe, hast Du das nicht getan...

Ok, dann werde ich das nochmal ändern heute Abend und gebe Bescheid, ob das mein Problem war.

Ich bedanke mich schonmal für die schnelle Hilfe.
Mit besten Grüßen,

Stefan
Zitieren
#7
bitte nach der Änderung in der inc/settings.php und erfolgreichem Login im ACP die Änderung auch unbedingt im ACP unter

Konfiguration --> Seiten-Details --> Cookies nur über HTTPS --> Nein

setzen und abspeichern, damit das auch in der Datenbank korrekt ist und die settings.php nicht wieder mit dem falschen Wert überschrieben wird, sobald du in der Konfiguratiion im ACP etwas speicherst.
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#8
@bv64
richtiiiig, die kleine Zusatzinfo hatte ich vergessen - danke Wink
Zitieren
#9
gerne doch Wink
Diese Info sollte man wirklich immer direkt anhängen, wenn man manuell an der inc/settings.php Änderungsvorschläge macht
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#10
Hallo zusammen,

dank eurer Hilfe habe ich meine Probleme lösen können.

Vielen Dank nochmal für die schnelle und unkomplizierte Hilfe!
Mit besten Grüßen,

Stefan
Zitieren