Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Domainumleitung und Cookies
#1
Question 
Hallo Forum,

ich habe hier eine etwas "besondere Konstellation" vor und wollte fragen, ob das überhaupt möglich ist?

Also:

Gegeben habe ich eine ganz "normale" Domain, worauf eine Umleitung geschaltet ist. Diese ist als Proxy realisiert, damit das Umleitungsziel nicht in der Adresszeile des Browsers sichtbar wird. Darüber möchte ich das Forum direkt aufrufen können.

Auf der "Zielseite" habe ich eine DynDNS Domain, und dort läuft das Forum
a) auf einem anderen Port und
b) in einem Unterordner forum

Das Ganze ist zur Zeit nur als Probebetrieb gedacht, würde aber einigen Komfort mehr bieten.

Ich mache das mal am Beispiel fest:
irgendein-forum.de -> forum.dyndns.org:47859/forum

Ich habe mich schon mal mit dem Boardnamen, dem Cookiepfad und der Cookiedomain beschäftigt, aber "nur" soweit zum Laufen bekommen, dass sich normale Benutzer anmelden konnten, aber ins ACP kam ich nicht mehr rein, weil mir dort immer wieder das Verzeichnis "forum" mit eingestellt wurde.

Also, auf obiges Beispiel bezogen:
anstatt: irgendein-forum.de/admin
erhalte ich: irgendein-forum.de/forum/admin
und das resultiert natürlich in einem 404 Fehler Sad

Geht das überhaupt? Bitte keine Diskussion, ob das sinnvoll ist oder nicht, ich möchte nur wissen, ob das technisch so funktioniert, und wenn ja, wie.

"Zur Not" kann ich die Umleitung natürlich als "reine Weiterleitung" machen, dann ist das Problem vom Tisch. Aber die Domain wird halt auch überschrieben.

Danke für's Nachgrübeln.

Gruß und schönes Wochenende

Rainer
Zitieren
#2
Was hast Du denn bei "Url zum Forum", "Cookie-Domain" und "Cookie-Pfad" hinterlegt?
Hier wird wohl der Fehler zu suchen sein.
Zitieren
#3
(27.07.2019, 13:55)Schnapsnase schrieb: Was hast Du denn bei "Url zum Forum", "Cookie-Domain" und "Cookie-Pfad" hinterlegt?
Hier wird wohl der Fehler zu suchen sein.

Ich hatte es probiert mit Folgendem:

URL zum Forum: http://irgendein-forum.de

Cookie-Domain: .irgendein-forum.de
Cookie-Pfad: /

Anstelle von / beim Cookie-Pfad hatte ich glaube ich auch schon /forum/ probiert. Das war es aber irgendwie alles nicht Sad

Ich schöpfe jetzt allerdings Hoffnung, dass es prinzipiell funktioniert, sonst hättest Du wohl nicht gefragt.
Schon einmal vielen Dank dafür.

Die Einstellungen hatte ich sowohl in der settings.php als auch in der Datenbank in der Tabelle mybb_settings hinterlegt. Ich hatte ja keinen Zugang mehr zum ACP.

Die benutzte Forumsversion ist übrigens die 1.8.21

Gruß Rainer
Zitieren
#4
Ich hoffe, ich hab Deine Problematik auch richtig verstanden......

Wenn Deine Domain "http://example.dyndns.org:47859/forum" mit dem Webspace verbunden ist und dort auch MyBB liegt, dann kann die Home-Url des Forums nicht "http://example-forum.de" sein.
Wie sollen denn Mybb-interne Url-Links dann weitergeleitet werden, wenn dies nicht explizit definiert ist?
Zitieren
#5
(27.07.2019, 17:06)Schnapsnase schrieb: Ich hoffe, ich hab Deine Problematik auch richtig verstanden......

Wenn Deine Domain "http://example.dyndns.org:47859/forum" mit dem Webspace verbunden ist und dort auch MyBB liegt, dann kann die Home-Url des Forums nicht "http://example-forum.de" sein.
Wie sollen denn Mybb-interne Url-Links dann weitergeleitet werden, wenn dies nicht explizit definiert ist?

Ich dachte, das würde dann mit der Umleitung passieren, da ja die Umleitung in dem Falle wieder auf
http://example.dynds.org:47859/forum zeigt.

War wohl falsch gedacht Sad

Funktionieren tut es zur Zeit so:
Home-URL: http://example.dyndns.org:47859/forum
Cookie-Domain: .example.dyndns.org
Cookie-Pfad: /forum/

Das führt allerdings dazu, dass beim Einloggen über die Weiterleitung ein Fehler passiert.
Code:
Falscher Autorisierungscode! Greifst du auf diese Funktion auf die übliche Weise zu? Bitte gehe zurück und versuche es erneut.

Danach steht die ursprüngliche dyndns Adresse wieder in der Adresszeile, und danach geht es wieder. Ist aber ja nicht Sinn der Sache gewesen. Dann brauche ich die Proxyfunktion nicht und kann auch "normal" weiterleiten.
Zitieren
#6
Hast du die diversen Hinweise in den Themen " Falscher Autorisierungscode" gelesen und ALLE login- templates entsprechend angepasst?
Sorry, hab nur das Tablet hier und da ist meine Linksammlung zu den Standardproblemen nicht drauf
Tipp: Ankündigungsthema zur 1.8.21
schönen Gruß
bv64 / Lu

kein Support per PN, Mail, Messenger etc.
still alive - aus gesundheitlichen Gründen aktuell nur sehr sporadisch aktiv
Zitieren
#7
(27.07.2019, 12:53)dora71 schrieb: Also, auf obiges Beispiel bezogen:
anstatt: irgendein-forum.de/admin
erhalte ich: irgendein-forum.de/forum/admin
und das resultiert natürlich in einem 404 Fehler Sad
Das MyBB verlässt sich auf $_SERVER-Variablen, die unter anderem verschiedene Information zur aufgerufenen URL enthalten. Aufgrund der ungewöhnlichen Funktionsweise des Proxies wird die Variable wohl stattdessen mit den "falschen" Daten gefüttert.
(27.07.2019, 18:09)dora71 schrieb: Das führt allerdings dazu, dass beim Einloggen über die Weiterleitung ein Fehler passiert.
Code:
Falscher Autorisierungscode! Greifst du auf diese Funktion auf die übliche Weise zu? Bitte gehe zurück und versuche es erneut.
Das passiert, weil aufgrund der abweichenden Domain kein Session-Cookie gesetzt werden kann.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren