Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
URL im Header
#1
Hallo, ich habe gerade entdeckt das ich eine seltsame Zeile im Header habe und weiss nicht seit wann.

PHP-Code:
src="https://www.koronaforum.de/jscripts/thread.js?ver=1821"

Seltsamerweise erscheint die Zeile immer nur in den Beiträgen und nicht auf der Übersicht.


Hier nicht
https://www.koronaforum.de/Kassenforum-A...ormationen
https://www.koronaforum.de/Kassenforum-K...ease-Notes

Hier erscheint sie
https://www.koronaforum.de/POS-Kasse-Rel...-PALM-TREE

   

EDIT: Es liegt wohl an Google SEO (1.8.3), wenn ich das Plugin deaktiviere dann ist die Zeile weg.
Ich habe mehrfach die Konfiguration und auch die Einträge in der .htaccess überprüft, das scheint alles zu passen.
Ich finde den Fehler nicht.
Zitieren
#2
Wahrscheinlich ist im Template "showthread" irgendein Fehler. Möglicherweise hast du bei einem Update dieses falsch aktualisiert. Der eingeblendete Code ist jedenfalls unvollständig.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
(15.07.2019, 09:31)StefanT schrieb: Wahrscheinlich ist im Template "showthread" irgendein Fehler. Möglicherweise hast du bei einem Update dieses falsch aktualisiert. Der eingeblendete Code ist jedenfalls unvollständig.

Daran habe ich nichts geändert.

Code:
<html>
<head>
<title>{$threadprefix['prefix']} {$thread['subject']} - {$lang->send_thread}</title>
{$headerinclude}
</head>
<body>
{$header}
{$errors}
<form action="sendthread.php" method="post">
<input type="hidden" name="my_post_key" value="{$mybb->post_code}" />
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<tr>
<td colspan="2" width="100%" class="thead"><strong>{$lang->send_thread}</strong></td>
</tr>
{$from_email}
<tr>
<td width="40%" class="trow1"><strong>{$lang->recipient}</strong><br /><span class="smalltext">{$lang->recipient_note}</span></td>
<td width="60%" class="trow1"><input type="text" class="textbox" size="50" name="email" value="{$email}" /></td>
</tr>
<tr>
<td width="40%" class="trow2"><strong>{$lang->subject}</strong></td>
<td width="60%" class="trow2"><input type="text" class="textbox" size="50" name="subject" value="{$subject}" /></td>
</tr>
<tr>
<td valign="top" width="40%" class="trow1"><strong>{$lang->message}</strong></td>
<td width="60%" class="trow1"><textarea cols="50" rows="10" name="message">{$message}</textarea></td>
</tr>
{$captcha}
</table>
<br />
<input type="hidden" name="action" value="do_sendtofriend" />
<input type="hidden" name="tid" value="{$tid}" />
<div align="center"><input type="submit" class="button" value="{$lang->send_thread}" /></div>
</form>
{$footer}
</body>
</html>
Zitieren
#4
Du hast das falsche Template (sendthread) erwischt. Wink 
Poste bitte den Inhalt des Template "showthread" - zu finden in der Gruppe "Show Thread Templates".
Zitieren
#5
(15.07.2019, 12:04)Schnapsnase schrieb: Du hast das falsche Template (sendthread) erwischt. Wink 
Poste bitte den Inhalt des Template "showthread" - zu finden in der Gruppe "Show Thread Templates".

Hoplla

Code:
<html>
<head>
<title>{$thread['subject']}</title>
{$headerinclude}
<script type="text/javascript">
<!--
var quickdelete_confirm = "{$lang->quickdelete_confirm}";
var quickrestore_confirm = "{$lang->quickrestore_confirm}";
var allowEditReason = "{$mybb->settings['alloweditreason']}";
lang.save_changes = "{$lang->save_changes}";
lang.cancel_edit = "{$lang->cancel_edit}";
lang.quick_edit_update_error = "{$lang->quick_edit_update_error}";
lang.quick_reply_post_error = "{$lang->quick_reply_post_error}";
lang.quick_delete_error = "{$lang->quick_delete_error}";
lang.quick_delete_success = "{$lang->quick_delete_success}";
lang.quick_delete_thread_success = "{$lang->quick_delete_thread_success}";
lang.quick_restore_error = "{$lang->quick_restore_error}";
lang.quick_restore_success = "{$lang->quick_restore_success}";
lang.editreason = "{$lang->postbit_editreason}";
lang.post_deleted_error = "{$lang->post_deleted_error}";
lang.softdelete_thread = "{$lang->soft_delete_thread}";
lang.restore_thread = "{$lang->restore_thread}";
// -->
</script>
<!-- jeditable (jquery) -->
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/report.js?ver=1820"></script>
<script src="{$mybb->asset_url}/jscripts/jeditable/jeditable.min.js"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/thread.js?ver=1820"></script>
<script type="text/javascript" src="{$mybb->settings['bburl']}/jscripts/thankyoulike.min.js"></script>
<script type="text/javascript">
<!--
var tylEnabled = "{$mybb->settings['g33k_thankyoulike_enabled']}";
var tylDisplayGrowl = "{$mybb->settings['g33k_thankyoulike_displaygrowl']}";
var tylCollapsible = "{$mybb->settings['g33k_thankyoulike_collapsible']}";
var tylUser = "{$mybb->user['uid']}";
var tylSend = "{$lang->tyl_send}";
var tylRemove = "{$lang->tyl_remove}";
// -->
</script>src="{$mybb->asset_url}/jscripts/thread.js?ver=1821"></script>
</head>
<body>
{$header}
{$threadnotesbox}
{$pollbox}
<div class="float_left">
{$multipage}
</div>
<div class="float_right">
{$newreply}
</div>
{$ratethread}
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder tfixed clear">
<tr>
<td class="thead">
<div class="float_right">
<span class="smalltext"><strong><a href="javascript:void(0)" id="thread_modes">{$lang->thread_modes}</a>{$threadnoteslink}</strong></span>
</div>
<div>
<strong>{$thread['displayprefix']}{$thread['subject']}</strong>
</div>
</td>
</tr>
<tr><td id="posts_container">
<div id="posts">
{$posts}
</div>
</td></tr>
<tr>
<td class="tfoot">
{$search_thread}
<div>
<strong>&laquo; <a href="{$next_oldest_link}">{$lang->next_oldest}</a> | <a href="{$next_newest_link}">{$lang->next_newest}</a> &raquo;</strong>
</div>
</td>
</tr>
</table>
<div class="float_left">
{$multipage}
</div>
<div style="padding-top: 4px;" class="float_right">
{$newreply}
</div>
<br class="clear" />
{$quickreply}
{$threadexbox}
{$similarthreads}
<br />
<div class="float_left">
<ul class="thread_tools">
{$printthread}
{$sendthread}
{$addremovesubscription}
{$addpoll}
</ul>
</div>

<div class="float_right" style="text-align: right;">
{$moderationoptions}
{$forumjump}
</div>
<br class="clear" />
{$usersbrowsing}
{$footer}
<div id="thread_modes_popup" class="popup_menu" style="display: none;"><div class="popup_item_container"><a href="showthread.php?mode=linear&amp;tid={$tid}&amp;pid={$pid}#pid{$pid}" class="popup_item">{$lang->linear}</a></div><div class="popup_item_container"><a href="showthread.php?mode=threaded&amp;tid={$tid}&amp;pid={$pid}#pid{$pid}" class="popup_item">{$lang->threaded}</a></div></div>
<script type="text/javascript">
// <!--
if(use_xmlhttprequest == "1")
{
$("#thread_modes").popupMenu();
}
// -->
</script>
<script type="text/javascript">
var thread_deleted = "{$thread_deleted}";
if(thread_deleted == "1")
{
$("#quick_reply_form, .new_reply_button, .thread_tools, .inline_rating").hide();
$("#moderator_options_selector option.option_mirage").attr("disabled","disabled");
}
</script>
</body>
</html>

EDIT: Ich habe den Fehler, aber ich glaube ich habe das nicht angepasst!
</script>src="{$mybb->asset_url}/jscripts/thread.js?ver=1821"></script>
</...
Zitieren
#6
Genau. Lösche diese Zeile komplett.
Wie die dahin kommt, kannst nur Du wissen... Big Grin
Zitieren
#7
(15.07.2019, 12:17)Schnapsnase schrieb: Genau. Lösche diese Zeile komplett.
Wie die dahin kommt, kannst nur Du wissen... Big Grin
Komplett löschen? Sicher? Hat die nicht einen Grund? Kann es sein das die durch (für)das Plugin Google SEO eingefügt wurde?
https://www.mybb.de/erweiterungen/18x/pl...ogle-seo2/
Zitieren
#8
Lösche diese Zeile. Es kann nichts passieren zumal der Script auch noch mit einem End-Tag startet, was letztlich den Fehler verursacht. Dieser script wird bereits weiter oben ausgeführt. Siehe:
Code:
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/thread.js?ver=1820"></script>
Was das SEO-Plugin damit zu tun hat, weiß ich nicht.
Sichere den Inhalt des Templates und dann lösche. Wink
Zitieren
#9
Vielleicht durch irgendein Plugin welches bei Deinstallation die Templates nicht korrekt (zurück) aktualisierte.
Zitieren
#10
(15.07.2019, 12:27)Schnapsnase schrieb: Lösche diese Zeile. Es kann nichts passieren zumal der Script auch noch mit einem End-Tag startet, was letztlich den Fehler verursacht. Dieser script wird bereits weiter oben ausgeführt. Siehe:
Code:
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/thread.js?ver=1820"></script>
Was das SEO-Plugin damit zu tun hat, weiß ich nicht.
Sichere den Inhalt des Templates und dann lösche. Wink

OK, da war dann noch ein Fehler..

<script type="text/javascript"> fehlte dan das </script> von der überflüssigen Zeile.
Ich habe die Zeile nun gelöscht und das </script> ergänzt.
Zitieren