Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.27 veröffentlicht (22.06.21)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Umzug 1.6.x auf 1.8.x und viele Fragen und Probleme
#1
Hallo,
 
ich habe ein riesengroßes Problem: seit 5 Jahren läuft mein Forum rund. Nach langer intensiver Arbeit hatte ich relativ schnell mein Traumforum gebastelt und deswegen scheute ich die Umstellung auf 1.8.x. Das war lange kein Problem. Mein webanbieter unterstützte das PHP Script für 1.6.x, Fehler gab es keine mehr, rumbasteln musste ich auch nicht mehr und die Komfortzone wollte ich nicht verlassen.

Jetzt aber zwingt mich mein Webspace-Anbieter dazu Sad, weil mein PHP veraltet ist. Ich muss umstellen auf 7.1. oder 7.2., außer ich zahle im Monat 8 Euro für den regelmäßigen Sicherheitscheck des alten Scripts. Für ein Hobby, das nichts einbringt, ein bisschen zu viel des guten. Also muss ich jetzt aktiv werden und bis zum 1.3. alles über die Bühne gebracht haben. Allerdings bin ich seit über 3 Jahren nicht mehr am Basteln gewesen und ziemlich raus aus der Materie. Auch habe ich relativ wenig Zeit für ein komplett neues Aufziehen, falls meine Vorgänge ins Nirwana führen. Auch beim Upgrade stellen sich mir viele Fragen, da ich sehr, sehr, sehr viel selbstgestrickt habe. Und bei meinen ganzen Suchen hier im Forum habe ich so vieles gelesen, dass mir ganz Angst und Bang um meine Optimierungen  wird.

Gestern habe ich deswegen an ein paar Ideen herumgespielt, aber ich weiß gar nicht so recht wo ich anfangen soll. Ich habe ständig das Gefühl ich mache irgendwo einen Denkfehler bzw. denke zu kompliziert.


Bestimmt ist ein upgrade die einfachste Variante, aber natürlich möchte ich mich vorher mit Backups auskennen, falls ich mir das Forum  zerschieße. Also habe ich gestern mit Üben angefangen. Aber hier gab es schon massiv Probleme:

- ich habe auf meinem Server ein "testforum" eingerichtet mit einer eigenen Datenbank, nennen wir sie einfach mal xyz69. 
- In den dazugehörigen Ordner habe ich die aktuellste Version von 1.8.x installiert und erfolgreich eingerichtet. 

- Anschließend habe ich über meinen Webanbieter mit phpMyAdmin ein Backup der Datenbank gemacht, in der sich das aktuelle Forum befindet, nennen wir sie xyz50, über Exportieren erstellt. 
- Hierfür habe ich "angepasst" ausgewählt, einen eigenen Dateinamen vergeben, Datei & Struktur ausgewählt und nach einem Rat hier im Forum einen Haken bei "keine der beiden obigen Optionen verwenden" gesetzt, da ich das Backup über bigdump einspielen muss und man das in einem Beitrag erwähnt hatte.
-Bis jetzt alles gut.
- Nach der Anleitung von bigdump habe ich die Datei um hostnamen, PW usw. ergänzt, die Dateien wie beschrieben auf meinen Server hochgeladen, bigdump gestartet - nichts ging. Der Fehler kam prompt, nämlich dass er keine Datenbank xyz50 in xyz69 erstellen kann.
- Nach der Suchfunktion hier erfuhr ich die Zeile im Backup, die ich löschen musste, um diesen Fehler zu umgehen. 
- Danach startete ich wieder Bigdump. Dieses Mal machte er Probleme, weil die Datenbanken schon alle vorhanden waren und er diese nicht erstellen könnte.
- Wieder Suchfunktion bemüht, danach in der neuen Datenbank xyz69 alle Daten mit mybb_ gelöscht, bigdump gestartet und es funktionierte.
- Als nächstes testforum aufgerufen. Das Forum mit seinen Tabellenstrukturen und Beschriftungen waren da, aber leider ohne die Einträge darin, auch meine angemeldeten User fehlten. Was lief falsch?
- Wäre ja schade wenn ich ein upgrade machen würde und etwas ging schief und alle Postings wären weg?

Wenn ich mit so einem testforum arbeite ist das ja quasi ein simulierter Umzug wie zwischen zwei verschiedenen Servern oder webspace Anbietern? Müsste ich dann mit so einem Backup nicht auch meine angemeldeten User mitnehmen können? Auch Design und veränderte Templates? Denn wenn ich eine Kopie über ftp auf Festplatte ziehe und diese Daten eins zu eins ins Testforum ziehe, ist zwar alles da, Inhalt, Design usw, aber ich übernehme ja wieder Altstrukturen vom 1.6.x und vor allem die Verlinkung führt dann ständig auf das alte Forum, anstatt auf das Testforum?

Oder ist da alles unerheblich für mich, wenn ich einfach das Backup von xyz50 mache und xyz50 upgrade auf 1.8.X und bei Fehlern einfach das Backup xyz50 einspiele? Dann dürfte er ja quasi die Fehlermeldung mit den fehlenden Rechten zum erstellen gar nicht bringen?
 
Und die letzte Frage fürs erste – wenn ich von 1.6.x auf 1.8.x ziehe – nehme ich dann die Upgrade-Datei zum installieren und gehe nach der Anleitung hier vor https://www.mybb.de/doku/installationakt...lisierung/ oder gibt es noch einen anderen Beitrag der hilfreich wäre?

Schon einmal vielen lieben Dank an alle, die bis hier her gelesen haben Smile

LG


 
Zitieren
#2
Habe gerade eben noch einmal versucht, dass Forum als testforum laufen zu lassen
https://www.buffymagazin.de/CV/

Hatte schon ein neues Theme installiert gehabt (Alpha gaming für 1.8), nach dem eingespielten Backup ist das theme jedoch überschrieben worden und ich kann mich jetzt nicht mehr anmelden, nachdem ich per bigdump das Update eingespielt habe.

Es kommt immer ein "Falscher Autorisierungscode! Greifen Sie auf diese Funktion auf die übliche Weise zu? Bitte gehen Sie zurück und versuchen Sie es erneut."
Zitieren
#3
Es gab mit den letzten Updates einige Änderungen an den Templates. Bei einem Theme, das über 4 Jahre nicht mehr aktualisiert wurde, sind diese nicht enthalten und müssen manuell nachgetragen werden.
Die nötigen Änderungen werden in unseren Ankündigungen erwähnt und sind in der Doku aufgeführt: https://www.mybb.de/doku/sonstiges/geaen...templates/
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#4
Jap, bis dahin hab ich mich inzwischen durchgegraben, sogar die backups laufen jetzt und die testforen.

Ich bin mir jetzt nur unsicher, wie ich vorgehen soll - reicht es wenn ich nach der Anleitung "upgrade" vom neusten Update vorgehe und anschließend die Anleitung für die aktualisierten Templates durchgehe, oder muss ich, eben weil das System so alt ist, irgendetwas anders machen? Schrittweise upgraden oder die neuste Version frisch installieren?
Zitieren
#5
Bei einem Upgrade über so viele Versionen werden dir vermutlich mehrere hundert Templates zum manuellen Aktualisieren angezeigt. Auch an den Stylesheets müssen zahlreiche Änderungen vorgenommen werden. Einfacher wäre es ein aktuelles Theme zu installieren.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#6
Ja das hab ich auch vor und werde dann nach und nach die gewünschten Optimierungen rekonstruieren. Aber generell ist die Anleitung zum Upgrade erst einmal meine Anlaufsstelle? Danach ein neues Theme installieren und hoffen dass alles gut wird Wink
Zitieren
#7
Korrekt. Einige Anmerkungen zum Upgrade findest du auch in den Ankündigungen: https://www.mybb.de/forum/thread-30264-p...#pid203008
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#8
Mir ist die upgarde-Geschichte gerade hier stehen geblieben:

Updating Database
Performing necessary upgrade queries...
Language onlinetodaylang (/homepages/2/d499415422/htdocs/Forum/inc/languages/onlinetodaylang) is not installed


Ist damit das upgrade schief gelaufen, oder kann ich an dieser Stelle noch etwas tun?
Zitieren
#9
Hast du vor dem Upgrade alle Plugins deaktiviert?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#10
Ja, sind alle ausgeschaltet. Ich hab einfach mal selbst nachgesehen. Dieses onlinetodaylang war im Forumsordner auf dem Server abgelegt, ich hab es rausgelöscht und siehe da, das upgrade lief weiter.. uff Smile

Ich habe aber noch eine Verständnisfrage: Wurden mit dem Upgrade automatisch alle Templates zurückgesetzt (also alle von Default und dem runtergeladenen Style Alpha Gaming), so dass sie auf dem aktuellen Stand sind, bis auf die Abänderungen die man wie hier angegeben: https://www.mybb.de/forum/thread-35911-p...#pid235879 von Hand vornehmen muss?

Oder muss ich jedes Template, das unter "Finde aktualisierte Templates" angezeigt wird von Hand zurücksetzen? Bzw. birgt das Weiterverwenden vom alten Alpha Gaming sowieso Probleme, so dass ich mir lieber die Mühe machen sollte, alles auf Alpha Gaming 2 umzustellen und meine Optimierungen da wieder vornehme?
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Update 1.6x > aktuelle 1.8x =viele Probleme Lippi 12 1.910 22.11.2014, 14:43
Letzter Beitrag: Lippi