Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Umlautprobleme
#1
Hallo liebe mybb Community.

Ich habe heute mein mybb Forum von meinem alten Server auf den neuen verschoben.
Nun habe ich ein kleines Problem. Sämtliche Umlaute funktionieren nicht mehr.

Im Internet steht dazu nur dass man bei apache auf utf-8 umstellen soll. Dies habe ich soweit auch getan - zeigt aber leider keine Änderung. Lediglich meine index.php hat nun Umlaute. Mybb nicht Sad

Ich beantworte einfach mal ein paar Fragen:

URL zum Forum:
http://superwylp.de/forum

Hast du Plugins installiert? Welche?
Disposable Email Blacklist, Report Private Messages 1.1

Welche MyBB-Version benutzt du?
1.8.15 (Von keine Upgrades gehabt)

Welche PHP-Version benutzt du?
7.0.27-0deb9u1

Welche Datenbank benutzt du? (mit Version)
  • Server: Localhost via UNIX socket

  • Server-Typ: MariaDB

  • Server-Version: 10.1.26-MariaDB-0+deb9u1 - Debian 9.1

  • Protokoll-Version: 10

  • Benutzer: luca@localhost

  • Server-Zeichensatz: UTF-8 Unicode (utf8)
Hast du dein MyBB Forum von einer anderen Boardsoftware konvertiert?
Nein

Seit wann tritt das Problem auf?
Seit dem Serverwechsel. Davor hatte ich keinerlei Probleme. Alle anderen Subseiten können Umlaute verwenden, nur mybb nicht.

Wird eine Fehlermeldung ausgegeben? Welche? Wann?

Keine Fehlermeldung im apache Verzeichnis o a

Webserver:
  • Apache/2.4.25 (Debian)

  • Datenbank-Client Version: libmysql - mysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $

  • PHP-Erweiterung: mysqli curl mbstring

  • PHP-Version: 7.0.27-0+deb9u1
Ich hoffe ihr könnt mir behilflich sein Sad

Ich finde keinen Lösungsweg Sad
Zitieren
#2
Hast Du mal die UTF-8 Konvertierung im ACP ausprobiert?
admin/index.php?module=tools-system_health&action=utf8_conversion
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#3
Danke für die schnelle Antwort,
hatte ich noch nicht ausprobiert. Gerade eben mal gemacht; auch mit 4 bit.

Alles ist soweit erfolgreich konvertiert.
Funktionieren tut es trotzdem noch nicht.

Auch php gibt mir aus dass ich utf-8 verwende. (http://prntscr.com/julsdp)

Grüße
Zitieren
#4
Werden die Umlaute in Deinem DB-Backup, mit dem Du umgezogen bist, korrekt dargestellt?
Vielleicht haben die frühere und die neuen Datenbank eine unterschiedliche Kollation.
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#5
Oh mann...

Daran habe ich tatsächlich nicht gedacht... - war genau das Problem.

Danke für deine Hilfe! Smile
Zitieren