Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[NG] Mehrere Probleme nach Upgrade von 1.8.10 auf 1.8.15
#1
Hallo zusammen,

ich habe heute unser Forum von 1.8.10 auf 1.8.15 geupdatet und nun habe ich eine Reihe Fehler festgestellt. Einige dieser Fehler wurden schon mehrfach hier besprochen, brachten aber bis jetzt keine Lösung für mich.

Folgende Probleme:

-Inline Moderation funktioniert nicht

-Registrieren funktioniert nicht (nach ausfüllen aller Daten geht es beim klick auf den (Registrieren-                              Button nicht weiter)

-Admin-CP --> Tools & Verwaltung --> "Moderator Log Daten" zeigt leere weisse Seite



Lösungstechnisch habe ich folgendes probiert und entsprechend abgeändert:
https://community.mybb.com/thread-206896.html

Da es sich hier um eine Lösung für 1.8.9 handelt, habe ich darauf geachtet alles 1.8.15 konform zu ändern. Mein headerinclude sieht folgend aus

Code:
<link rel="alternate" type="application/rss+xml" title="{$lang->latest_threads} (RSS 2.0)" href="{$mybb->settings['bburl']}/syndication.php" />
<link rel="alternate" type="application/atom+xml" title="{$lang->latest_threads} (Atom 1.0)" href="{$mybb->settings['bburl']}/syndication.php?type=atom1.0" />
<meta http-equiv="Content-Type" content="text/html; charset={$charset}" />
<meta http-equiv="Content-Script-Type" content="text/javascript" />
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/jquery.js?ver=1813"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/jquery.plugins.min.js?ver=1813"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/general.js?ver=1815"></script>

<link type="text/css" rel="stylesheet" href="cache/themes/global/thanks/thx.css" />
<script type="text/javascript" src="jscripts/thx.js"></script>
{$stylesheets}
<script type="text/javascript">
<!--
lang.unknown_error = "{$lang->unknown_error}";

lang.select2_match = "{$lang->select2_match}";
lang.select2_matches = "{$lang->select2_matches}";
lang.select2_nomatches = "{$lang->select2_nomatches}";
lang.select2_inputtooshort_single = "{$lang->select2_inputtooshort_single}";
lang.select2_inputtooshort_plural = "{$lang->select2_inputtooshort_plural}";
lang.select2_inputtoolong_single = "{$lang->select2_inputtoolong_single}";
lang.select2_inputtoolong_plural = "{$lang->select2_inputtoolong_plural}";
lang.select2_selectiontoobig_single = "{$lang->select2_selectiontoobig_single}";
lang.select2_selectiontoobig_plural = "{$lang->select2_selectiontoobig_plural}";
lang.select2_loadmore = "{$lang->select2_loadmore}";
lang.select2_searching = "{$lang->select2_searching}";

var cookieDomain = "{$mybb->settings['cookiedomain']}";
var cookiePath = "{$mybb->settings['cookiepath']}";
var cookiePrefix = "{$mybb->settings['cookieprefix']}";
var cookieSecureFlag = "{$mybb->settings['cookiesecureflag']}";
var deleteevent_confirm = "{$lang->deleteevent_confirm}";
var removeattach_confirm = "{$lang->removeattach_confirm}";
var loading_text = '{$lang->ajax_loading}';
var saving_changes = '{$lang->saving_changes}';
var use_xmlhttprequest = "{$mybb->settings['use_xmlhttprequest']}";
var my_post_key = "{$mybb->post_code}";
var rootpath = "{$mybb->settings['bburl']}";
var imagepath = "{$theme['imgdir']}";
  var yes_confirm = "{$lang->yes}";
var no_confirm = "{$lang->no}";
var MyBBEditor = null;

function dismissANN(id)
{
if(!$("Ann_"+id))
{
return false;
}

if(use_xmlhttprequest != 1)
{
return true;
}

new Ajax.Request("index.php?action=ann_dismiss", {method: "post", postBody: "ajax=1&my_post_key="+my_post_key+"&id="+id});
Element.remove("Ann_"+id);
return false;
}
var spinner_image = "{$theme['imgdir']}/spinner.gif";
var spinner = "<img src='" + spinner_image +"' alt='' />";
// -->
</script>

admin/inc/class_page.php habe ich die Zeile entsprechend auf
Code:
echo " <script type=\"text/javascript\" src=\"../jscripts/general.js?ver=1815\"></script>\n";
abgeändert


Zusätzlich zu dem Update habe ich folgendes Plugin installiert und aktiviert:
https://github.com/MattRogowski/Cookie-Law

Aktivieren oder Deaktivieren des Plugins was scheinbar reibungslos funktioniert hat an den Problemen nichts geändert.


Link zum Forum:
https://summonerswar-fanforum.de/


Für Hilfe wäre ich sehr dankbar!
Zitieren
#2
Was die Modlog-Daten im ACP angeht: https://www.mybb.de/forum/thread-35409-p...#pid233087

Hast Du nach dem Update nach aktualisierten Templates gesucht und entsprechend aktualisiert?
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#3
Danke schonmal für die Antwort :-)

Also, das Moderatoren Log-Problem ist somit behoben. Vielen dank dafür.

Zu dem Thema aktualisieren der Templates... wenn damit gemeint ist:

1. aktualisierte Templates finden
2. entsprechende Templates im Editor aufrufen
3. Speichern und zur Liste zurück kehren

dann habe ich dies gemacht, ja. Hätte ich daran etwas manuell verändern müssen? Wenn ja dann nein Undecided
Zitieren
#4
Wenn du die Templates ohne irgendeine Veränderung speicherst, hast du sie nicht aktualisiert. Dabei ist dieser Schritt in unserer Doku beschrieben: https://www.mybb.de/doku/installationakt...#templates
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Seien Sie mir nicht böse, aber diese Dokumentation ist etwas irreführend. Warum sollte ich denn etwas zurück setzen wenn es nichtmal automatisch geändert wird? Jetzt da ich es weiss ergibt es natürlich einen Sinn, allerdings war das vorher nicht zwingend ersichtlich. Nun gut, empfohlener Schritt bzw. welche Möglichkeiten habe ich nun?
Zitieren
#6
Welche Template sich geändert haben, kannst du in unserer Doku nachlesen, dort kannst du dir auch die Veränderungen ansehen: https://www.mybb.de/doku/sonstiges/geaen...#templates

Ich fürchte, du musst diese nun manuell durchgehen und anpassen oder zurücksetzen. Templates, die sich bei dir im Originalzustand befinden, kannst du natürlich überspringen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#7
Zwischenzeitlich habe ich dies anders gehandhabt indem ich das komplette Backup der Version 1.8.10 inklusive Datenbank wieder aufgezogen habe. Upgrade neu durchgeführt, Templates manuell geändert und tada... selbes Problem >.<
Weder im Adminbereich noch im Forum funktioniert die Inlinemoderation (welche nach dem Backup auf 1.8.10 wieder funktioniert hat!!!)

Einzig die "admin/inc/class_page.php" habe ich noch nicht manuell bearbeitet, was ich gleich noch tun werde. Da davon aber nichts in der Dokumentation steht wollte ich dies zumindest erwähnen. Änderung kann ich erst später vornehmen da unser Server gerade gewartet wird.

Wenn dieser Schritt nun nichts bringt werde ich das alte 1.8.10 Backup komplett erneut aufspielen und es gut sein lassen, insofern hier nicht noch andere Lösungsvorschläge gepostet werden.

Ich führe dieses Forum inzwischen seit 2014 und hin und wieder gab es zwar mal Problemchen aber nichts was mich so sehr genervt hat wie das Thema hier. Ich meine mich zwar erinnern zu können schonmal ein derartiges/ähnliches Problem gehabt zu haben welches ich durch eine komplette Neuinstallation gelöst habe. Aber dies kann nicht Sinn und Zweck des ganzen sein. Wie viele andere betreibe ich das ganze als Hobby und meine Grundkenntnisse sind dementsprechend nicht ausgereift aber wachsen mit der Aufgabe und dem Beschäftigen mit der Materie. Allerdings verlasse ich mich dann auch auf diejenigen, welche die Software zur Verfügung stellen und sie supporten. Meine Zeit ist durch meinen Beruf auch nicht offen um mich tagelang am Stück mit einem Problem zu beschäftigen welches für mich ohne Hilfe nicht lösbar ist. Und wenn man die Suche hier oder Google benutzt scheine ich damit nicht alleine zu stehen. Dies nur mal in aller schnelle angemerkt um meinen Unmut darüber Luft zu machen ohne jemanden dabei zu Nahe tretten zu wollen. Ich bin dankbar für die Arbeit die sich gemacht wird aber irgendwas scheint leider auch nicht zu passen.

""Werde in dieser Zeile editieren falls die "admin/inc/class_page.php" etwas gebracht hat!""
Ich vergass, dass ich gar nicht editieren kann Undecided Daher entschuldigt doppelpost...

Die oben beschriebene Änderung in der "admin/inc/class_page.php" hat leider nicht geholfen.
Backup somit wieder hergestellt...
Zitieren
#8
Schade, dass du uns nicht ermöglichst dir zu helfen. Dass du die "Templates manuell geändert" hast, hilft mir bei der Fehlersuche nicht weiter und durch das Zurücksetzen des Forums kann nun auch andere in Betracht kommende Ursachen nicht mehr überprüfen. Mit großer

Wahrscheinlichkeit ist ein Javascript-Fehler der Verursacher für dein Problem, das hätte man aber näher untersuchen müssen. Wenn es auch im ACP Probleme gibt, würde ich auf veraltete Javascript-Dateien (aus welchem Grund auch immer) oder den Browser-Cache tippen.
(29.05.2018, 13:36)BoDStorm schrieb: Die oben beschriebene Änderung in der "admin/inc/class_page.php" hat leider nicht geholfen.
Die Änderung ist ja auch ausschließlich für MyBB 1.8.9 gedacht, wie man dem fetten roten Hinweis im Beitrag entnehmen kann.
(29.05.2018, 13:36)BoDStorm schrieb: Allerdings verlasse ich mich dann auch auf diejenigen, welche die Software zur Verfügung stellen und sie supporten. Meine Zeit ist durch meinen Beruf auch nicht offen um mich tagelang am Stück mit einem Problem zu beschäftigen welches für mich ohne Hilfe nicht lösbar ist. Und wenn man die Suche hier oder Google benutzt scheine ich damit nicht alleine zu stehen. Dies nur mal in aller schnelle angemerkt um meinen Unmut darüber Luft zu machen ohne jemanden dabei zu Nahe tretten zu wollen.
Auch dieses Fehlerbild immer mal wieder auftritt, am MyBB liegt das nicht, sonst wären ja alle User betroffen. In der Regel sind Fehler in Templates oder Plugins Schuld.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#9
Entschuldigung, bin aktuell im Umzugsstress und fange in 3 Tagen einen neuen Job an. Wollte das Update in Verbindung mit den Datenschutzaktualisierungen hinter mich bringen und habe gerade einfach keine großen Nerven dafür. Ich wollte dies nicht unbedingt an dritten raus lassen.

Sobald ich die Zeit dazu finde würde ich das komplette Forum kopieren und das Update an der Kopie probieren und mich dann zwecks Hilfe hier noch einmal melden.

Kurz schonmal als Anmerkungen:

- Browser-Cache sowie Cookies habe ich beim testen beständig gelöscht
- Die Änderung an der class_page.php habe ich durchgeführt da die aktuelle auch "...ver=1807..." stehen
hatte. Hier habe ich lediglich meiner eigenen Logik folge geleistet:
(1.8.9 - ...ver=1809... --> 1.8.15 - ...ver=1815...)
Zitieren
#10
(29.05.2018, 20:45)BoDStorm schrieb: - Die Änderung an der class_page.php habe ich durchgeführt da die aktuelle auch "...ver=1807..." stehen
hatte. Hier habe ich lediglich meiner eigenen Logik folge geleistet:
(1.8.9 - ...ver=1809... --> 1.8.15 - ...ver=1815...)
Der Code wird auch nur bei Veränderungen der Datei geändert, was beispielsweise bei MyBB 1.8.15 nicht der Fall war. Auf die Funktionalität hat das übrigens keinen Einfluss, es verhindert nur, dass die alte Datei aus dem Browser-Cache geladen wird.
Allerdings kommt in der aktuellen class_page.php nirgends 1807 vor. Bist du sicher, dass alle Dateien aktuell sind?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren