Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Benutzer-CP {mysupport_nav_option}
#1
Hallo,

habe das Template "Default Red Theme Templates" (von myBB im Januar 2018 heruntergeladen) welches mit im Benutzer-CP links oben (siehe Grafik) nur den Syntax {mysuport_nav_options} anzeigt.

Im Template usercp_nav_misc bin ich in Zeile 13, was den vorgenannten Syntax betrifft, fündig geworden.
Code:
<tr>
    <td class="tcat">
        <div class="expcolimage"><img src="{$theme['imgdir']}/collapse{$collapsedimg['usercpmisc']}.gif" id="usercpmisc_img" class="expander" alt="[-]" title="[-]" /></div>
        <div><span class="smalltext"><strong>{$lang->ucp_nav_misc}</strong></span></div>
    </td>
</tr>
<tbody style="{$collapsed['usercpmisc_e']}" id="usercpmisc_e">
    <tr><td class="trow1 smalltext"><a href="usercp.php?action=usergroups" class="usercp_nav_item usercp_nav_usergroups">{$lang->ucp_nav_usergroups}</a></td></tr>
    <tr><td class="trow1 smalltext"><a href="usercp.php?action=editlists" class="usercp_nav_item usercp_nav_editlists">{$lang->ucp_nav_editlists}</a></td></tr>
    <tr><td class="trow1 smalltext"><a href="usercp.php?action=attachments" class="usercp_nav_item usercp_nav_attachments">{$lang->ucp_nav_attachments}</a></td></tr>
    <tr><td class="trow1 smalltext">{$draftstart}<a href="usercp.php?action=drafts" class="usercp_nav_item usercp_nav_drafts">{$lang->ucp_nav_drafts}</a>{$draftend}</td></tr>
    <tr><td class="trow1 smalltext"><a href="usercp.php?action=subscriptions" class="usercp_nav_item usercp_nav_subscriptions">{$lang->ucp_nav_subscribed_threads}</a></td></tr>
    <tr><td class="trow1 smalltext"><a href="usercp.php?action=forumsubscriptions" class="usercp_nav_item usercp_nav_fsubscriptions">{$lang->ucp_nav_forum_subscriptions}</a></td></tr>{mysupport_nav_option}<tr><td class="trow1 smalltext"><a href="{$profile_link}" class="usercp_nav_item usercp_nav_viewprofile">{$lang->ucp_nav_view_profile}</a></td></tr>
</tbody>
Der Syntax ist in deer letzten TR-Zeile. Hier die Grafik wie es aussieht:    

Entferne ich den Syntax aus der Template-Datei wird das Benutzer-CP verzerrt dargestellt = also Entfernen keine Option.

Der Syntax muss ja eine Bedeutung haben. Wie muss ich vorgehen um den Syntax {mysupport_nav_options} mit Leben zu füllen? Wo finde ich die Defintionen des Syntax?
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Forum-1 | Forum-2 | Forum-3
Versionen: (PHP: 5.6.32 | MyBB: 1.8.15)


Zitieren
#2
Das ist im Default Theme in diesem Template gar nicht vorhanden und gehört vermutlich zu einem Plugin?!
Zitieren
#3
Kannst Du bitte zu dem Theme "Default Red Theme Templates" verlinken? Ich möchte nicht extra suchen, von welchem Theme du sprichst oder auch nicht.....
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#4
(10.03.2018, 11:51)Jockl schrieb: Kannst Du bitte zu dem Theme "Default Red Theme Templates" verlinken? Ich möchte nicht extra suchen, von welchem Theme du sprichst oder auch nicht.....
Aber gerne doch, Default Red Theme bin ja froh das jemand bereit ist zu helfen.

Ich habe den Syntax ohne <tr></tr> ausgeklammert, jetzt ist das Benutzer-CP korrekt. Dürfte so sein wie Du vermutet hast, das es nicht benötigt wird und vermutlich aus der "alten" Datenbank (V1.12.10), welche ohne FTP-Daten implementiert werden musste, stammt.
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Forum-1 | Forum-2 | Forum-3
Versionen: (PHP: 5.6.32 | MyBB: 1.8.15)


Zitieren
#5
Mal abgesehen davon, dass dieses Theme nicht kompatibel zu MyBB 1.8 ist, scheinst Du zudem das Plugin MySupport installiert zu haben. Auch dieses ist nicht kompatibel zu MyBB 1.8. Von diesem Plugin kommt das {mysupport_nav_option}
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#6
(10.03.2018, 14:55)Jockl schrieb: Mal abgesehen davon, dass dieses Theme nicht kompatibel zu MyBB 1.8 ist,...
ops, da steht aber doch
Zitat:Default Red Theme works with all versions of MyBB 1.6.x and may be compatible with MyBB 1.8.x once it's released.
und ist, so ich verrstehe, kompatibel zu V1.8.x
(10.03.2018, 14:55)Jockl schrieb: ...scheinst Du zudem das Plugin MySupport installiert zu haben. Auch dieses ist nicht kompatibel zu MyBB 1.8. Von diesem Plugin kommt das {mysupport_nav_option}
Ich finde "MySupport" in den PlugIns nicht. Wie könnte sich dies bennen?

Wie deinstalliert man eigentlich PlugIns korrekt? Einfach nur die Dateien des PlugIn entfernen und gut ist?
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Forum-1 | Forum-2 | Forum-3
Versionen: (PHP: 5.6.32 | MyBB: 1.8.15)


Zitieren
#7
"may be" bedeutet für mich "kann" kompatibel sein. Allein die Tatsache, dass Du mit dem Theme noch so einige andere Probleme hast, spricht dafür, dass dieses Theme nicht (100%ig) kompatibel ist.

Wenn Du das Plugin MySupport nicht findest, dann ist es evtl. in der Vergangenheit nicht korrekt entfernt worden und in den Templates befinden sich dann eben solche Überbleibsel (ggf. auch mit Einstellungen und Einstellgruppen in der DB). Was meinst Du eigentlich damit, dass Du {mysupport_nav_option} "ausgeklammert" hast? Was ist denn wenn Du es einfach löscht?

"Einfach nur Dateien zu entfernen" um ein Plugin zu deinstallieren, kann genau zu solchen Folgen führen. In der Regel liegen den Plugins Deaktivierungs- und Deinstallationsroutinen bei (geschieht alles sehr bequem via ACP). Wenn das geschehen ist, dann können auch die Dateien vom Server entfernt werden.....
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#8
(10.03.2018, 15:28)Jockl schrieb: Wenn Du das Plugin MySupport nicht findest, dann ist es evtl. in der Vergangenheit nicht korrekt entfernt worden und in den Templates befinden sich dann eben solche Überbleibsel

Ich habe mal in die XML-Datei von dem Default Red Theme geschaut, die Templates darin stecken voller MySupport-Variablen. Offenbar hatte der Autor das MySupport Plugin installiert und die alle bei der Veröffentlichung des Themes da drin gelassen.
Zitieren
#9
(10.03.2018, 15:28)Jockl schrieb: "may  be" bedeutet für mich "kann" kompatibel sein. Allein die Tatsache, dass Du mit dem Theme noch so einige andere Probleme hast, spricht dafür, dass dieses Theme nicht (100%ig) kompatibel ist.
Da schreibt eben der Fachmann und der Laie steht frustiert davor.

(10.03.2018, 15:28)Jockl schrieb: Wenn Du das Plugin MySupport nicht findest, dann ist es evtl. in der Vergangenheit nicht korrekt entfernt worden und in den Templates befinden sich dann eben solche Überbleibsel (ggf. auch mit Einstellungen und Einstellgruppen in der DB). Was meinst Du eigentlich damit, dass Du {mysupport_nav_option} "ausgeklammert" hast? Was ist denn wenn Du es einfach löscht?
Da ich Anfangs nicht weis ob es mich meinem Ziel näher bringt, klammere ich mit <!-- und --> zuerst aus. Wenn das Ergebnis wie gwünscht ist (hier Wegfall  der inkorrekten Anzeige) dann erst lösche ich.

(10.03.2018, 15:28)Jockl schrieb: "Einfach nur Dateien zu entfernen" um ein Plugin zu deinstallieren, kann genau zu solchen Folgen führen. In der Regel liegen den Plugins Deaktivierungs- und Deinstallationsroutinen bei (geschieht alles sehr bequem via ACP). Wenn das geschehen ist, dann können auch die Dateien vom Server entfernt werden.....
Da ist eben das Problem, da ich nur eine "alte" Datenbank (V1.12.10) übernehmen konnte. FTP-Daten standen keine zur Verfügung. Jetzt muss ich mich halt so nach und nach durchquälen und die "Störenfriede versuchen zu beseitigen.

Wäre super, würde es auch ein PlugIn geben, welches die Templates (je Template = eine Datei mit dem Template-Namen) erfassen könnte. Dies hätte den Vorteil, das man immer mal nach dem Inhalt der "Ursprungsdatei" nachsehen könnte. Bei phpBB konnte ich alle Template-Dateien via FTP bearbeiten und mein FTP-Programm legt hierbei immer eine automatische Datensicherung (Datum/Uhrzeit) an. Egal, es ist wie es ist, alles hat eben seine Vor- und Nachteile.

Irgendwie bekommeen wir auch mal die Dtaenbank bereinigt. Muss eh was hierbei tun da die Suchfunktion nicht funzt. Gibbet für/von myBB ein Datenbanktool was da behilflich (z.B. Zuordnung von Postings etc.) sein kann?
Wer fragt, ist gegebenenfalls für fünf Minuten ein Narr. Wer nicht fragt, bleibt ein Narr.
Forum-1 | Forum-2 | Forum-3
Versionen: (PHP: 5.6.32 | MyBB: 1.8.15)


Zitieren