Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
MyBB updatesicher einrichten
#1
Ich habe bisher keine Anleitung gefunden wie MyBB updatesicher eingerichtet wird.

Soweit ich bisher mitbekommen habe, wird gerne (muß) hardgecoded (werden) und mit jeder zukünftigen Veränderung beginnt die Arbeit erneut oder man "schießt sich was ab". Doch dass kann es natürlich nicht sein.

Wie muß ich MyBB einrichten, damit es updatesicher bleibt?

Danke
Zitieren
#2
Bin mir nicht ganz sicher, was Du mit "updatesicher" meinst, aber wegen möglicher Core-Änderungen, die durch ein Update verworfen würden, kannst Du Dir mal das Patches-Plugin von frostschutz ansehen. Das ist wirklich sehr hilfreich.
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#3
(13.12.2017, 13:39)Jockl schrieb: Bin mir nicht ganz sicher, was Du mit "updatesicher" meinst,

Ja, ich denke an Core-Modifikationen.
Wenn ich mir als Beispiel das ansehe: https://www.mybb.de/forum/thread-35223.html dann habe ich hier direkt im Core eingegriffen. Falls dieser Teil des Cores irgendwann einmal durch ein Update verändert werden sollte, sind meine Arbeiten verloren. Oder ich muß mir die Arbeit machen und jedes Update erst mal mit Kdiff https://userbase.kde.org/KDiff3/de kontrollieren ob ich die alten Dateien "gefahrlos" gegen die Neuen ersetzen kann. Falls nicht, muß ich ja wieder Hand anlegen und die selbe Arbeit erneut wiederholt ausführen.

(13.12.2017, 13:39)Jockl schrieb: aber wegen möglicher Core-Änderungen, die durch ein Update verworfen würden, kannst Du Dir mal das Patches-Plugin von frostschutz ansehen. Das ist wirklich sehr hilfreich.

Danke - werde ich. Funktioniert es auch mit dem 1.8er Zweig?
Zitieren
#4
Hol dir die 1.8 kompatible Version aus meinem GitHub.
Zitieren