Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.14 veröffentlicht (30.11.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Anmelden
#1
Hallo ihr lieben,
Vielleicht kann mir jemand helfen.
Ich habe in meinem Forum eine Seiten Navigationstabelle aufgebaut. Hab sie sogar soweit angepasst, dass User und Gäste zwei Unterschiedliche sehen können.
Denn habe ich für die Mitglieder noch sowas wie UCP Button und ausloggbutton eingefügt und bei den Gästen eben den anmelde und registrierbutton

Und da kommen wir auch schon zu meinem Problem.
Also bis gestern lief das alles noch, deseegen wundere ich mich auch stark
Aber der schnell Logpopupfenster geht nicht mehr aug. Auch wenn ich den orginal Code eingebe
Code:
 <a href="{$mybb->settings['bburl']}/member.php?action=login" onclick="$('#quick_login').modal({ fadeDuration: 250, keepelement: true, zIndex: (typeof modal_zindex !== 'undefined' ? modal_zindex : 9999) }); return false;" class="login">{$lang->welcome_login}</a>
 

Wird mir das anmelde ding angezeigt aber nichts passiert wenn ich drauf drücke
(Damit es verständlich wird habe ich ein Bild noch
)
Vielleicht kann mir ja jemand helfen oder ein Tipp geben
LG


Angehängte Dateien Thumbnail(s)
   
Zitieren
#2
Sieht für mich so aus als ob ein jquery Konflikt Vorliegt oder die zuständige jquery Datei nicht angesprochen wird. Die Tage in der Headerinclude was geändert oder eine jquery Datei ausgetauscht?
[x] <= Hier Nagel einschlagen für neues Display!
Wer Böses spricht,über mich und die Meinen, der gehe nach Hause,und betrachte die Seinen !!!

Zitieren
#3
Stehe irgendwie auf den Schlauch. Ich denke aber das es nur im Headerincloud ist/war.
Damit ich mich einloggen kann, habe ich das Template header_welcomeblocl_guest wieder auf den Ursprung gebracht und da funktioniert das ganze mit dem Einloggen. Obwohl da der selbe Code steht wie in meinem Navi
Zitieren
#4
Weiß ich nicht ob die Identisch sind. Aber anscheinend ja nicht. Hier Posten dann können wir alle mal drüber schauen.
[x] <= Hier Nagel einschlagen für neues Display!
Wer Böses spricht,über mich und die Meinen, der gehe nach Hause,und betrachte die Seinen !!!

Zitieren
#5
So das ist mein Code vom header_welcomeblock_guest
Code:
                        <!-- Continuation of div(class="upper") as opened in the header template -->
                        <h2><span class="welcome">{$lang->welcome_guest} <a href="{$mybb->settings['bburl']}/member.php?action=login" onclick="$('#quick_login').modal({ fadeDuration: 250, keepelement: true, zIndex: (typeof modal_zindex !== 'undefined' ? modal_zindex : 9999) }); return false;" class="login">{$lang->welcome_login}</a> <a href="{$mybb->settings['bburl']}/member.php?action=register" class="register">{$lang->welcome_register}</a></span></h2>
                    </div>
                </div>
                <div class="modal" id="quick_login" style="display: none;">
                    <form method="post" action="{$mybb->settings['bburl']}/member.php">
                        <input name="action" type="hidden" value="do_login" />
                        <input name="url" type="hidden" value="" />
                        <input name="quick_login" type="hidden" value="1" />
                        <table width="100%" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" border="0" class="tborder">
                            <tr>
                                <td class="thead" colspan="2"><strong>{$lang->login}</strong></td>
                            </tr>
                            <tr>
                                <td class="trow1" width="25%"><strong>{$login_username}</strong></td>
                                <td class="trow1"><input name="quick_username" id="quick_login_username" type="text" value="" class="textbox initial_focus" /></td>
                            </tr>
                            <tr>
                                <td class="trow2"><strong>{$lang->password}</strong></td>
                                <td class="trow2">
                                    <input name="quick_password" id="quick_login_password" type="password" value="" class="textbox" /> <a href="{$mybb->settings['bburl']}/member.php?action=lostpw" class="lost_password">{$lang->lost_password}</a>
                                </td>
                            </tr>
                            <tr>
                                <td class="trow1">&nbsp;</td>
                                <td class="trow1 remember_me">
                                    <input name="quick_remember" id="quick_login_remember" type="checkbox" value="yes" class="checkbox" checked="checked" />
                                    <label for="quick_login_remember">{$lang->remember_me}</label>
                                </td>
                            </tr>
                            <tr>
                                <td class="trow2" colspan="2">
                                    <div align="center"><input name="submit" type="submit" class="button" value="{$lang->login}" /></div>
                                </td>
                            </tr>
                        </table>
                    </form>
                </div>
                <script type="text/javascript">
                    $("#quick_login input[name='url']").val($(location).attr('href'));
                </script>

und das ist mein Code von der Navigationsleiste
Code:
<div id="push-menu-right2" style="padding-top:5px">
<div class="link"><a href="index.php" title="home"><div style="font-size: 39px; color: #955b3b;"><n class="fa fa-university" aria-hidden="true"></n></div></a></div><hr>
    
    <div class="link"><a href="search.php" target="_blank" title="Search"><div style="font-size: 48px;  color: #955b3b;"><n class="fa fa-search" aria-hidden="true"></n></div></a></div><div style="color: #E4D6BF;"><hr></div>

    <div class="link"><a href="lists.php" target="_blank" title="Lists"><div style="font-size: 45px;  color: #955b3b;"><n class="fa fa-list" aria-hidden="true"></n></div></a></div><hr>
    
    <div class="link"><a href="showteam.php" target="_blank" title="Team"><div style="font-size: 48px;  color: #955b3b;"><n class="fa fa-star" aria-hidden="true"></n></div></a></div><hr>
    

    <div class="link"><a href="{$mybb->settings['bburl']}/member.php?action=login" onclick="$('#quick_login').modal({ fadeDuration: 250, keepelement: true, zIndex: (typeof modal_zindex !== 'undefined' ? modal_zindex : 9999) }); return false;" class="login">{$lang->welcome_login}</a><div style="font-size: 39px; color: #955b3b;"><n class="fa fa-sign-in" aria-hidden="true"></n></div></a></div><hr>
    
    <div class="link"><a href="member.php?action=register" target="_blank" title="Registrieren"><div style="font-size: 48px;  color: #955b3b;"><n class="fa fa-plus" aria-hidden="true"></n></div></a></div><div style="color: #E4D6BF;"></div>
    
    </div>
Zitieren
#6
Das da mal in deine Navigationsleisten Code am ende Einfügen.

<script type="text/javascript">
$("#quick_login input[name='url']").val($(location).attr('href'));
</script>
[x] <= Hier Nagel einschlagen für neues Display!
Wer Böses spricht,über mich und die Meinen, der gehe nach Hause,und betrachte die Seinen !!!

Zitieren
#7
Upps mist. Hatte echt Tomaten auf den Augen.
Danke für die Hilfe
Zitieren
#8
Passiert den Besten mal. ;-)
[x] <= Hier Nagel einschlagen für neues Display!
Wer Böses spricht,über mich und die Meinen, der gehe nach Hause,und betrachte die Seinen !!!

Zitieren
#9
Okay wieder komisch es funktioniert schon wieder nicht. Obwohl ich nichts mehr in dem Temp gemacht habe seid dem
Zitieren
#10
Bei mir funktioniert deine Seiten-Navi.

ABER:

Du hast recht viele HTML Fehler auf deiner Seite. Diese können noch mehr Fehler verursachen, oder tun dies bereits. Prüfe doch bitte deine Seite mit einen Validator. Zum Beispiel mit diesen hier. https://validator.w3.org/
Mit freundlichen Grüßen

MrBrechreiz
Zitieren