Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.12 veröffentlicht (22.05.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Portal als Startseite
#1
Hallo Leute Wink

ich habe gefühlt 1.000 Beiträge gelesen, 100.000 mal die .htaccess
Code:
DirectoryIndex portal.php index.php
 geöffnet, geändert und erneuert, Google bis zum Erbrechen gefordert...
Zum Thema:
Ich betreibe ein MyBB1.8.11 Forum auf meinem Ubuntu16.04-Home-Server mit apache2, PHP7 und MySQL. Auf's Forum greife ich über einen DynDNS zu... Das Forum läuft gut.
Nun möchte ich ein angepasstes Portal als Startseite setzen, aber, was ich auch versuche, es funzt nicht.

Was mache ich falsch?
ShareColley
Ubuntu 16.04 LTS - CPU: Intel®Core™i5 650@3.20GHz - RAM: 6GB
Server: Ubuntu 16.04 - CPU: Intel®Core™i3 400SU@1.70GHz - RAM: 4GB - Apache2/PHP7/MySQL - MyBB 1.8.11
Zitieren
#2
So... Lösung gefunden:

Apache2 benötigt eine Berechtigung für den DirectoryIndex-Befehl in der .htaccess-Datei. Die Datei '/etc/apache2/apache2.conf' mit einem Editor öffnen und folgenden Code einfügen oder ändern:

Code:
<Directory /var/www/html/'DeinForum'/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted
</Directory>
speichern

Terminal öffnen, dann mit folgendem Befehl Apache2 neustarten 
Code:
sudo service apache2 restart

Im Verzeichnis /var/www/html/'DeinForum'/ die '.htaccess' öffnen/erstellen und folgenden Code eingeben:
Code:
DirectoryIndex portal.php index.php
speichern.

Das gilt für meinen Ubuntu-Home-Server, nicht für Web-Server, bei dem die Berechtigungen u.U. vom Hoster gesetzt werden müssen. 
ShareColley
Ubuntu 16.04 LTS - CPU: Intel®Core™i5 650@3.20GHz - RAM: 6GB
Server: Ubuntu 16.04 - CPU: Intel®Core™i3 400SU@1.70GHz - RAM: 4GB - Apache2/PHP7/MySQL - MyBB 1.8.11
Zitieren