Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.11 veröffentlicht (04.04.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
MyBB 1.8.7 - LogIn und Out nicht möglich
#1
Hallo zusammen,

Nachdem ich mich bereits durch viele englisch -und deutschsprachige Seiten gelesen habe, hoffe ich das mir jemand helfen kann.

Was ist das Problem:
User (inkl. Admins) können sich auf unserem Forum nicht richtig ausloggen, bzw. wenn der LogOut akzeptiert wird, nicht mehr einloggen.

Installierte PlugIns:
Derzeit nur PHP in Templates 2.1. Dieses PlugIn wird seitens meines Hosters als Urheber der ganzen Probleme vermutet. Leider reichen meine PHP nicht so tief den Fehler zu entschlüsseln und zu beheben.

Die etwas längere Geschichte dahinter:
Bis gestern morgen um 09:30Uhr war die Welt nocht in Ordnung. Ich habe meine member_profile umdesigned und dann ging auf einmal gar nichts mehr. Seitens one.com gab es einen Serverausfall der bis in den frühen Abend andauerte. Zu dieser Zeit lief mein Forum wenn ich mich wirklich nicht ganz schrecklich irre, auf PHP Version 5.3 (ich gebe keine 100% Garantie dafür, aber zu 98% bin ich mir sicher.) Kurzzeitig war das Forum samt funktionierendem LogIn und LogOut wieder erreichbar. Als die Seite noch mal kurzzeitig danach nicht erreichbar war begannen die Probleme. Sobald ich mich ordnungsgemäß abmelden wollte, bekam ich eine rein weiße Seite angezeigt (ohne Weiterleitung zum Boardindex wie es sein sollte). Ein LogIn verursachte genau das selbe Phänomen. Da ich annahm, dass es sich dabei um einen, auf diesem Serverausfall basierenden, Fehler handelt, habe ich den Support von one.com besucht und die Dame meinte letztlich, ich solle mir bitte Hilfe für MyBB suchen, da es sich um eine Drittanbietersoftware handelt.

Und das bekomme ich nun angezeigt:
Code:
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; phptpl_templates has a deprecated constructor in /customers/0/6/d/blackwhitedesign.de/httpd.www/seven-letters/inc/plugins/phptpl.php(75) : eval()'d code on line 2 Notice: Undefined offset: 2 in /customers/0/6/d/blackwhitedesign.de/httpd.www/seven-letters/inc/plugins/phptpl.php on line 89 Notice: Undefined offset: 2 in /customers/0/6/d/blackwhitedesign.de/httpd.www/seven-letters/inc/plugins/phptpl.php on line 89 Notice: Undefined offset: 2 in /customers/0/6/d/blackwhitedesign.de/httpd.www/seven-letters/inc/plugins/phptpl.php on line 89 Notice: Undefined variable: awaitingusers in /customers/0/6/d/blackwhitedesign.de/httpd.www/seven-letters/global.php(817) : eval()'d code on line 109 Notice: Undefined index: style in /customers/0/6/d/blackwhitedesign.de/httpd.www/seven-letters/global.php on line 875 Notice: Undefined property: MyLanguage::$lang_select_default in /customers/0/6/d/blackwhitedesign.de/httpd.www/seven-letters/inc/functions.php on line 4984 Notice: Undefined index: additionalgroups in /customers/0/6/d/blackwhitedesign.de/httpd.www/seven-letters/inc/functions.php on line 6987 Notice: Undefined index: additionalgroups in /customers/0/6/d/blackwhitedesign.de/httpd.www/seven-letters/inc/functions.php on line 6987 Notice: Undefined index: additionalgroups in /customers/0/6/d/blackwhitedesign.de/httpd.www/seven-letters/inc/functions.php on line 6987 Notice: Undefined index: additionalgroups in /customers/0/6/d/blackwhitedesign.de/httpd.www/seven-letters/inc/functions.php on line 6987 

Ich hoffe inständig, dass mir jemand helfen kann.

Mit freundlichen Grüßen,
Dementia
Zitieren
#2
Kannst du einen Link zu deinem Forum posten?

Ich würde dir, unabhängig vom Problem, zur einer Aktualisierung auf die neueste Version raten.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Seven Letters
Das wäre das Forum um dass es geht.

Das Upgrade habe ich auch schon ins Auge gefasst, doch wollte ich vorher noch alle installierten PlugIns auf ihre Kompatibilität überprüfen.
Zitieren
#4
Das MyBB unterdrückt PHP-Notices standardmäßig. Sofern du diese nicht durch eine Code-Änderung anzeigen lässt, wende dich bitte an deinen Hoster und frage, warum die vom MyBB mittels error_reporting() gesetzten Werte überschrieben werden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Vielen Dank. Das werde ich tun.

Ich habe eben noch mal die -leider in Englisch geführte- Konversation von gestern Abend durchgelesen, und das einzige was ich dazu gefunden habe, war das:

Zitat:Francis: ok then, once you have updated your site - please do remove the debugging script to remove the warning messages. Is there anything else i can assist you with ?

Umschließt das Debugging Script auch die PHP Notices?
Zitieren
#6
Wahrscheinlich, auch wenn ich nicht weiß, was gemeint sein soll.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#7
Hallo nocheinmal,

Ich habe nun noch einmal den Support kontaktiert und die PHP Fehlermeldungen direkt im Dashboard bei one.com deaktiviert. Alles was ich nun noch sehe wenn ich versuche mich einzuloggen ist das:

Screenshot LogIn
[url=http://prntscr.com/ey7ia6][/url]

Nachtrag:
Auszug aus der Konversation bezgl. error_reporting()
Zitat:(10:03:13) Maren: Ok, ich frage kurz mal die Technik, einen Moment, bitte
(10:04:17) Maren: Also der error_reporting command kann von Scripten ausgeführt werden.
(10:04:26) Maren: Serverseitig wird da also nichts unterdrückt.
Zitieren
#8
Als du dein member_profile umgestaltet hast, hast du da auch etwas an der Sprachdatei member.lang.php geändert?
Wenn ich auf dein Login-Formular gehe, wird mir folgender Fehler angezeigt:
   
Das deutet möglicherweise auf eine Bearbeitung der Sprachdatei mit einem ungeeigneten Editor hin.
Zitieren
#9
Leider ja. Den Windows Editor. Ich habe da wirklich nicht mehr dran gedacht, dass ich den nicht nutzen darf.
Ich habe die Linknamen für PM und Email geändert.

Und nun habe ich das ganze noch verschlimmert.
Ich habe versucht das Upgrade von 1.8.7 auf 1.8.11 zu installieren, wie es Stefan empfohlen hat. Leider nimmt er die LogIn Daten nicht. Ich komme bis zu folgendem Punkt:

Screenshot Upgrade

Wenn ich meine Daten eingebe, lande ich wieder auf genau der selben Seite mit unausgefüllten Feldern.


NACHTRAG.
Meine Mitadmina (Dauereingeloggt bei uns, d.h. sie hat sich gestern gar nicht ausgeloggt) macht das Upgrade gerade zu Ende.
Das Upgrade auf 1.8.11 wurde erfolgreich durchgeführt. Nun lande auch ich wieder -wenn auch nach wie vor uneingeloggt- auf dem Index. Wäre es Hilfreich, die Sprachpakete für 1.8.11 nachträglich zu installieren um das zu korrigieren? Die Cookie-Einstellungen werde ich gleich noch mal überprüfen.
Zitieren
#10
Bei einem Upgrade werden aktuelle Sprachpakete autmatisch mit installiert, sollte nun also alles aktuell sein.
Zitieren