Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.13 veröffentlicht (07.11.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Klick auf Foren aktualisiert nur Seite (Permalinks?)
#1
Werte Community,
ich kämpfe schon seit mehreren Stunden mit dem erstellen von Foren weil sich vermutlich die Permalinks weigern.
Das Forum läuft im Admin Panel usw. einwandfrei nur wenn ich auf ein Forum oder Unterforum klicke passiert nichts. Überzeugt euch selbst: https://forum.spacepc.de/
Ich hoffe jemand hat einen Tipp? Smile

Zur Kinfiguration:
Debian 8.0
MySQL
Apache2
mod_rewrite
mod_ssl
wildcard Zertifikat

.htaccess aktiv!
Subdomain

vhost:
Code:
<VirtualHost *:80>ServerAdmin webmaster@spacepc.de
DocumentRoot /var/www/spacepcf
ServerName forum.spacepc.de
DirectoryIndex index.php
ErrorLog /var/log/apache2/spacepcf-error.log
</VirtualHost>
<Location />
RewriteEngine on
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R]
</Location>
<Directory "/var/www/spacepcf">
       Require all granted
       Options Indexes FollowSymLinks
       AllowOverride All
       Order allow,deny
       Allow from all
</Directory>

<IfModule mod_ssl.c>
<VirtualHost *:443>
ServerAdmin webmaster@spacepc.de
DocumentRoot /var/www/spacepcf/
ServerName forum.spacepc.de
DirectoryIndex index.php

Header always set Strict-Transport-Security: 'max-age=31536000; preload'

ErrorLog /var/log/apache2/spacepcf-error.log

SSLEngine on
SSLProtocol All -SSLv2 -SSLv3
SSLHonorCipherOrder On
SSLCompression off

CustomLog /var/log/apache2/spacepcf-access.log combined
ServerSignature Off
SSLCertificateFile    /etc/letsencrypt/live/stoecklmayer.net/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/stoecklmayer.net/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf

<Directory "/var/www/spacepcf/">


AllowOverride all
Require all granted

</Directory>

RewriteEngine On
#RewriteBase /
RewriteRule ^/$ /index.php [L]
RewriteCond %{DOCUMENT_ROOT}%{REQUEST_FILENAME} !-f
RewriteCond %{DOCUMENT_ROOT}%{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /index.php/$1 [L]

</VirtualHost>

</IfModule>
Zitieren
#2
Schon mal mit den Standard (default) Theme versucht ?
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#3
Das liegt offensichtlich an den mod_rewrite-Regeln in der Konfigurations-Datei. Die für MyBB korrekten findest du in der htaccess.txt des MyBB.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#4
Vielen Dank für die schnellen Antworten. Auch mit dem Default Theme ändert sich nichts.
Ich habe jetzt den mod_rewrite teil der .htaccess einfach in die vhost kopiert. Jetzt habe ich einen 404 Fehler.
Könnte mir jemand sagen wie ich das integriere und warum nimmt Apache die RewriteRules nicht direkt aus der .htaccess?
Vielen Dank! Smile
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  upgrade auf 1.8 - globale templates nicht aktualisiert Felk 3 783 23.11.2014, 13:43
Letzter Beitrag: spyking