Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Datenbank kann nicht gesichert werden!
#1
hallo,
habe schon des öfteren eure hilfe in anspruch genommen und bin mir sicher,daß ihr mir auch diesmal aus der patsche helfen könnt.

zunächst ein kurzbericht:
upgrade von 1.1.8 auf 1.2.1 getätigt
dummerweise ohne vorher die datenbank zu sichern
das board läuft zwar mit der neuen software-version
allerdings können z.b. neue themes nicht als standard übernommen werden
ausserdem kann ich die datenbank nicht sichern
es folgt einen fehlermeldung des servers
irgendwas ist also faul und ich hätte gerne das ganze neu aufgespielt.

wir haben testweise ein anderes board auf einem anderen server eingerichtet mit version 1.2.1
dort lassen sich neue themes ohne weiteres anpassen und auch die datenbank kann gesichert werden.

also vermuten wir das beim upgraden was schief gelaufen ist.

haben zunächst mit phpmyadmin ein backup der datenbank gemacht
wenn diese allerdings importiert wird,kommen die gleichen fehler wieder.
es ist also offenbar irgend ein fehler in der datenbank

Nun zu den eigentlichen fragen:
was können wir tun um das board zu retten bzw.wie finden wir den fehler?
welche dateien werden benötigt um bei einer neuinstallation wieder auf alles alte zugreifen zu können?

schon jetzt tausend dank

coppeliusfan
COPPELIUS HILFT!!
#2
Nur um das mal auszuschließen: Du hast bei dem Upgrade nach dem Hochladen der Dateien die upgrade.php ausgeführt?
Vantage-Forum: http://vantage-forum.de/
#3
sehr wohl sir,hab ich!
COPPELIUS HILFT!!
#4
Versuchen wir es mal so: Installier ein neues Board und spiel dann nur die Tabellen users, usergroups, threads und posts ein.
Das übernimmt nur die Benutzer(gruppen), Beiträge und Themen, also das wichtigste.
Eine bessere Lösung kan ich dir ohne Backup der alten Version nicht anbieten.
Vantage-Forum: http://vantage-forum.de/
#5
Wie lautet die Fehlermeldung?

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#6
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, service@webmailer.de and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
COPPELIUS HILFT!!
#7
Hast du Zugriff auf die Errorlogs des Servers? Hier sollten genauere Informationen zum Fehler zu finden sein.

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
#8
Zugriff auf die Errorlogs?
Keine Ahnung,wohl eher nicht.
Komm wohl nicht drum rum ne Neuinstallation zu machen.
Ist die Version 1.2.0 (deutsch) eigentlich noch verfügbar oder muss ich gleich 1.2.1 hochladen?

Zitat Mak:
Installier ein neues Board und spiel dann nur die Tabellen users, usergroups, threads und posts ein.
Frage: Genügt es wenn ich nach der Neuinstallation diese Tabellen im sql-format in die Datenbank importiere?
Muss ich die angelegten vorher löschen oder werden diese überschrieben?
Wie würdet ihr genau vorgehn ?
coppeliusfan
COPPELIUS HILFT!!
#9
Ja nachdem, wie genau dein Backup aussieht, musst du die alten Tabellen wahrscheinlich vorher löschen, sonst bekommst du die Fehlermeldung "table ... already exists".
Du kannst die Tabellen ganz normal als SQL Backup einspielen.
Version 1.2.0 gibt es (offiziell) nicht mehr als Download. Es ist aber besser, direkt 1.2.1 zu nehmen.
Vantage-Forum: http://vantage-forum.de/