Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
PHP 7.0 - SQL extension Error?
#1
Aloha!

All-Inkl hat ja gerade angekündigt, daß sie alte PHP Versionen abschalten und bietet den Service, dem Benutzer zu zeigen, wo Handlungsbedarf entsteht. Man kann nun in diesem Zuge seine gewünsche PHP-Version einstellen.

Ich habe also bei meinen Subdomänen das etwas neuere und nun auch noch ne Weile gültige PHP 5.5 eingestellt, wollte jetzt aber mal PHP 7.0 testen. Wenn ich PHP 7 eingestellt habe, gibt mir mein Forum bei Klick auf ein Forum der Startseite den MyBB Error (44) - "MyBB was unable to load the SQL extension", der nicht mehr auftaucht, wenn ich zurück auf PHP 5.5 stelle.

Ist das jemandem schon begegnet? Eigentlich ist das ja laut MyBB Docs ein Konfigurationsfehler des Datenbank-Typs. Aber ich stelle ja nur die PHP-Version hin und her.



Liebe Grüße
Ama
Zitieren
#2
Mit PHP 7.0 fällt die schon lange als veraltet geltende mysql-Erweiterung von PHP weg. Stattdessen muss die mysqli-Erweiterung genutzt werden, die das MyBB ebenso unterstützt.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Ah, vielen Dank, das war es auch schon. Smile
Zitieren
#4
Ich muss mich mal hier dranhängen. Habe auch grade auf all-inkl auf php7 umgestellt und auch in der inc/confic.php bei Type von mysql auf mysqli umgetragen, aber der Fehler besteht leider noch immer. :/
Wäre ja auch zu schön gewesen wenn mal was so einfach klappt, wie bei jedem anderen auch.^^
Hat noch jemand eine Idee?
Zitieren
#5
Hast Du mal nachgesehen, ob Du in den Einstellungen beim Server die PHP Erweiterung mysqli aktiviert hast?
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#6
Ich selbst hantiere auf dem Server nur mit meinen Datenbanken rum und bin da beim Rest leider gar nicht so bewandert (wie ich vielleicht sein sollte xD). Unter den nomalen Einstellungen gab es bei all-inkl nichts zum mysql, aber an anderer Stelle habe ich folgendes (unten) entdeckt, von dem ich aber nicht weiß ob es jemanden hilft mir zu helfen. Big Grin
Heißt theoretisch müsste die Eintragung mit mysqli schon funktionieren? Was es aber ja leider nicht macht. -.-


Angehängte Dateien Thumbnail(s)
   
Zitieren
#7
So die ganz dumme Frage: Du hast auch die richtige config.php angepasst und sie auch in das richtige Verzeichnis hochgeladen? Smile Und trotzdem kommt obige Fehlermeldung?
Zitieren
#8
Unter inc die config.php. Die ich auch dort wieder hochgeladen hab. Big Grin Leider ja. Ich wünschte das wäre mein Fehler. xD
Zitieren