Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Upgrade von 1.6.1 auf 1.8.7
#1
Ich habe heute versucht, ein Upgrade eines meiner Foren durchzuführen.
Bitte verzeiht meine Unerfahrenheit und meine eventuell unzureichende Beschreibung des Fehlers. Bitte einfach kurz erklären, wo ich nachsehen kann, um das aufgetretene Problem genauer zu spezifizieren.

Das Upgrade scheitert bereits beim Aufrufen von upgrade.php. Es wird die Angabe des Admins mit Passwort abverlangt. Nach Eingabe der richtigen Daten taucht die Abfrage einfach wieder auf, ohne Fehlermeldung.

Ich habe geschaut, ob es eine Fehlermeldung in einem error_log File gibt. Habe jedoch kein error_log File im Hauptverzeichnis gefunden.

Die Seite lief ursprünglich auf unter einer anderen Adresse. Ich habe es auf eine neue Adresse verlegt. Settings.php und Config.php geändert. Ebenfalls die Daten im Admin Backend auf die neue Adresse geändert. Alles lief bestens. Nun wollte ich im nächsten Schritt die ältere Version upgraden.

Nachdem ich die Dateien aus upload auf den Server kopiert hatte und upgrade.php aufrief, kam ich nicht weiter, weil der richtig angegebene Admin mit Passwort nicht erkannt wird.

Für Hilfe wäre ich sehr dankbar.
Und bitte verzeiht meine etwas schwammige Beschreibung. Sie Resultiert aus Unerfahrenheit. :-(
Zitieren
#2
Und Du konntest Dich nach dem Umzug aber noch vor dem Upgrade problemlos im Forum und im ACP anmelden?
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#3
(03.10.2016, 23:08)Jockl schrieb: Und Du konntest Dich nach dem Umzug aber noch vor dem Upgrade problemlos im Forum und im ACP anmelden?

Ja. Bevor ich die Dateien für das Upgrade kopiert habe, ging alles einwandfrei.
Zitieren
#4
Hast Du das komplette Packet oder nur die geänderten Dateien als Paket hochgeladen und dann versuch ein Upgrade durchzuführen ?
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#5
(03.10.2016, 23:37)MrBrechreiz schrieb: Hast Du das komplette Packet oder nur die geänderten Dateien als Paket hochgeladen und dann versuch ein Upgrade durchzuführen ?

Ich habe den kompletten Ordner upgrade hochgeladen.
Am Ende tappt Ihr im Dunkeln, weil ich nicht in der Lage bin, den Fehler genau zu spezifizieren. Ich habe, wie bereits geschrieben, nicht einmal ein error_log gefunden. Und im Frontend gibt es keine Meldung. Nicht einmal so etwas wie: "Falsche Logindaten". Obwohl sicher gestellt ist, dass die Logindaten richtig sind. Denn vor dem Kopieren habe ich mich damit als Admin eingeloggt und die Seiteneinstellungen geändert.
Zitieren
#6
Welchen Ordner "upgrade" meinst du?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#7
(04.10.2016, 11:42)StefanT schrieb: Welchen Ordner "upgrade" meinst du?

Entschuldigung, ich meinte den Ordner "upload" aus mybb_1807_de, ca. 12 MByte und 1055 Objekte.
Zitieren
#8
Ich kann im Moment nicht beurteilen, ob es einfach nur an den Cookie-Einstellungen liegt (dies kann bei einem Umzug leicht passieren), oder ob ein anderes Problem vorliegt.
Falls gar nichts hilft, kannst du den Login auch entfernen: https://www.mybb.de/forum/thread-13462-p...l#pid96456
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#9
(04.10.2016, 12:33)StefanT schrieb: Ich kann im Moment nicht beurteilen, ob es einfach nur an den Cookie-Einstellungen liegt (dies kann bei einem Umzug leicht passieren), oder ob ein anderes Problem vorliegt.
Falls gar nichts hilft, kannst du den Login auch entfernen: https://www.mybb.de/forum/thread-13462-p...l#pid96456

Den Thread hatte ich bei der Suche vor meiner Frage schon gefunden. Dachte aber, dass er auf die neue Version nicht zutrifft. Ich hatte auch die Codezeile gesucht, aber so nicht gefunden. Ich werde mich nachher nochmals auf dem Server einloggen und die angegebene Stelle suchen.
Ich bitte um Entschuldigung, wenn sich das Problem so lösen lassen wird, denn dann habe ich diese Anfrage gestellt, obwohl bereits eine Lösung im Forum existiert.

Auf jeden Fall schon einmal vielen Dank für die Hilfe. Ich wüsste nicht, was ich ohne Euch machen würde. Ihr seid es am Ende, die MyBB herausragend machen.
LG
Zitieren
#10
Das müssten in der install/upgrade.php die Zeilen  217 bis inkl. 254 sein.
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren