Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
PN Funktion und Foren-Berechtigungen nach Update fehlerhaft
#1
Hallo liebe Community,
vor wenigen Tagen habe ich meine Forenversion geupdatet und seitdem ein paar Schwierigkeiten mit gewissen Funktionen. Ich habe alles nach Anleitung aktuallisiert und dann mein Backup für die Inhalte meines Forums neu aufgespielt.

Nun habe ich folgende Probleme:

1. Funktioniert die PN funktion nicht mehr richtig. Möchte ich eine PN erstellen und den User auswählen, an den sie geschickt werden soll, nimmt das Forum dies nicht an. Stattdessen wird angezeigt "loading failed" und das Eingabefenster verkleinert sich, ohne den angegebenen Inhalt anzuzeigen. Ich kann demnach nur PN's verschicken wenn ich im jeweiligen Profil auf "PN senden" klicke, denn das klappt komischerweise.

2. Spielen die Foren-Berechtigungen im ACP verrückt. Erstelle ich ein neues Forum sind alle Optionen für die Foren-Berechtigungen untereinander aufgelistet, statt nebeneinander durch klicken auf die jeweiligen "Tabs". Änderungen an diesen Berechtigungen werden nicht übernommen, stattdessen werde ich nur auf eine weiße Seite weitergeleitet in der ein " steht. Erst wenn ich die Seite neu lade, nimmt er die Änderungen an, doch geschieht dies bei jedem neuen Forum das ich erstelle. Warum auch immer.

3. Öffnen sich keine Popup-Fenster mehr. In der Adresszeile ändert sich der Link zwar, doch tut er nicht, wozu er eigentlich da ist. Es geschieht einfach gar nichts.

Nun meine Frage:

Habe ich bei dem Update irgendwas gravierendes falsch gemacht, oder bin ich zu beschränkt für die neue Software? In 1.6. hat nämlich alles tadellos funktioniert.

Vielen Dank im voraus für die Hilfe.
LG

(Den Link zum Forum mag ich lieber als PN rausgeben, statt ihn öffentlich zu machen. Ich hoffe, das stellt kein Problem dar?!)
Zitieren
#2
Das klingt stark nach irgendeinem Javascript-Problem. Bitte stelle sicher, dass alle Dateien korrekt und vollständig hochgeladen wurden. Sofern es nicht daran liegt, schick mir doch bitte den Link zum Forum.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Ich habe mal in der Browserkonsole nachgesehen, dort werden tatsächlich Scriptfehler bemängelt, allerdings weiß ich leider nicht, wie diese zu beheben sein sollen. Eine PN mit Link und Zugangsdaten ist unterwegs.
Zitieren
#4
Im Front-End werden schon einmal die völlig falschen Javascript-Dateien geladen:
Code:
<script type="text/javascript" src="xxx/jscripts/prototype.js?ver=1806"></script>
<script type="text/javascript" src="xxx/jscripts/general.js?ver=1806"></script>
<script type="text/javascript" src="xxx/jscripts/popup_menu.js?ver=1806"></script>
Da hat zwar jemand versucht das Theme an MyBB 1.8 anpassen, aber schon auf den ersten Blick erkenne ich zu zahlreiche Fehler und Inkompatibilitäten. Ich kann da eigentlich nur raten stattdessen ein Theme zu verwenden, das auch tatsächlich für MyBB 1.8 geeignet ist.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Ich habe jetzt einfach mal das Standardtheme für 1.8. wiederhergestellt. Das Problem mit den PN's hat sich damit tatsächlich in Luft aufgelöst. Aber das Problem im ACP besteht weiterhin..
Zitieren
#6
Kannst du davon einen Screenshot machen? Ich weiß nicht genau, was gemeint ist.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#7
Ja, na klar.
Mir ist nun auch aufgefallen, dass das immer bei der zweiten Änderung auftritt. Sprich, ich ändere die Berechtigungen für Admins und es klappt. Ändere ich danach beispielsweise "Gäse", sieht es so aus.


Angehängte Dateien Thumbnail(s)
   
Zitieren
#8
Dieser Fehler ist bereits bekannt und wird mit der nächsten Version behoben.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#9
Ich habe tatsächlich schon an meinem Verstand gezweifelt. Aber dann kann ich natürlich keine Lösung für das Problem finden.

Danke dir vielmals, du hast mir echt wahnsinnig geholfen.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Probleme bei Berechtigungen/Foren einstellen Darkness Rises 14 199 03.12.2018, 11:23
Letzter Beitrag: Darkness Rises
  Foren Berechtigungen Itstechtalk 1 294 31.07.2017, 19:23
Letzter Beitrag: bv64
  Foren Berechtigungen pether 3 519 25.01.2015, 22:32
Letzter Beitrag: MrBrechreiz