Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.13 veröffentlicht (07.11.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
MyBB 1.8.5 und 1.6.17 veröffentlicht
#1
MyBB 1.8.5
MyBB 1.8.5 wurde veröffentlicht und steht ab sofort zum Herunterladen bereit. Es handelt sich um ein Wartungs- und Sicherheitsupdate.

Was ist neu/geändert?
Es wurden 6 Sicherheitslücken geschlossen und 58 Fehler behoben.

Geschlossene Sicherheitslücken:
  • Mittleres Risiko: Passwort-Zurücksetz-Code kann in der member.php umgangen werden
  • Mittleres Risiko: Absender kann beim Versenden von E-Mails in der member.php gefälscht werden
  • Mittleres Risiko: Fehlerhafte Prüfung der Berechtigung in der search.php
  • Mittleres Risiko: XSS-Schwachstelle bei der Beitrags-Bearbeitung in der xmlhttp.php
  • Niedriges Risiko: CSRF-Schwachstelle beim Abbrechen von Massenmails
  • Niedriges Risiko: Benutzung des U+200E Unicode Zeichens kann zu "doppelten" Benutzernamen führen

Informationen zum Update, zu Template- und Pluginänderungen und zu Änderungen in den Sprachdateien befinden sich in den nächsten Beiträgen.

Für die Aktualisierung auf MyBB 1.8.5 ist die Ausführung des Upgradeskripts erforderlich, da es Änderungen in der Datenbankstruktur, in den Sprachstrings oder in den Templates gibt.

MyBB 1.6.17
MyBB 1.6.17 wurde veröffentlicht und steht ab sofort zum Herunterladen bereit. Es handelt sich um ein Sicherheitsupdate, welches zwei Sicherheitslücken mit mittlerem und fünf mit niedrigem Risiko schließt.

Wir weisen an dieser Stelle noch einmal darauf hin, dass der Support für MyBB 1.6.x am 1. September 2015 eingestellt wird.

Was ist neu/geändert?
Es wurden 7 Sicherheitslücken geschlossen.

Geschlossene Sicherheitslücken:
  • Mittleres Risiko: Passwort-Zurücksetz-Code kann in der member.php umgangen werden
  • Mittleres Risiko: Fehlerhafte Prüfung der Berechtigung in der search.php
  • Niedriges Risiko: CSRF-Schwachstelle beim Abbrechen von Massenmails
  • Niedriges Risiko: Benutzung des U+200E Unicode Zeichens kann zu "doppelten" Benutzernamen
  • Niedriges Risiko: Mehrere XSS-Schwachstellen, die Admin-Rechte erfordern
  • Niedriges Risiko: CSRF-Schwachstelle beim Admin-CP-Login
  • Niedriges Risiko: Schwachstelle beim Cache-Handler im Zusammenhang mit Zend Multibyte

Informationen zum Update, zu Template- und Pluginänderungen und zu Änderungen in den Sprachdateien befinden sich in den nächsten Beiträgen.

Für die Aktualisierung auf MyBB 1.6.17 ist die Ausführung des Upgradeskripts nicht erforderlich, da es keine Änderungen in der Datenbankstruktur oder in den Templates gibt.

Melden von Sicherheitsproblemen
Solltest du ein Sicherheitsproblem im Code des MyBB finden, poste dieses bitte NICHT öffentlich im Forum. Melde das Problem stattdessen über die E-Mail-Adresse im Impressum oder hier dem Support-Team.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#2
Aktualisierung von MyBB 1.8.4 auf 1.8.5
Bei der Aktualisierung gehen keine eigenen Themes, Plugins und Sprachpakete verloren.

Sichert vorher alle Dateien des Forums und die Datenbank! Führt ein normales Upgrade durch. Optional könnt ihr auch nur ein Paket mit den geänderten Dateien herunterladen:
Pakete zur Aktualisierung auf MyBB 1.8.5

Aktualisierung von vorigen Versionen auf 1.8.5
Sichert vorher alle Dateien des Forums und die Datenbank! So kann das Forum im Notfall wiederhergestellt werden.

Führt ein normales Upgrade durch.

Geänderte Dateien seit MyBB 1.8.4
  • admin
    • inc
      • class_form.php
    • modules
      • config
        • calendars.php
        • mod_tools.php
        • mycode.php
        • profile_fields.php
        • settings.php
        • smilies.php
      • forum
        • announcements.php
        • management.php
      • home
        • preferences.php
      • style
        • templates.php
        • themes.php
      • user
        • admin_permissions.php
        • group_promotions.php
        • groups.php
        • mass_mail.php
        • users.php
    • index.php
  • images
    • headerlinks_sprite.png
  • inc
    • datahandlers
      • login.php
      • pm.php
      • post.php
      • user.php
      • warnings.php
    • languages
      • english
        • admin
          • config_profile_fields.lang.php
          • config_settings.lang.php
          • config_thread_prefixes.lang.php
          • forum_management.lang.php
          • global.lang.php
          • user_users.lang.php
        • datahandler_post.lang.php
        • global.lang.php
        • member.lang.php
        • private.lang.php
        • reputation.lang.php
        • showteam.lang.php
      • english.php
    • tasks
      • delayedmoderation.php
      • userpruning.php
    • adminfunctions_templates.php
    • class_core.php
    • class_custommoderation.php
    • class_datacache.php
    • class_moderation.php
    • class_parser.php
    • db_base.php
    • db_mysql.php
    • db_mysqli.php
    • db_pdo.php
    • db_pgsql.php
    • db_sqlite.php
    • functions.php
    • functions_archive.php
    • functions_forumlist.php
    • functions_post.php
    • functions_search.php
    • functions_user.php
  • install
    • resources
      • adminoptions.xml
      • mybb_theme.xml
      • mysql_db_tables.php
      • pgsql_db_tables.php
      • settings.xml
      • sqlite_db_tables.php
      • upgrade2.php
      • upgrade3.php
      • upgrade5.php
      • upgrade12.php
      • upgrade30.php
      • upgrade32.php
      • upgrade33.php
    • index.php
  • jscripts
    • sceditor
      • editor_plugins
        • bbcode.js
        • format.js
        • undo.js
        • xhtml.js
      • jquery.sceditor.bbcode.min.js
      • jquery.sceditor.default.min.css
      • jquery.sceditor.min.js
      • jquery.sceditor.xhtml.min.js
  • contact.php
  • forumdisplay.php
  • global.php
  • managegroup.php
  • member.php
  • misc.php
  • modcp.php
  • moderation.php
  • newreply.php
  • newthread.php
  • private.php
  • reputation.php
  • search.php
  • sendthread.php
  • showteam.php
  • showthread.php
  • stats.php
  • usercp.php
  • warnings.php
  • xmlhttp.php

* Rot markierte Dateien beinhalten sicherheitsrelevante Änderungen.
* Grün markierte Dateien sind neu.

Details können unserer Doku entnommen werden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Aktualisierung von MyBB 1.6.16 auf 1.6.17
Bei der Aktualisierung gehen keine eigenen Themes, Plugins und Sprachpakete verloren.

Sichert vorher alle Dateien des Forums und die Datenbank! Führt ein normales Update durch. Optional könnt ihr auch nur ein Paket mit den geänderten Dateien herunterladen:
Pakete zur Aktualisierung auf MyBB 1.6.17

Aktualisierung von vorigen Versionen auf 1.6.17
Sichert vorher alle Dateien des Forums und die Datenbank! So kann das Forum im Notfall wiederhergestellt werden.

Führt ein normales Upgrade durch.

Geänderte Dateien seit MyBB 1.6.16
  • admin
    • modules
      • config
        • attachment_types.php
        • mycode.php
        • post_icons.php
        • profile_fields.php
        • thread_prefixes.php
      • forum
        • management.php
      • style
        • templates.php
      • tools
        • tasks.php
      • user
        • groups.php
        • mass_mail.php
        • titles.php
        • users.php
    • index.php
  • inc
    • cachehandlers
      • disk.php
    • class_core.php
    • class_error.php
    • functions.php
  • managegroup.php
  • member.php
  • modcp.php
  • search.php
  • showthread.php
  • usercp.php
  • xmlhttp.php
* Rot markierte Dateien beinhalten sicherheitsrelevante Änderungen.

Details können unserer Doku entnommen werden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#4
MyBB 1.8.5
Theme- und Templateänderungen
Folgende Templates haben sich seit MyBB 1.8.4 geändert:
  • codebuttons
  • modcp
  • postbit_attachments_images_image
  • postbit_attachments_thumbnails_thumbnail
  • private_advanced_search
  • private_send_tracking
  • reputation
  • usercp_profile_contact_fields
  • usercp_profile_customtitle

Sprachpaketänderungen
Seit MyBB 1.8.4 wurden folgende Sprachdateien geändert:
  • admin
    • config_profile_fields.lang.php
    • config_settings.lang.php
    • config_thread_prefixes.lang.php
    • forum_management.lang.php
    • global.lang.php
    • user_users.lang.php
  • datahandler_post.lang.php
  • global.lang.php
  • member.lang.php
  • private.lang.php
  • reputation.lang.php
  • showteam.lang.php
Die deutschen Sprachpakete wurden aktualisiert und stehen in einer neuen Version zum Herunterladen bereit. Eine Aktualisierung ist empfehlenswert, da zudem einige Korrekturen vorgenommen wurden.

Plugins
Plugins ab MyBB 1.8.0 sollten auch unter 1.8.5 funktionieren.

MyBB 1.6.17
Theme- und Templateänderungen
Seit 1.6.16 wurden keine Template verändert.

Sprachpaketänderungen
Seit 1.6.16 wurden keine Sprachdateien geändert.

Plugins
Plugins ab MyBB 1.6.5 sollten auch unter 1.6.17 funktionieren.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Diskussion zur Ankündigung
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren