Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.30 veröffentlicht (09.03.22)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Suchfunktion defekt / Blanke Seiten im CP
#1
Moinsen^^

Mir ist vor kurzem aufgefallen, dass die Suchfunktion im Admin CP nicht mehr funktioniert. Ich bin mir auf jeden Fall sicher, dass ich sie bereits in vergangener Zeit nutzte, kann mir aber nicht erklären, was da schief gegangen ist. Sobald ich nach irgendetwas suche, erscheint nur eine komplett blanke Seite. Dabei ist anzumerken, dass aus dem Text oben im Tab statt "Übersicht" nur noch die URL steht. Hab einfach mal testweise die URL ausgetauscht, da ich das vorerst am naheliegendsten fand. (URL.de/admin/index.php?module=config)
Hat natürlich nicht geholfen. Die Suchfunktion an sich ist mir eigentlich auch nicht so wichtig, allerdings tritt dieses Phänomen auch auf, wenn ich die Berechtigungen einer Kategorie bzw. eines Forums verändern will und das ist in meinen Augen doch schon irgendwie Bestandteil. :/

Benutze die aktuellste Version von Mybb, installierte Plugins sind Profile Comments und XSTYLED custom languaje vars.

Vielleicht hat ja einer eine Vermutung und kann weiterhelfen Toungue

Viele Grüße
Chris
Zitieren
#2
Welche Suchfunktion meinst du eigentlich? Die Suche nach Einstellungen oder die Benutzer-Suche?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Meine die Suche nach Einstellungen.
Kann auch gut sein, dass irgendwo noch mehr betroffen ist, mir fällt aber bis jetzt nichts auf. Hab auch vor kurzem noch eine fehlende Datei in den languages Ordner kopieren müssen; davor konnte ich im CP kaum noch was machen, weil Buttons fehlten.
Zitieren
#4
Vermutlich tritt irgendein PHP-Fehler auf, aber die PHP-Konfiguration verhindert, dass dieser angezeigt wird. Hast du Zugriff auf die Error-Logs des Servers? Oder kannst du die Anzeige von PHP-Fehlern bei deinem Hoster aktivieren?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Finde beim Hoster diesbezüglich leider nichts. Gibts eine Art internes Error-Log von der Software, die das auf dem FTP-Server speichert? Denn auf FTP und Datenbanken hab ich (so weit ich weiß) uneingeschränkten Zugriff.
Zitieren
#6
Eine weiße Seite deutet auf einen PHP-Error hin, das wird normalerweise nur vom Server selbst geloggt.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#7
Hab im Support-Forum einen Thread bezüglich eines Error-Logs gelesen, dass ein solches zwar existiert, da jedoch von jedem User die Fehler drin stehen, darf den keiner einsehen... (Stand 2010)

Das sind die Möglichkeiten, die ich da habe:
   
   


Im Quelltext der "leeren" Seite steht übrigens unter anderem folgendes:


//]]>


</script>

<script type="text/javascript">

//<![CDATA[

var loading_text = 'Lade<br />Bitte warten ...';

var cookieDomain = '.Muss ja nicht unbedingt öffentlich sein';

var cookiePath = '/admin/';

var cookiePrefix = '';

var imagepath = '../images';



lang.unknown_error = "Ein unbekannter Fehler ist aufgetreten.";

lang.saved = "Gespeichert";

//]]>


</script>

<script type="text/javascript">

<!--

lang.searching = "Suchen...";

lang.search_error = "Es ist zu einem Fehler beim Laden der Suchergebnisse gekommen:";

lang.search_done = "Fertig!";

// -->

</script></head>
Zitieren
#8
Wenn hier nur Teile des Quelltexts ausgegeben werden, dann scheint mir eher irgendetwas unvollständig oder beschädigt zu sein.
Bitte stelle sicher, dass alle MyBB-Dateien hochgeladen wurden und aktuell und vollständig sind. Dazu kannst du z.B. die Datei-Überprüfung im Admin-CP verwenden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#9
Ich hab nur einen Teil des Quelltexts kopiert; der ist vollständig. Hab auch bereits die Datei-Überprüfung laufen lassen, hat aber auch nicht geholfen.
Fand nur im Quelltext diese Art Fehlermeldung und dachte, dass die evtl. hilfreich sein könnte.
Zitieren
#10
Der komplette Quelltext wäre allerdings hilfreich, denn leer ist die Seite offenbar doch nicht. Es wird nur aus irgendeinem Grund nichts angezeigt.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren