Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.30 veröffentlicht (09.03.22)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
php in templates und Standardavatar in Profil
#1
Hallo,
mich macht ein Problem kirre.
Ich möchte gerne, dass Usern, die kein Avatar drin haben ein Standardavatar angezeigt (das was es da bei Einstellungen gibt, dass nützt nichts, es wird nicht angezeigt)
Dafür hab ich im der postbit:
Code:
<if $post['avatar'] then>
<div class="author_avatar"><a href="{$post['profilelink_plain']}"><img src="{$useravatar['image']}" width="230px" height="170px"></a></div>
<else><img src="{$theme['imgdir']}/noava.png" width="230px" height="170px"></if>
und in der memberlist:
Zitat:<if $GLOBALS['mybb']->user['usergroup'] == 1 then><img src="{$theme['imgdir']}/noava.png" alt="" {$useravatar['width_height']} /><else>
<if $user['avatar'] then>
<img src="{$useravatar['image']}" alt="" {$useravatar['width_height']} /><else><img src="{$theme['imgdir']}/noava.png" alt="" {$useravatar['width_height']} /></if></if>

Das klappt auch alles wunderbar und das wollte ich jetzt auch im Profil so einstellen und hab diesen Code genutzt, weil er ja eigentlich funktioniert:
Code:
<if $GLOBALS['mybb']->user['usergroup'] == 1 then><img src="{$theme['imgdir']}/noava.png" alt="" {$useravatar['width_height']} /><else>
<if $useravatar['image'] then>
<img src="{$useravatar['image']}" alt="" {$useravatar['width_height']} /><else><img src="{$theme['imgdir']}/noava.png" alt="" {$useravatar['width_height']} /></if></if>
Klappt aber nicht. Laut Quelltext steht da:
Zitat:<!-- start: member_profile_avatar -->


<img src="http://canada.gipsyheart.de/&lt;img src=&quot;{$theme['imgdir']}/noava.png&quot; alt=&quot;&quot; {$useravatar['width_height']} /&gt;" alt="" width="230" height="170" />
<!-- end: member_profile_avatar -->
Aber warum? Der Code ist doch nicht anders wie im postbit und die Verlinkung ist ebenfalls gleich.
Ich steh auf dem Schlauch und bräuchte eure Hilfe Sad
Zitieren
#2
PHP-Code:
<if $useravatar['image'then

müsste das für das Profil nicht so lauten:

PHP-Code:
<if $memprofile['avatar'] then

Edit: Vielleicht hilft dir auch dieses Thema?
Zitieren
#3
Ich hab natürlich nur memberprofile getestet Blush Danke.
Aber warum hat das nicht den gleichen Code wie das Avatar auch aufgerufen wird? Das verwirrt mich.
Zitieren
#4
Klappt's denn nun? (Mein Vorschlag war nämlich auch eher vermutet als tatsächlich gewusst oô)
Mich verwirrt deine Frage Wink Was genau meinst du?
Zitieren
#5
Ja es klappt Big Grin
Ich verwirre mich gerade selber, ich hab gerade gesehen, dass ich es nie so gemacht habe, wie ich gedacht habe. Deswegen vergessen wir meine Frage xD Hauptsache es klappt, dank dir, jetzt.
Zitieren
#6
Kein Problem Smile
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Templates in Templates einbinden Frido 3 2.169 11.01.2009, 15:41
Letzter Beitrag: StefanT