Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Spiegelung auf USB Stick
#1
Hallo zusammen,

ich wollte die Umstellung unseres Forums von 1.6.16 auf 1.8.3 auf einem USB-Stick testen.  Hat jemand Erfahrung damit und kann mir ein paar Tips geben? Bei mir funktioniert es nicht.

Ich habe dort den USBWebServer eingerichtet, die Forensoftware installiert, funktioniert. Ich nutze lediglich einen anderen Browser, wegen der Cookies usw. 
 
Dann habe ich die Einstellungen und Foren manuell 1:1 wie im produktiven Forum eingerichtet und die Plugins installiert. Hat auch noch funktioniert. Weiterhin hab ich noch die Daten aus dem Uploadordner geholt.

Dann hab ich den msd installiert, ein Backup des Forums gezogen und auf dem Stick eingespielt. Seitdem kann ich mich auf dem Stick nicht mehr korrekt anmelden und die Foren-, Thread- und andere Links usw. funktionieren auch nicht mehr. Beim Aufspielen des Backups ist mir lediglich aufgefallen, dass ich zwei Anläufe benötigt habe. Im ersten Anlauf kam nach 30s eine Fehlermeldung wegen Zeitüberschreitung. Mit dem zweiten Anlauf hat es dann funktioniert, Laufzeit waren ca. 1 Minute und 25 Sekunden. Damit es überhaupt funktioniert, habe ich das Löschen der Tabellen im msd aktiviert. Anschließend sah es so aus, als ob alle Daten drin waren. Viele User, reichlich Beiträge usw.

Im beiden Foren wird z.B. versucht, über domäne/fid ... ein Forum aufzurufen. Auf dem Stick ist die Domäne http://localhost:8080/. Wenn ich auf dem Stick noch forumdisplay.php? dazu schreibe, funktioniert es.  

Wenn ich ins Admin-CP will, dann kommt zwar die Anmeldeabfrage, aber ich bleibe danach im Forum.

Schreibe ich den Link zum Admin-CP in die Adressleiste, komme ich rein. Versuche ich, von dort aus weiterzukommen, kommt ein Fehler wegen inkorrekter Anmeldung.

Danke und
PHP Version 5.6.31
Mybb Version 1.8.19
(Stand 10/2018)

Grüße, André
#2
Mach das doch einfach mit XAMPP oder zieh dir XAMPP auf deinen USB-Stick.
Liebe Grüße.
masariC / TerminoHD
#3
Hast du die Url des Forums und die Cookie-Einstellungen angepasst?
Siehe auch: https://www.mybb.de/doku/haeufig-gestell...-forum-um/
https://www.mybb.de/doku/haeufig-gestell...-anmelden/
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#4
Hallo Stefan,

ja, hab ich alles gemacht. Hab die ursprüngliche url durch localhost:8080 ersetzt.

Habe inzwischen versucht, ohne vorherige Installation des Forums die Tabellen mit msd zu erzeugen und dann die Dateien zu kopieren, einschl. der url- und Passwortänderungen in den php.
Auf diese Variante kann ich gar nicht zugreifen. Der Browser versucht entweder auf das richtige Forum zu gehen oder, wenn ich konkrete Links in Beiträge oder den Adminbereich mit localhost:8080 erzeuge, läuft sich der Browser tod und nix passiert.

Ich werde morgen oder übermorgen eine Installation und Wiederherstellung mit msd auf einem anderen Hoster im Netz versuchen.

Xampp hab ich übrigens nicht genommen, weil nach meinen Erkenntnissen aus Internetbeiträgen die Software nicht 100%ig portabel ist. Man muss auf dem jeweiligen System wohl Daten installieren. Ich wollte aber mit dem Stick an beliebigen Rechnern arbeiten bzw. eine Testinstallation - in dem Fall aber ohne produktive userdaten usw. verteilen.
PHP Version 5.6.31
Mybb Version 1.8.19
(Stand 10/2018)

Grüße, André
#5
Hallöchen,

mir wird von msd neben der eigentlichen Datenbank noch eine mit dem Namen information_schema mit >20 Tabellen angezeigt. Was hat die zu bedeuten? Bei der Konfiguration von msd kann ich sie nicht auswählen und beim Backup wird mir nur die db... angezeigt.
PHP Version 5.6.31
Mybb Version 1.8.19
(Stand 10/2018)

Grüße, André
#6
information_schema gehört zu MySQL.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#7
So, jetzt hab ich das Forum im Netz bei einem anderen Hoster. Gleiches Problem wie auf dem Stick.
Gebe ich die URL www.clever-office-forum ein, lande ich im Originalforum clever-excel-forum.
Gebe ich den Link nach www.clever-office-forum/admin ein, kommt die Anmeldeabfrage. Ich logge mich ein, bin auch im Admin-CP. Klicke ich auf irgendein Menü, kommt die Anmeldeabfrage erneut mit dem Hinweis "Ungültige Administrations-Sitzung" Mit dem user und passwort kann ich mich dann allerdings nicht anmelden, die Abfrage geht nicht weg ...
Ersetze ich im Link auf ein Forum
http://www.clever-excel-forum.de/forum-2.html
das Excel durch Office, lande ich trotzdem wieder auf Excel.

Neben der URL ist ein weiterer Unterschied auch das Unterverzeichnis, wo die Forensoftware liegt.
Das Forum hab ich übrigens mit aktivierten Plugins gesichert.

Ich habe die
Ordnerrechte gesetzt,
config.php angepasst:
alles was clever-excel hieß durch clever-office ersetzt
Datenbank, user und passwort angepasst,
settings.php
alles was clever-excel hieß durch clever-office ersetzt
cookiepfad angepasst

.htaccess Domaineinträge angepasst
robots.txt Domaineinträge für Sitemap angepasst

Im anderen Browser bleibe ich auf office-forum.de
Allerdings erhalte ich da Fehler. Das sollte eigentlich eine Tabelle aus Excel sein, wie wir sie bei uns im Forum darstellen. Wenn ich die Fehlermeldungen kopiere, stehen die Spalteneinträge hier untereinander statt nebeneinander, da sieht man auch schwer durch :-( 
Ich hab die Meldungen auch noch als Exceldatei angehängt. 
Editiert: Ich finde die allerdings hier nicht im Beitrag.

Code:
<table border='1' cellspacing='0' cellpadding='2' valign='middle' colspan='4' style='font-family:Calibri; color:#000000; background-color:#FFFFFF; font-size:11px; font-weight:bold; font-style:normal; '><colgroup><col width='28pt'><col width='60pt'><col width='60pt'><col width='362,25pt'></colgroup><tr style='background-color:#FAFAFA'><td align='middle' colspan='4'>Arbeitsblatt mit dem Namen 'Tabelle1'</td></tr><tr style='background-color:#cacaca'><td> </td><td align='middle'>A</td><td align='middle'>B</td><td align='middle'>C</td></tr><tr><td style='background-color:#cacaca' align='middle'>1</td><td colspan='3' rowspan='1' align='left' style='font-family:Verdana; background-color:#ADCBE7; font-size:9px; ' >Folgende Warnungen sind aufgetreten:</td></tr><tr><td style='background-color:#cacaca' align='middle'>2</td><td colspan='3' rowspan='1' align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; ' >Warning [2] Cannot modify header information - headers already sent by (output started at /homepages/26/d169151287/htdocs/TestMyBB18x/inc/settings.php:1) - Line: 1721 - File: inc/functions.php PHP 5.4.35 (Linux)</td></tr><tr><td style='background-color:#cacaca' align='middle'>3</td><td align='left' style='font-family:Verdana; background-color:#CCCCCC; font-size:8px; ' >File</td><td align='left' style='font-family:Verdana; background-color:#CCCCCC; font-size:8px; ' >Line</td><td align='left' style='font-family:Verdana; background-color:#CCCCCC; font-size:8px; ' >Function</td></tr><tr><td style='background-color:#cacaca' align='middle'>4</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >[PHP]</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' > </td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >errorHandler->error</td></tr><tr><td style='background-color:#cacaca' align='middle'>5</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >/inc/functions.php</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >1721</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >header</td></tr><tr><td style='background-color:#cacaca' align='middle'>6</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >/inc/class_session.php</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >338</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >my_setcookie</td></tr><tr><td style='background-color:#cacaca' align='middle'>7</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >/inc/class_session.php</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >75</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >session->load_guest</td></tr><tr><td style='background-color:#cacaca' align='middle'>8</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >/global.php</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >55</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >session->init</td></tr><tr><td style='background-color:#cacaca' align='middle'>9</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >/index.php</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >18</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >require_once</td></tr><tr><td style='background-color:#cacaca' align='middle'>10</td><td colspan='3' rowspan='1' align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; ' >Warning [2] Cannot modify header information - headers already sent by (output started at /homepages/26/d169151287/htdocs/TestMyBB18x/inc/settings.php:1) - Line: 1721 - File: inc/functions.php PHP 5.4.35 (Linux)</td></tr><tr><td style='background-color:#cacaca' align='middle'>11</td><td align='left' style='font-family:Verdana; background-color:#CCCCCC; font-size:8px; ' >File</td><td align='left' style='font-family:Verdana; background-color:#CCCCCC; font-size:8px; ' >Line</td><td align='left' style='font-family:Verdana; background-color:#CCCCCC; font-size:8px; ' >Function</td></tr><tr><td style='background-color:#cacaca' align='middle'>12</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >[PHP]</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' > </td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >errorHandler->error</td></tr><tr><td style='background-color:#cacaca' align='middle'>13</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >/inc/functions.php</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >1721</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >header</td></tr><tr><td style='background-color:#cacaca' align='middle'>14</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >/inc/class_session.php</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >343</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >my_setcookie</td></tr><tr><td style='background-color:#cacaca' align='middle'>15</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >/inc/class_session.php</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >75</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >session->load_guest</td></tr><tr><td style='background-color:#cacaca' align='middle'>16</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >/global.php</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >55</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >session->init</td></tr><tr><td style='background-color:#cacaca' align='middle'>17</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >/index.php</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >18</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >require_once</td></tr><tr><td style='background-color:#cacaca' align='middle'>18</td><td colspan='3' rowspan='1' align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; ' >Warning [2] Cannot modify header information - headers already sent by (output started at /homepages/26/d169151287/htdocs/TestMyBB18x/inc/settings.php:1) - Line: 1721 - File: inc/functions.php PHP 5.4.35 (Linux)</td></tr><tr><td style='background-color:#cacaca' align='middle'>19</td><td align='left' style='font-family:Verdana; background-color:#CCCCCC; font-size:8px; ' >File</td><td align='left' style='font-family:Verdana; background-color:#CCCCCC; font-size:8px; ' >Line</td><td align='left' style='font-family:Verdana; background-color:#CCCCCC; font-size:8px; ' >Function</td></tr><tr><td style='background-color:#cacaca' align='middle'>20</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >[PHP]</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' > </td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >errorHandler->error</td></tr><tr><td style='background-color:#cacaca' align='middle'>21</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >/inc/functions.php</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >1721</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >header</td></tr><tr><td style='background-color:#cacaca' align='middle'>22</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >/inc/class_session.php</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >83</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >my_setcookie</td></tr><tr><td style='background-color:#cacaca' align='middle'>23</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >/global.php</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >55</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >session->init</td></tr><tr><td style='background-color:#cacaca' align='middle'>24</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >/index.php</td><td align='right' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >18</td><td align='left' style='font-family:Verdana; background-color:#F5F5F5; font-size:8px; font-weight:normal; ' >require_once</td></tr></table><table style='font-family:Arial; font-size:7pt'><tr><td style='color:#333333'>Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg</td></tr></table>
PHP Version 5.6.31
Mybb Version 1.8.19
(Stand 10/2018)

Grüße, André
#8
Ich kann das Problem nicht richtig nachvollziehen. Welche Toplevel-Domain nutzt Du denn? Die hast oben vergessen einzutragen. Ich gehe aber mal davon aus, dass es .de ist. Damit funktionieren die Links aber und es erfolgt keine Weiterleitung an das andere Forum.
Des weiteren sieht es so aus, als ob Du die settings.php mit einem falschen Editor bearbeitet hast. Dann noch die Frage, ob Du das Forum tatsächlich unter der o.a. URL eingerichtet hast, oder unter dem Verzeichnis "TestMyBB18x".
viele Grüße
Jockl
übersetzte und eigene Plugins
#9
Hallo Jockl,

das Forum ist unter dem Verzeichnis TestMyBB18x eingerichtet. Ich hatte dort vorher eine 1.8 beta zum Test, daher der Name. Erreicht habe ich das Testforum ohne weitere Zusätze unter
www.clever-office-forum.de

Die "weiterleitung" hab ich in dem Browser, mit dem ich sonst in das richtige Forum gehe.
Im anderen Browser ist keine Weiterleitung, aber z.B. das beschriebene Verhalten, wenn ich ins admin-cp will.

Bearbeiten tue ich die Dateien aus Filezilla heraus mit dem notepad++
PHP Version 5.6.31
Mybb Version 1.8.19
(Stand 10/2018)

Grüße, André
#10
Warum steht die CookieDomain der Seite http://www.clever-office-forum.de auf ".clever-excel-forum.de"?
viele Grüße
Jockl
übersetzte und eigene Plugins