Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Problem beim Upgrade von 1.6.15 zu 1.8.3
#1
Hallo ihr Lieben,

etwas verspätet, aber besser spät, als nie wollte ich heute von der Version 1.6.15 zu 1.8.3 upgraden. Ich habe also alle Plugins deaktiviert, ein Backup vom Server und der Datenbank gemacht und die Dateien auf dem Server neu eingespielt.

Nun war ich grade bei dem Punkt an dem ich das Upgrade anstoßen wollte, dabei bekomme ich jedoch folgende Fehlermeldung:

Fatal error: Call to undefined function my_inet_pton() in /www/htdocs/w011c6e3/inc/class_session.php on line 29


Die betroffenene Datei hab ich also wieder rausgeschmissen und nochmal neu eingespielt für den Fall, dass er da beim Hochladen was durcheinander geworfen hat. Leider keine Änderung. Wenn ich mir die entsprechende Zeile in der class-session.php angucke kann ich auch keinen Fehler entdecken.

Code:
// Get our visitor's IP.
        $this->ipaddress = get_ip();
        $this->packedip = my_inet_pton($this->ipaddress);

Kann es sein, dass ich es vergessen habe irgendein Plugin zu deaktivieren und er sich dabei aufhängt? 
Hat jemand von euch eine Idee oder kann ich jetzt die Dateien auf dem Server wieder zurücksetzen und nochmal von vorn anfangen?


LG Ciddy
Zitieren
#2
Zumindest die Datei inc/function.php ist veraltet. Bitte achte darauf, dass alle neuen Dateien hochgeladen wurden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Ahh super danke!
Hab nochmal alle Dateien im inc überprüft und nun lief es.
Das war wirklich schön leicht und eigene Blödheit ^^'

Danke dir!

Jetzt hat sich leider ein neues Problem aufgetan, wenn ich mich im ACP anmelden will bekomm ich 1 Zeilen und nicht die normalen 2. Ich hab da nun den Nutzernamen, das Passwort und den PIN eingegeben. Das hat nicht funktioniert und wenn ich zweimal das Passwort nehme oder nur das Passwort einmal geht es auch nicht.

@ edit: hat sich erledigt, hab es in der config.php gefunden ^^''
Zitieren