Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.30 veröffentlicht (09.03.22)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[NG] Index Validierung
#1
Da im index Template die Forum Legende in einer Validierung bemängelt wird, in Form einer Warnung, gibt es einen kleinen aber wirksamen Trick, um dies zu korrigieren.

Macht aus

Code:
<dl class="forum_legend smalltext">
<dt><span class="forum_status forum_on" title="{$lang->new_posts}"></span></dt>
<dd>{$lang->new_posts}</dd>

<dt><span class="forum_status forum_off" title="{$lang->no_new_posts}"></span></dt>
<dd>{$lang->no_new_posts}</dd>

<dt><span class="forum_status forum_offlock" title="{$lang->forum_locked}"></span></dt>
<dd>{$lang->forum_locked}</dd>

<dt><span class="forum_status forum_offlink" title="{$lang->forum_redirect}"></span></dt>
<dd>{$lang->forum_redirect}</dd>
</dl>


einfach dies

Code:
<dl class="forum_legend smalltext">
<dt><span class="forum_status forum_on" title="{$lang->new_posts}">&nbsp;</span></dt>
<dd>{$lang->new_posts}</dd>

<dt><span class="forum_status forum_off" title="{$lang->no_new_posts}">&nbsp;</span></dt>
<dd>{$lang->no_new_posts}</dd>

<dt><span class="forum_status forum_offlock" title="{$lang->forum_locked}">&nbsp;</span></dt>
<dd>{$lang->forum_locked}</dd>

<dt><span class="forum_status forum_offlink" title="{$lang->forum_redirect}">&nbsp;</span></dt>
<dd>{$lang->forum_redirect}</dd>
</dl>

und schon ist der Validator zu frieden.
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#2
Moin,

mit welchem Validator hast du das gecheckt? Bei mir werden nämlich auch in der Standardvariante keine Fehler angezeigt.

Ich prüfe immer mit: http://validator.w3.org/
Zitieren
#3
Ich wüsste jetzt auch nicht, was an leeren span-Elementen nicht valide wäre...
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#4
Ich nutze hierzu das AddOn für den FireFox -> http://users.skynet.be/mgueury/mozilla/
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#5
Schau mal in den Plugineinstellungen, ob du beim Algorithmus den SGML-Parser ausgewählt hast. Der wird auch von validator.w3..org benutzt. Smile
Zitieren
#6
Ui, genau das wars, danke waldo. Naja, falsch sind ja nun beide demnach nicht Big Grin
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#7
(28.11.2014, 00:07)MrBrechreiz schrieb: Da im index Template die Forum Legende in einer Validierung bemängelt wird, in Form einer Warnung, gibt es einen kleinen aber wirksamen Trick, um dies zu korrigieren.

Macht aus


Code:
<dl class="forum_legend smalltext">
<dt><span class="forum_status forum_on" title="{$lang->new_posts}"></span></dt>
<dd>{$lang->new_posts}</dd>

<dt><span class="forum_status forum_off" title="{$lang->no_new_posts}"></span></dt>
<dd>{$lang->no_new_posts}</dd>

<dt><span class="forum_status forum_offlock" title="{$lang->forum_locked}"></span></dt>
<dd>{$lang->forum_locked}</dd>

<dt><span class="forum_status forum_offlink" title="{$lang->forum_redirect}"></span></dt>
<dd>{$lang->forum_redirect}</dd>
</dl>


einfach dies


Code:
<dl class="forum_legend smalltext">
<dt><span class="forum_status forum_on" title="{$lang->new_posts}">&nbsp;</span></dt>
<dd>{$lang->new_posts}</dd>

<dt><span class="forum_status forum_off" title="{$lang->no_new_posts}">&nbsp;</span></dt>
<dd>{$lang->no_new_posts}</dd>

<dt><span class="forum_status forum_offlock" title="{$lang->forum_locked}">&nbsp;</span></dt>
<dd>{$lang->forum_locked}</dd>

<dt><span class="forum_status forum_offlink" title="{$lang->forum_redirect}">&nbsp;</span></dt>
<dd>{$lang->forum_redirect}</dd>
</dl>

und schon ist der Validator zu frieden.

Hi Leutz wo ändere ich das denn suche mir nen Wolf mfg
Zitieren
#8
Das ist nicht nötig, da ich meinen Validierer falsch eingestellt hatte. So wie er im Originalzustand ist, passt er.
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#9
(29.12.2014, 01:57)MrBrechreiz schrieb: Das ist nicht nötig, da ich meinen Validierer falsch eingestellt hatte. So wie er im Originalzustand ist, passt er.
Hi mir zeigt er trotzdem line 394 column 6 - Warnung: trimming empty <span>
an und finde nicht die stelle wo man das ändern kann
Zitieren
#10
Findest Du unter dem Templatset Index Page Templates->index
Mit freundlichen Grüßen

MrBrechreiz
Zitieren