Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
mycode Button 1.8
#1
Hallo an alle Nachtschwärmer,

hoffentlich bin ich hier richtig ^^

Ich komme einfach nicht mehr weiter und hoffe, dass mir geholfen werden kann. Hab in der Suche nichts aktuelles gefunden.

Dieser Anleitung für den mycode button habe ich jetzt mehrfach hinter mir und leider ohne Erfolg.


Im AdminCP habe ich den mycode definiert und funktioniert super. Wenn ich den im Forum anwende klappt das auch sorgenfrei. Nur kann ich keinen Button in der leiste entdecken...

Mir wird weder ein Button, Platzhalter oder gar meine Grafik angezeigt, die mir den aufrufen soll.

Der TAG von meinem mycode ist vcard

Spaßenshalber habe ich auch das ganze 1:1 mit mycode TAG versucht. Selbiges Ergebnis.

Weiß echt nicht mehr weiter bzw. was ich falsch mache und hoffe, dass mir geholfen werden kann.
Habe ursprünglich mit der 1.8.1 angefangen und bin derweil echt begeistert! (jetzt 1.8.3)
Zitieren
#2
(24.11.2014, 23:43)Anime Fighter schrieb: Im AdminCP habe ich den mycode definiert und funktioniert super. Wenn ich den im Forum anwende klappt das auch sorgenfrei. Nur kann ich keinen Button in der leiste entdecken...
Hast du den Button wieder in der Anleitung erstellt? Wenn ja, welche Code- und Template-Änderungen hast du vorgenommen?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Habe es auch simpel mit den Tag mycode versucht und den code so genommen wie er ist. ebenso den namen mycode.png verwendet.

Der eigentliche Tag ist nach wie vor vcard
Der Button liegt, wie in der Anleitung beschrieben, auf: jscripts/sceditor/editor_themes
16x16px, vcard.png

Templates ohne Gruppe >> codebuttons

PHP-Code:
<style type="text/css">
.
sceditor-button-vcard div  {
    
backgroundurl({$mybb->asset_url}/jscripts/sceditor/editor_themes/vcard .png);


PHP-Code:
$.sceditor.command.set('mycode', {
 
exec: function() {
 
this.wysiwygEditorInsertHtml('<span class="mycode">''</span>');
 },
 
txtExec: ['[vcard]''[/vcard]'],
 
tooltip"Visitenkarte verlinken"
});
 
$.
sceditor.plugins.bbcode.bbcode.set('mycode', {
 
tags: {
 
'span': {
 
'class': ['vcard']
 }
 },
 
format'[vcard]{0}[/vcard]',
 
html'<span class="vcard">{0}</vcard>'
}); 

Spielen die hinterlegten MyCodes im ACP überhaupt eine Rolle, wenn ich hier nochmal alles definieren muss?
Vor allem, wie füge ich mehrere hinzu? Kommen dann zig solche Blöcke zustande? Bin gerade irgendwie echt verwirrt. Danke für eure Mühen.
Zitieren
#4
Kannst du bitte einmal das ganze Templates? Das ist ja nur ein Teil und vom CSS-Code für den Button ist gar nichts zu sehen.
(25.11.2014, 19:18)Anime Fighter schrieb: Spielen die hinterlegten MyCodes im ACP überhaupt eine Rolle, wenn ich hier nochmal alles definieren muss?
Die MyCodes müssen zusätzlich zum Admin-CP auch beim Editor hinterlegt werden, sonst zeigt dieser die MyCodes nicht an.
(25.11.2014, 19:18)Anime Fighter schrieb: Kommen dann zig solche Blöcke zustande?
Genau, die ganzen standardmäßigen MyCodes sind auch in einer Datei einzeln definiert.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Hier noch eben der Fragenkatalog (hab ich voll vergessen)
URL zum Forum: http://impressions-ro.bplaced.net/ (hat noch keinen Hingergrund)
Welche Styles nutzt du?: Kopie vom Default
Hast du Plugins installiert? Welche? (wenn möglich bitte Links zu den Plugins angeben)
Welche MyBB-Version benutzt du?: 1.8.3
Welche PHP-Version benutzt du?: 5.5.5
Welche Datenbank benutzt du? (mit Version): MySQLi 5.5.33
Hast du ein Update/Upgrade durchgeführt? ja, von 1.8.1 > ..2 > ..3
Hast du dein MyBB Forum von einer anderen Boardsoftware konvertiert?: nein
Seit wann tritt das Problem auf?: von Anfang an
Wird eine Fehlermeldung ausgegeben? Welche? Wann?: nein

Das hier ist alles, was in dem codebuttons drin steht. Hab zuletzt den TAG "mycode" als Versuchsobjekt genommen.

PHP-Code:
<link rel="stylesheet" href="{$mybb->asset_url}/jscripts/sceditor/editor_themes/{$theme['editortheme']}type="text/css" media="all" />
<
style type="text/css">
.
sceditor-button-vcard div  {
 
backgroundurl({$mybb->asset_url}/jscripts/sceditor/editor_themes/vcard.png);
}
</
style>
<
script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/jquery.sceditor.bbcode.min.js"></script>
<
script type="text/javascript" src="{$mybb->asset_url}/jscripts/bbcodes_sceditor.js"></script>
<
script type="text/javascript">
var 
partialmode = {$mybb->settings['partialmode']},
opt_editor = {
 
plugins"bbcode",
 
style"{$mybb->asset_url}/jscripts/sceditor/textarea_styles/jquery.sceditor.{$theme['editortheme']}",
 
rtl: {$lang->settings['rtl']},
 
locale"mybblang",
 
enablePasteFilteringtrue,
 
emoticonsEnabled: {$emoticons_enabled},
 
emoticons: {
 
// Emoticons to be included in the dropdown
 
dropdown: {
 {
$dropdownsmilies}
 },
 
// Emoticons to be included in the more section
 
more: {
 {
$moresmilies}
 },
 
// Emoticons that are not shown in the dropdown but will still be converted. Can be used for things like aliases
 
hidden: {
 {
$hiddensmilies}
 }
 },
 
emoticonsCompattrue,
 
toolbar"{$basic1}{$align}{$font}{$size}{$color}{$removeformat}{$basic2}image,{$email}{$link}|video{$emoticon}|{$list}{$code}quote|maximize,source",
};
{
$editor_language}
$(function() {
$.
sceditor.command.set('mycode', {
 
exec: function() {
 
this.wysiwygEditorInsertHtml('<span class="mycode">''</span>');
 },
 
txtExec: ['[mycode]''[/mycode]'],
 
tooltip"MyCode einfügen"
});
 
$.
sceditor.plugins.bbcode.bbcode.set('mycode', {
 
tags: {
 
'span': {
 
'class': ['mycode']
 }
 },
 
format'[mycode]{0}[/mycode]',
 
html'<span class="mycode">{0}</span>'
});

 $(
"#{$bind}").sceditor(opt_editor);

 
MyBBEditor = $("#{$bind}").sceditor("instance");
 {
$sourcemode}
});
</
script

ich möchte letzten Endes erreichen: Der User setzt den BBcode ein, der mit Hilfe der Variable ein hinterlegtes Bild vom Server im Post anzeigt
aus "\[vcard\](.*?)\[/vcard\]" (bzw [vcard]NAME[vcard]) soll das werden <img src="../$1.png"> (per Hand funktioniert das wunderbar. Leider ohne Button T__T)
Zitieren
#6
(25.11.2014, 20:08)Anime Fighter schrieb: Hier noch eben der Fragenkatalog (hab ich voll vergessen)
URL zum Forum: http://impressions-ro.bplaced.net/ (hat noch keinen Hingergrund)
Welche Styles nutzt du?: Kopie vom Default
Hast du Plugins installiert? Welche? (wenn möglich bitte Links zu den Plugins angeben)
Welche MyBB-Version benutzt du?: 1.8.3
Welche PHP-Version benutzt du?: 5.5.5
Welche Datenbank benutzt du? (mit Version): MySQLi 5.5.33
Hast du ein Update/Upgrade durchgeführt? ja, von 1.8.1 > ..2 > ..3
Hast du dein MyBB Forum von einer anderen Boardsoftware konvertiert?: nein
Seit wann tritt das Problem auf?: von Anfang an
Wird eine Fehlermeldung ausgegeben? Welche? Wann?: nein

Das hier ist alles, was in dem codebuttons drin steht. Hab zuletzt den TAG "mycode" als Versuchsobjekt genommen.


PHP-Code:
<link rel="stylesheet" href="{$mybb->asset_url}/jscripts/sceditor/editor_themes/{$theme['editortheme']}type="text/css" media="all" />
<
style type="text/css">
.
sceditor-button-vcard div  {
 
backgroundurl({$mybb->asset_url}/jscripts/sceditor/editor_themes/vcard.png);
}
</
style>
<
script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/jquery.sceditor.bbcode.min.js"></script>
<
script type="text/javascript" src="{$mybb->asset_url}/jscripts/bbcodes_sceditor.js"></script>
<
script type="text/javascript">
var 
partialmode = {$mybb->settings['partialmode']},
opt_editor = {
 
plugins"bbcode",
 
style"{$mybb->asset_url}/jscripts/sceditor/textarea_styles/jquery.sceditor.{$theme['editortheme']}",
 
rtl: {$lang->settings['rtl']},
 
locale"mybblang",
 
enablePasteFilteringtrue,
 
emoticonsEnabled: {$emoticons_enabled},
 
emoticons: {
 
// Emoticons to be included in the dropdown
 
dropdown: {
 {
$dropdownsmilies}
 },
 
// Emoticons to be included in the more section
 
more: {
 {
$moresmilies}
 },
 
// Emoticons that are not shown in the dropdown but will still be converted. Can be used for things like aliases
 
hidden: {
 {
$hiddensmilies}
 }
 },
 
emoticonsCompattrue,
 
toolbar"{$basic1}{$align}{$font}{$size}{$color}{$removeformat}{$basic2}image,{$email}{$link}|video{$emoticon}|{$list}{$code}quote|maximize,source",
};
{
$editor_language}
$(function() {
$.
sceditor.command.set('mycode', {
 
exec: function() {
 
this.wysiwygEditorInsertHtml('<span class="mycode">''</span>');
 },
 
txtExec: ['[mycode]''[/mycode]'],
 
tooltip"MyCode einfügen"
});
 
$.
sceditor.plugins.bbcode.bbcode.set('mycode', {
 
tags: {
 
'span': {
 
'class': ['mycode']
 }
 },
 
format'[mycode]{0}[/mycode]',
 
html'<span class="mycode">{0}</span>'
});

 $(
"#{$bind}").sceditor(opt_editor);

 
MyBBEditor = $("#{$bind}").sceditor("instance");
 {
$sourcemode}
});
</
script

ich möchte letzten Endes erreichen: Der User setzt den BBcode ein, der mit Hilfe der Variable ein hinterlegtes Bild vom Server im Post anzeigt
aus "\[vcard\](.*?)\[/vcard\]" (bzw [vcard]NAME[vcard]) soll das werden <img src="../$1.png"> (per Hand funktioniert das wunderbar. Leider ohne Button T__T)

#####

Gibt es schon was neues!?
Zitieren
#7
In der Anleitung für das einfügen eines Buttons in den Editor, wurde etwas vergessen zu erwähnen.

Suche im codebuttons Template nach

Code:
emoticonsCompat: true,
toolbar: "{$basic1}{$align}{$font}{$size}{$color}{$removeformat}{$basic2}image,{$email}{$link}|video{$emoticon}|{$list}{$code}quote|maximize,source",

und ersetze es mit diesem

Code:
emoticonsCompat: true,
toolbar: "{$basic1}{$align}{$font}{$size}{$color}{$removeformat}{$basic2}image,{$email}{$link}|video{$emoticon}|{$list}{$code}quote|maximize,source,mycode",


Wobei mycode in deinen tatsächlichen MyCode Tag geändert werden muss.

Nachtrag:

Der Bildpfad zum Buttonicon muss natürlich in der Stylesheet ( background: url(mycode.png); ) angepasst werden.
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#8
Oh, das ist des Rätsels Lösung. Jetzt funktioniert es wunderbar. Vielen, vielen Dank!
Zitieren
#9
Danke für den Hinweis, ich werden die Anleitung korrigieren.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#10
Merci Stefan.
Mit freundlichen Grüßen

MrBrechreiz
Zitieren