Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
[geteilt] Fehler bei der Installationroutine
#1
Hallo,

bin für meinen Teil verzweifelt, denn wenn ich versuche von der 1.80 auf die 1.81 ein upgrade durchzuführen. Bleibe ich nach dem Aufruf immer mit "Upgraderoutine" und der Meldung "Fehler" stehen.

Ich habe alles nach Anleitung gemacht und eine anderes Board bereits problemlos von der 1.80 auf 181 gebracht. Nur bei http://jsg.spdns.de/jsg/ gelingt es mir nicht. Ich habe keine Ahnung, wo ich nachsehen kann, denn außer "Fehler" gibt es keine Meldung.

Habe das Backup eingespielt, aber das ist die 1.80.

Wo kann ich nachsehen, was den "Fehler" verursacht?

Viele Grüße
Zitieren
#2
Leider kann ich mit der Beschreibung nicht viel anfangen. Wo kommt es genau zum Fehler? Was wird genau angezeigt?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
(31.10.2014, 18:17)StefanT schrieb: Leider kann ich mit der Beschreibung nicht viel anfangen. Wo kommt es genau zum Fehler? Was wird genau angezeigt?

... das ist ja mein Problem, es steht nur "Fehler" und das Board lässt sich nicht ansprechen, weil die lock-Datei im install-Ordner fehlt. Ich habe keine Ahnung, wo ich ein Fehlerprotokoll oder dergleichen finden könnte.

Ratlose Grüße...

Christian
Zitieren
#4
Du könntest ja das Upgrade Paket nochmals drauf laden und den Upgrade Prozess wiederholen, falls nicht schon versucht.
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#5
Kannst du bitte einen Screenshot vom Fehler machen?
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#6
(01.11.2014, 09:42)cwolf schrieb: ... es steht nur "Fehler" und das Board lässt sich nicht ansprechen, weil die lock-Datei im install-Ordner fehlt.

Kann es sein, dass es sich um den Fehler handelt, wie er im Anhang dargestellt ist?


Angehängte Dateien Thumbnail(s)
   
viele Grüße
Jockl
übersetzte und eigene Plugins
Zitieren
#7
(01.11.2014, 10:31)Jockl schrieb:
(01.11.2014, 09:42)cwolf schrieb: ... es steht nur "Fehler" und das Board lässt sich nicht ansprechen, weil die lock-Datei im install-Ordner fehlt.

Kann es sein, dass es sich um den Fehler handelt, wie er im Anhang dargestellt ist?
... den hatte ich auch schon, der kommt, wenn eben die lock fehlt. Bei mir beginnt die Upgraderoutine und dort, wo ich normalerweise weiter machen kann, steht dann nur in dicken Lettern "Fehler" - ich probiere gleich nochmal dran rum und poste einen Screenshot.

Noch eine Frage zur Anleitung unten: Ich habe die settings und die config nach dem Upload der neuen Version immer drüberkopiert, also ersetzt. Was ist denn unter Punkt 5 mit "einfügen" gemeint?

1) Alle Plugins deaktivieren

2) Datensicherung (Upload Ordner, inc/settings.php, inc/config.php, Datenbank)
3) Alle Dateien aus 1.8 hochladen
4) inc/settings.php von 1.8 durch die alte ersetzen
5) inc/config.php einfügen
6) /install/upgrade.php aufrufen, upgrade durchführen
7) Templates ggf. zurücksetzen
(01.11.2014, 10:15)StefanT schrieb: Kannst du bitte einen Screenshot vom Fehler machen?

Im Anhang der Screenshot.

Folgende Dinge habe ich gemacht:

Version 1.80
alle Plugins deaktiviert
Forum offline geschaltet

changed files 1.80 auf 1.81 ins Board kopiert
alte settings und config aus Backup dorthin kopiert

Eigentümer und Gruppe auf www-data gesetzt

Upgraderoutine gestartet -> Ergebnis: siehe Srceenshot

... und nachdem ich das Backup eingespielt habe gibt es momentan nur einen weißen Bidlschirm


Angehängte Dateien Thumbnail(s)
   
Zitieren
#8
Die Beschreibung richtet sich an ein Upgrade von 1.6.x auf 1.8.x. Bei einem Upgrade von 1.8.0 auf 1.8.1 sind nicht alle Schritte nötig. Siehe auch: https://www.mybb.de/doku/installationakt...lisierung/

Wenn du nur die geänderten Dateien verwendest, ist das Kopieren der settings.php und config.php nicht nötig, diese sind im Paket nämlich überhaupt nicht enthalten. Auch das Deaktivieren der Plugins ist normalerweise nicht notwendig. Wink

Bitte verwende einmal das englischsprachige Paket zum Aktualisieren, womöglich fehlt dort etwas in den deutschen Übersetzung.
(02.11.2014, 07:33)cwolf schrieb: [quote='Jockl' pid='205915' dateline='1414834267']
... und nachdem ich das Backup eingespielt habe gibt es momentan nur einen weißen Bidlschirm
Das deutet auf einen PHP-Error hin. Falls du Zugriff auf die Error-Logs des Servers hast, sollte sich da eine konkrete Fehlermeldung finden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#9
(02.11.2014, 10:40)StefanT schrieb: Die Beschreibung richtet sich an ein Upgrade von 1.6.x auf 1.8.x. Bei einem Upgrade von 1.8.0 auf 1.8.1 sind nicht alle Schritte nötig. Siehe auch: https://www.mybb.de/doku/installationakt...lisierung/

Wenn du nur die geänderten Dateien verwendest, ist das Kopieren der settings.php und config.php nicht nötig, diese sind im Paket nämlich überhaupt nicht enthalten. Auch das Deaktivieren der Plugins ist normalerweise nicht notwendig. Wink

Bitte verwende einmal das englischsprachige Paket zum Aktualisieren, womöglich fehlt dort etwas in den deutschen Übersetzung.

(02.11.2014, 07:33)cwolf schrieb:
(01.11.2014, 10:31)Jockl schrieb: ... und nachdem ich das Backup eingespielt habe gibt es momentan nur einen weißen Bidlschirm
Das deutet auf einen PHP-Error hin. Falls du Zugriff auf die Error-Logs des Servers hast, sollte sich da eine konkrete Fehlermeldung finden.
ja, ich weiß, aber weil es nicht funktionierte habe ich zur Sicherheit die genannten Schritte unternommen. Bei einem anderen Board klappte es bei gleicher Vorgehensweise auf Anhieb.

Errolog von Apache setze ich dran, kann damit aber kaum etwas anfangen. Den Tipp mit der englischen Version werde ich versuchen, denke aber der Fehler liegt woanders. Hier das Log:

[Sun Nov 02 09:59:59 2014] [error] [client 89.0.160.73] PHP Fatal error:  Unknown: Failed opening required '/var/www/jsg/install/upgrade.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0

[Sun Nov 02 10:00:03 2014] [error] [client 89.0.160.73] PHP Warning:  Unknown: failed to open stream: Permission denied in Unknown on line 0
[Sun Nov 02 10:00:03 2014] [error] [client 89.0.160.73] PHP Fatal error:  Unknown: Failed opening required '/var/www/jsg/install/upgrade.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0
[Sun Nov 02 10:10:06 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42
[Sun Nov 02 10:10:13 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42
[Sun Nov 02 10:10:14 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42
[Sun Nov 02 10:11:01 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42
[Sun Nov 02 10:11:04 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42
[Sun Nov 02 10:11:06 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42
[Sun Nov 02 10:11:06 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42
[Sun Nov 02 10:11:12 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42, referer: http://jsg.spdns.de/jsg/misc.php?action=help&hid=7
[Sun Nov 02 10:11:22 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42, referer: http://jsg.spdns.de/jsg/showthread.php?tid=26
[Sun Nov 02 10:13:28 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42
[Sun Nov 02 10:15:06 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42, referer: http://cw-film.dd-dns.de/jsg/syndication.php?limit=15
[Sun Nov 02 10:17:42 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42
[Sun Nov 02 10:17:45 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42
[Sun Nov 02 10:20:06 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42
[Sun Nov 02 10:20:10 2014] [error] [client 89.0.160.73] PHP Fatal error:  Class 'errorHandler' not found in /source/www/jsg/inc/init.php on line 42
[Sun Nov 02 10:25:47 2014] [error] [client 37.201.227.53] script '/var/www/jsg/mobiquo/mobiquo.php' not found or unable to stat
[Sun Nov 02 10:25:47 2014] [error] [client 37.201.227.53] script '/var/www/jsg/mobiquo/mobiquo.php' not found or unable to stat
[Sun Nov 02 10:32:50 2014] [error] [client 89.0.160.73] PHP Fatal error:  require_once(): Cannot redeclare class defaulttable in /source/www/jsg/admin/index.php on line 420
zend_mm_heap corrupted
[Sun Nov 02 10:32:54 2014] [error] [client 89.0.160.73] PHP Fatal error:  require_once(): Cannot redeclare class defaulttable in /source/www/jsg/admin/index.php on line 420
[Sun Nov 02 10:33:04 2014] [error] [client 89.0.160.73] PHP Fatal error:  require_once(): Cannot redeclare class defaulttable in /source/www/jsg/admin/index.php on line 420
Zitieren
#10
Entweder ist beim Upload irgendetwas völlig schief gegangen oder die Rechte der Dateien stimmen nicht.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Fehler bei der Installationroutine eisenherz 10 1.946 04.09.2014, 09:53
Letzter Beitrag: Nik101010