Hallo, Gast! (Registrieren)

Letzte Ankündigung: Sicherheitsupdate: MyBB 1.8.30 veröffentlicht (09.03.22)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Editor Optionen ein und ausfahren.
#1
Hallo, hab ein kleines Anliegen.
Und zwar, möchte ich den im Attachment Rot makierten Bereich ein und ausfahrbar machen.
Dafür habe ich die ganzen Sachen schon in ein Template zusammengefasst.
Das Sieht so aus:
Code:
<label><input type="checkbox" class="checkbox" name="postoptions[disablesmilies]" value="1" tabindex="9"{$postoptionschecked['disablesmilies']} /> {$lang->options_disablesmilies}</label>
<br>
<label><input type="checkbox" class="checkbox" name="postoptions[signature]" value="1" tabindex="6"{$postoptionschecked['signature']} /> {$lang->options_sig}</label><br />

<tr>
<td class="trow2" valign="top"><strong>{$lang->mod_options}</strong></td>
<td class="trow2"><span class="smalltext">
<label><input type="checkbox" class="checkbox" name="modoptions[closethread]" value="1"{$closecheck} />&nbsp;{$lang->close_thread}</label><br />
<label><input type="checkbox" class="checkbox" name="modoptions[stickthread]" value="1"{$stickycheck} />&nbsp;{$lang->stick_thread}</label>
</span></td>
</tr>

Soweit geht das auch alles aber ich komme jetzt einfach nicht weiter.
Ich weiß nicht was ich machen muss damit das ein und ausfahrbar ist.
Es sollte am Anfang eingefahren sein.

Vielleicht kann mir ja jemand helfen.

Mit freundlichen Grüßen & Danke!

Hier das Bild:     
Zitieren
#2
Du hast die 1.6* Version ?
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#3
Genau, 1.8 ist mir noch zu neu Toungue
Zitieren
#4
Ich weis nicht wo Du dein Beispielcode eingefügt hast, aber so im etwa könnte es gehen.

Hier ein Beispiel für das Neue Antwort Template.

Suche im newreply Template nach

Code:
<td class="trow2">
<textarea id="message" name="message" rows="20" cols="70" tabindex="2" >{$message}</textarea>
{$codebuttons}
{$multiquote_external}
</td>
</tr>


und füge direkt darunter dies ein


Code:
<tr>
<td colspan="2">
<div class="expcolimage"><img src="{$theme['imgdir']}/collapse.gif" id="newreply_img" class="expander" alt="[-]" title="[-]" /></div>
</td>
</tr>
<tbody style="{$collapsed['newreply_e']}" id="newreply_e">


weiterhin Suchen nach

Code:
{$captcha}


darunter dies einfügen

Code:
</tbody>


Sollte am Ende etwa so aussehen.

Aufgeklappt
   


Zugeklappt
   
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#5
Soweit schon mal ganz gut, sieht so aus wie auf dem Bild, nur der "Knopf" geht nicht Toungue

Das ist jetzt ausgefahren und man kanns nicht einfahren.

Code:
<td class="trow2" valign="top"><strong>{$lang->your_message}</strong><br />{$smilieinserter}</td>
<td class="trow2">
<textarea id="message" name="message" rows="20" cols="70" tabindex="2" >{$message}</textarea>
{$codebuttons}
{$multiquote_external}
</td>
</tr>

<tr>
<td colspan="2">
<div class="expcolimage"><img src="{$theme['imgdir']}/collapse.gif" id="newreply_img" class="expander" alt="[-]" title="[-]" /></div>
</td>
</tr>
<tbody style="{$collapsed['newreply_e']}" id="newreply_e">

<tr>
<td class="trow1" valign="top"><strong>{$lang->post_options}</strong></td>
<td class="trow1"><span class="smalltext">
{$option_signature}
{$disablesmilies}
</span></td>
</tr>
{$modoptions}
{$subscriptionmethod}
{$captcha}
</tbody>
</table>
{$attachbox}
Hier mal ein Stück von dem Template. 
Zitieren
#6
So habe ich es auch Local, nur da funktioniert es Huh
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#7
Jetzt wird's komisch Big GrinD

Hab mich grad ma ausgeloggt und Gästen das Recht gegben Beiträge zu verfassen.

Und bei Gästen geht die Funktion einfach. Wenn ich ausgeloggt bin. Geht das ein und ausfahren.

Cookies gelöscht, aber das bringt nix o.O

Edit: Kannst dir das ja selbst mal anschauen:
Klick Mich
Als Gast gehts, dann Registriere dich mal und bestätige die Mail.
Und versuchs nochmal.
Lösche deinen Account später wieder.
Zitieren
#8
Ok, scheint so als hättest Du etwas am laufen, was auf angemeldete User einwirkt und auf abgemeldete nicht.

Jscript oder ein Plugin, könnte der schuldige sein.
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#9
Hmm, das ist komisch habe eigenltich noch nichts besonderes mit so einer Auswirkung installiert. jscripts sind nur die von der shoutbox und dem sceditor drin.
Plugins habe ich bis jetzt nur die Shoutbox und den Editor..
Zitieren
#10
Als Gast habe ich den normalen Editor, aber als Member den SC Editor. Das wird wohl auch dem Fehler verursachen.
Mit freundlichen Grüßen

MrBrechreiz
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Wer weiss ein vernünftiges Gästebuchscript mit folgenden Optionen ? GlobalPlayer 4 2.332 14.04.2007, 20:43
Letzter Beitrag: modercol