Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.15 veröffentlicht (16.03.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Square theme
#1
Eine neue Erweiterung wurde veröffentlicht: Square

Zitat:Information
Square is a minimalistic theme, renewed for MyBB 1.8 series.
You can find a lot of details, animated forums, sidebars, news and more with jQuery.
Tested in the latest Google Chrome, Opera and Mozilla Firefox versions.
Zitieren
#2
Hallo Community,

ich verwende das Theme Square und habe z. B. unter Private Nachrichten einen Fehler im Breadcrump und möchte dies gerne Fixen.

Kann mir vielleicht jemand weiterhelfen wie ich dies in Ordnung bekomme?


Angehängte Dateien Thumbnail(s)
   
Mit freundlichen Grüßen,
Justin Dittmer

HelpBoard.eu
Das Board rund um Coding, Programmierung und Design sowie Tutorials und Gewinnspiele.
Zitieren
#3
Hi,

aus einem Screenshot einen Fehler rauszulesen ist ziemlich schwierig. Den Code anschauen macht es leichter... hast du denn einen Link zu deiner Seite?


Gruß
Durchschnittliche Nährwerte dises Posts:
Brennwert: 2192kJ/526kcal | Eiweiß: 5,1g | Kohlenhydrate: 50,9g - davon Zucker 47,2g | Fett: 33,5g - davon gesättigte Fettsäuren: 18,6g | Ballaststoffe: 6,8g | Enthält eine Phenylalaninquelle | Enhält Spuren von Nüssen und Spam.
Zitieren
#4
(17.12.2014, 23:28)Nik101010 schrieb: Hi,

aus einem Screenshot einen Fehler rauszulesen ist ziemlich schwierig. Den Code anschauen macht es leichter... hast du denn einen Link zu deiner Seite?


Gruß
Gerne kann man sich mit diesem Account einloggen:
Link: http://helpboard.eu
BN: demo_helpboard
PW: demohb

Link zum Fehler: http://helpboard.eu/private.php
Mit freundlichen Grüßen,
Justin Dittmer

HelpBoard.eu
Das Board rund um Coding, Programmierung und Design sowie Tutorials und Gewinnspiele.
Zitieren
#5
Hi,

wenn man im Default MyBB die Privaten Nachrichten öffnet, sehen die Breadcrumbs folgendermaßen aus: Forumname > Private Nachrichten. Bei dir wird allerdings noch ein Link zum UserCP hinzugefügt, also Forumname > User CP > Private Nachrichten. Der User CP Link hat allerdings keinen Text, wodurch der Breadcrumb leer ist. Dies führt zu diesem Anzeigefehler, da jeder Breadcrumb eine Mindestlänge an Text braucht.
Der Link wird entweder durch Codeänderungen, oder durch ein Plugin eingefügt, hat allerdings nichts mit dem Theme zu tun (ist im Defaulttheme auch vorhanden, nur fällt es da nicht so schnell auf).


Gruß
Durchschnittliche Nährwerte dises Posts:
Brennwert: 2192kJ/526kcal | Eiweiß: 5,1g | Kohlenhydrate: 50,9g - davon Zucker 47,2g | Fett: 33,5g - davon gesättigte Fettsäuren: 18,6g | Ballaststoffe: 6,8g | Enthält eine Phenylalaninquelle | Enhält Spuren von Nüssen und Spam.
Zitieren
#6
(18.12.2014, 00:24)Nik101010 schrieb: Hi,

wenn man im Default MyBB die Privaten Nachrichten öffnet, sehen die Breadcrumbs folgendermaßen aus: Forumname > Private Nachrichten. Bei dir wird allerdings noch ein Link zum UserCP hinzugefügt, also Forumname > User CP > Private Nachrichten. Der User CP Link hat allerdings keinen Text, wodurch der Breadcrumb leer ist. Dies führt zu diesem Anzeigefehler, da jeder Breadcrumb eine Mindestlänge an Text braucht.
Der Link wird entweder durch Codeänderungen, oder durch ein Plugin eingefügt, hat allerdings nichts mit dem Theme zu tun (ist im Defaulttheme auch vorhanden, nur fällt es da nicht so schnell auf).


Gruß
Also kann ich selber nichts daran ändern?
Oder gibt es dafür doch noch eine Lösung?
Mit freundlichen Grüßen,
Justin Dittmer

HelpBoard.eu
Das Board rund um Coding, Programmierung und Design sowie Tutorials und Gewinnspiele.
Zitieren
#7
Möglichkeit 1: du hast was an den Dateien geändert, dann kannst du diese Änderung rückgängig machen
Möglichkeit 2: es kommt von einem Plugin, dann kannst du das Plugin deaktivieren, oder entsprechend nachvollziehen, an welcher Stelle im Plugin das Problem entsteht (vermutl. fehlende Sprachvariablen im Deutschen)

Gruß
Durchschnittliche Nährwerte dises Posts:
Brennwert: 2192kJ/526kcal | Eiweiß: 5,1g | Kohlenhydrate: 50,9g - davon Zucker 47,2g | Fett: 33,5g - davon gesättigte Fettsäuren: 18,6g | Ballaststoffe: 6,8g | Enthält eine Phenylalaninquelle | Enhält Spuren von Nüssen und Spam.
Zitieren
#8
(18.12.2014, 00:51)Nik101010 schrieb: Möglichkeit 1: du hast was an den Dateien geändert, dann kannst du diese Änderung rückgängig machen
Möglichkeit 2: es kommt von einem Plugin, dann kannst du das Plugin deaktivieren, oder entsprechend nachvollziehen, an welcher Stelle im Plugin das Problem entsteht (vermutl. fehlende Sprachvariablen im Deutschen)

Gruß

Ein Mitglied auf unserem Board hat das ganze mal Lokal auf seinem Rechner ausprobiert und konnte diesen Fehler nicht reproduzieren.
Wir bzw. ich muss das ganze also dann noch ein wenig Untersuchen.



Ich habe dann noch zwei weitere Probleme dich ich selber nicht gelöst bekomme.
  1. Auf dem ersten Bild wird das default_avatar.png nicht angezeigt, obwohl dieses existiert.
    Wenn man den Pfad untersucht, wird auch kein Bild geladen (src ist leer).
  2. Auf dem zweiten Bild wird "Benutzer Control-Panel" zwei mal angezeigt mit jeweils dem gleichen Link (usercp.php). Wieso ist das so und wie kann ich dies ändern?


Angehängte Dateien Thumbnail(s)
       
Mit freundlichen Grüßen,
Justin Dittmer

HelpBoard.eu
Das Board rund um Coding, Programmierung und Design sowie Tutorials und Gewinnspiele.
Zitieren
#9
1.) Der Standard-Avatar ist für dieses Template nicht definiert, daher wird er auch nicht geladen. Bevor du aber in den Core-Dateien rumwerkelst, könntest du lieber diesen Weg gehen.

Installiere (wenn nicht schon erfolgt) das PlugIn: PHP in Templates

Öffne das Theme Template "header_welcomeblock_member"  

Suche dort...
PHP-Code:
<a href="{$mybb->settings['bburl']}/usercp.php?action=avatar"><img class="panelavatar" style="vertical-align: top; margin-top: 5px;" src="{$mybb->user['avatar']}height="40" width="40"></a

und ersetze den Teil komplett durch:
PHP-Code:
<a href="{$mybb->settings['bburl']}/usercp.php?action=avatar"><img class="panelavatar" style="vertical-align: top; margin-top: 5px;" src="<if $mybb->user['avatar'] then>{$mybb->user['avatar']}<else>{$theme['imgdir']}/default_avatar.png</if>" height="40" width="40"></a
------------------

2.) Diese doppelte Anzeige hat wahrscheinlich die gleiche Ursache wie das Problem in den PNs. 

Ich habe das Theme lokal auch installiert, konnte den Fehler aber auch nicht reproduzieren.
MfG Sven
Zitieren
#10

  1. Die Avatar Lösung von dir hat wunderbar funktioniert Smile
    Danke.
  2. Dann werde ich mal demnächst schauen .. vielleicht finde ich mit Glück eine Lösung für dieses Problem.
Mit freundlichen Grüßen,
Justin Dittmer

HelpBoard.eu
Das Board rund um Coding, Programmierung und Design sowie Tutorials und Gewinnspiele.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Square Forum Icon Sprites MyBB.de Bot 0 300 31.03.2015, 17:10
Letzter Beitrag: MyBB.de Bot
  Square Theme MyBB.de Bot 0 366 19.02.2014, 23:35
Letzter Beitrag: MyBB.de Bot