Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.8 veröffentlicht (17.10.16)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
admin Language , (...) is not installed
#1
Hallo,

ich habe kürzlich auf version 1.2 geupdated und bekomme nach auswahl der sprachdatei folgende fehlermeldung wenn ich mich im Adminbereich einloggen will:
Language , (D:\Programme\xampp\htdocs\Homepage\Forum/inc/languages/,) is not installed.(ich komme lokal an die Daten ran).

Habe nun schon diverse male neu installeirt und jedesmal das selbe spiel.
Habe auch schon die Suchfunktion hier genutzt aber keine Fehlerbeschreibung dieser Art gefunden.

Könnte mir jemand weiterhelfen oder auf einen thread verweisen der sich meines Problems annimmt?

danke im vorraus.
Zitieren
#2
Bitte stelle sicher, dass sich alle Sprachdateien im richtigen Order befinden (auch die fürs Admin-CP im Unterordner "admin").

Gucke bitte auch, ob die Einstellungen in der Datei inc/settings.php richtig gespeichert sind:
PHP-Code:
$settings['bblanguage'] = "english"
und
PHP-Code:
$settings['cplanguage'] = "english"

Gruß,
Michael
[Bild: banner.png]
Support erfolgt NUR im Forum!
Bitte gelöste Themen als "erledigt" markieren.
Beiträge mit mangelhafter Rechtschreibung/Grammatik werden kommentarlos gelöscht.
Zitieren
#3
bei mir stand

$settings['cplanguage'] = ",";

habs geändert und funzt super.

vielen Dank
Zitieren
#4
Hi,

hab das gleiche Problem. Ich erhalte immer im Admin-CP eine Fehlermeldung:

Language , (/srv/www/httpd/phost/f/net/pytalhost/fcluftpumpe/web/inc/languages/,) is not installed

Sprich wenn ich etwas im Admin-CP umstelle kommt immer diese Meldung. Ich muss dann die settings.php von Hand editieren: Sprache wieder richtig einstellen und die Adressen bei den Cookie-Pfaden hat sich auch verstellt. Danach komm ich wieder ins Admin-CP, bis ich die nächste Option verändere....

Meine Daten:
Webspace: fcluftpumpe.pytalhost.net
Domain: http://www.fcluftpumpe.net
Forum liegt im Root.

Hier noch meine Settings.php:

<?php
/*********************************\
DO NOT EDIT THIS FILE, PLEASE USE
THE SETTINGS EDITOR
\*********************************/

$settings['load'] = "0";
$settings['adminemail'] = "redwing@congster.de";
$settings['extraadmininfo'] = "no";
$settings['pmsallowimgcode'] = "yes";
$settings['sigimgcode'] = "yes";
$settings['pmsallowhtml'] = "no";
$settings['sightml'] = "no";
$settings['pmsallowmycode'] = "yes";
$settings['sigmycode'] = "yes";
$settings['pmsallowsmilies'] = "yes";
$settings['sigsmilies'] = "yes";
$settings['subscribeexcerpt'] = "100";
$settings['announcementlimit'] = "2";
$settings['attachthumbh'] = "60";
$settings['attachthumbw'] = "60";
$settings['avatardir'] = "images/avatars";
$settings['avataruploadpath'] = "./uploads/avatars";
$settings['bannedemails'] = "http://www.fcluftpumpe.net";
$settings['bannedips'] = "1.FC Luftpumpe";
$settings['bannedusernames'] = "http://fcluftpumpe.pytalhost.net";
$settings['boardclosed'] = "mailto:redwing@congster.de";
$settings['boardclosed_reason'] = "deutsch_du";
$settings['bbname'] = "1.FC Luftpumpe Board";
$settings['bburl'] = "http://fcluftpumpe.pytalhost.net";
$settings['captchaimage'] = "off";
$settings['smilieinserter'] = "off";
$settings['contactlink'] = "mailto:redwing@congster.de";
$settings['cplanguage'] = "deutsch_du";
$settings['cpstyle'] = ".";
$settings['cookiedomain'] = ".pytalhost.net";
$settings['cookiepath'] = "/";
$settings['cssmedium'] = "db";
$settings['customtitlemaxlength'] = "40";
$settings['wolcutoffmins'] = "15";
$settings['dateformat'] = "d.m.Y";
$settings['dstcorrection'] = "yes";
$settings['decpoint'] = ",";
$settings['bblanguage'] = "deutsch_du";
$settings['default_memberlist_sortby'] = "username";
$settings['default_memberlist_order'] = "ASC";
$settings['timezoneoffset'] = "+1";
$settings['disableregs'] = "yes";
$settings['failedlogintext'] = "yes";
$settings['edittimelimit'] = "0";
$settings['enablecalendar'] = ".pytalhost.net";
$settings['enableforumjump'] = "no";
$settings['enablememberlist'] = "yes";
$settings['enablepms'] = "yes";
$settings['enablereputation'] = "no";
$settings['portal_announcementsfid'] = "1";
$settings['modlist'] = "on";
$settings['redirects'] = "on";
$settings['gziplevel'] = "4";
$settings['hideprivateforums'] = "yes";
$settings['homename'] = "1.FC Luftpumpe";
$settings['homeurl'] = "http://fcluftpumpe.pytalhost.net";
$settings['siglength'] = "255";
$settings['logip'] = "hide";
$settings['avatarsize'] = "15";
$settings['maxattachments'] = "5";
$settings['maxavatardims'] = "120x120";
$settings['maxpostimages'] = "10";
$settings['maxmessagelength'] = "0";
$settings['maxsigimages'] = "2";
$settings['maxpolloptions'] = "10";
$settings['maxpasswordlength'] = "30";
$settings['polloptionlimit'] = "250";
$settings['maxposts'] = "0";
$settings['maxregsbetweentime'] = "2";
$settings['maxnamelength'] = "30";
$settings['membersperpage'] = "20";
$settings['minmessagelength'] = "2";
$settings['minpasswordlength'] = "6";
$settings['minsearchword'] = "0";
$settings['minnamelength'] = "3";
$settings['sigcountmycode'] = "yes";
$settings['smilieinsertercols'] = "15";
$settings['smilieinsertertot'] = "email";
$settings['portal_numannouncements'] = "10";
$settings['wordwrap'] = "80";
$settings['portal_showdiscussionsnum'] = "10";
$settings['failedlogincount'] = "3";
$settings['tplhtmlcomments'] = "yes";
$settings['postfloodcheck'] = "on";
$settings['postfloodsecs'] = "60";
$settings['postsperpage'] = "10";
$settings['privateeventcolor'] = "off";
$settings['publiceventcolor'] = "/";
$settings['threadreadcut'] = "7";
$settings['refreshwol'] = "yes";
$settings['regdateformat'] = "M Y";
$settings['regtype'] = "admin";
$settings['hottopic'] = "20";
$settings['reportmethod'] = "email";
$settings['repsperpage'] = "15";
$settings['searchfloodtime'] = "60";
$settings['searchtype'] = "standard";
$settings['nocacheheaders'] = "no";
$settings['standardheaders'] = "no";
$settings['showteamleaders'] = "no";
$settings['showeditedbyadmin'] = "yes";
$settings['showeditedby'] = "yes";
$settings['showsimilarthreads'] = "no";
$settings['attachthumbnails'] = "yes";
$settings['showdescriptions'] = "yes";
$settings['portal_showstats'] = "yes";
$settings['portal_showdiscussions'] = "yes";
$settings['multiquote'] = "on";
$settings['quickreply'] = "off";
$settings['portal_showsearch'] = "no";
$settings['showindexstats'] = "yes";
$settings['subforumsstatusicons'] = "no";
$settings['portal_showpms'] = "no";
$settings['portal_showwelcome'] = "no";
$settings['showbirthdays'] = "yes";
$settings['showvernum'] = "off";
$settings['portal_showwol'] = "yes";
$settings['showwol'] = "yes";
$settings['similarlimit'] = "10";
$settings['similarityrating'] = "1";
$settings['statslimit'] = "15";
$settings['subforumsindex'] = "0";
$settings['thousandssep'] = ".";
$settings['threadsperpage'] = "20";
$settings['failedlogintime'] = "5";
$settings['betweenregstime'] = "24";
$settings['timeformat'] = "H:i";
$settings['uploadspath'] = "./uploads";
$settings['dotfolders'] = "no";
$settings['gzipoutput'] = "yes";
$settings['useshutdownfunc'] = "yes";
$settings['usereferrals'] = "no";
$settings['threadusenetstyle'] = "no";
$settings['userpppoptions'] = "5,10,20,25,30,40,50";
$settings['usertppoptions'] = "10,20,25,30,40,50";
$settings['browsingthisforum'] = "off";
$settings['emailkeep'] = "redwing@congster.de";
$settings['hottopicviews'] = "150";

?>
Zitieren
#5
redwing schrieb:Sprich wenn ich etwas im Admin-CP umstelle kommt immer diese Meldung. Ich muss dann die settings.php von Hand editieren: Sprache wieder richtig einstellen und die Adressen bei den Cookie-Pfaden hat sich auch verstellt. Danach komm ich wieder ins Admin-CP, bis ich die nächste Option verändere....
Die Einstellungen im ACP werden aus der Datenbank geholt. Es reicht nicht die inc/settings.php zu bearbeiten. Bitte stelle im ACP alles richtig ein.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#6
Das hilft mir jetzt mal grad garnicht...

Was stimmt denn an den geposteten Einstellungen nicht?
Warum kommt immer diese Fehlermeldung nachdem ich im Admin-CP was geändert habe?
Zitieren
#7
Nachdem du die Fehler in der Datei gespeichert hast, musst du als nächstes im ACP die Sprache neu eintstellen, weil da wohl irgendwas schiefgelaufen ist.
Vantage-Forum: http://vantage-forum.de/
Zitieren
#8
In der Datenbank stimmt die Einstellung nicht. Jedes Mal, wenn du was änderst, wird wieder der falsche Wert aus der Datenbank genommen. Bitte verändere die einsprechende Einstellung im ACP. Dann wird auch die Datenbank aktualisiert und der Fehler ist weg.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#9
Jo,

ich stelle die oben geposteten Einstellungen über den Admin-CP ein. Sowie ich aber auf Speichern drücke kommt die Fehlermeldung. Danach kann ich nichts mehr im Admin-CP machen - ist blockiert.

Erst nachdem ich die settings.php von Hand geändert habe, komme ich wieder ins Admin-CP rein. In der Datei ändert sich jedesmal cpLanguage auf "," und die Forums-URL von "http://fcluftpumpe.pytalhost.de" auf "http://fcluftpumpe.pytalhost.de/index.php". Erst wenn ich diese beiden Werte geändert habe komme ich wieder ins Admin-CP.
Zitieren
#10
Was für eine Fehlermeldung erhälst du?

Mfg Garlant
Ich gebe keinen Support per Messenger oder PN!
Zitieren