Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.19 veröffentlicht (11.09.18)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Beim Thumpnail erzeugen unklares Bild
#1
Hallo,


wenn ich Thumbnail erzeuge, dann sieht das Bild so aus:    

Da ist ja fast keine Farbe mehr drin.

Kann mir jemand sagen was ich da falsch gemacht habe oder was man noch verbessern kann? Huh

Danke!


PHP-Code:
​$PicPathIn="$uploaddir";
$PicPathOut="$thumb_dir";

// Orginalbild
$bild="$rename_bild2.jpg";

// Bilddaten ermitteln
$size=getimagesize("$PicPathIn"."$bild");
$breite=$size[0];
$hoehe=$size[1];
$neueBreite=100;
$neueHoehe=intval($hoehe*$neueBreite/$breite);

if(
$size[2]==1) {
// GIF
$altesBild=ImageCreateFromGIF("$PicPathIn"."$bild");
$neuesBild=imageCreate($neueBreite,$neueHoehe);
imageCopyResized($neuesBild,$altesBild,0,0,0,0,$neueBreite,$neueHoehe,$breite,$hoehe);
imageGIF($neuesBild,"$PicPathOut"."TN"."$bild");
}

if(
$size[2]==2) {
// JPG
$altesBild=ImageCreateFromJPEG("$PicPathIn"."$bild");
$neuesBild=imageCreate($neueBreite,$neueHoehe);
imageCopyResized($neuesBild,$altesBild,0,0,0,0,$neueBreite,$neueHoehe,$breite,$hoehe);
ImageJPEG($neuesBild,"$PicPathOut"."TN"."$bild");
}

if(
$size[2]==3) {
// PNG
$altesBild=ImageCreateFromPNG("$PicPathIn"."$bild");
$neuesBild=imageCreate($neueBreite,$neueHoehe);
imageCopyResized($neuesBild,$altesBild,0,0,0,0,$neueBreite,$neueHoehe,$breite,$hoehe);
ImagePNG($neuesBild,"$PicPathOut"."TN"."$bild");
}

$TN_bild "TN$bild";

echo 
"<img src=\"$TN_bild\"><br>\n"
Gruß, Micha
=========
Zitieren
#2
Vermutlich liegt es an der Komprimierung, oder einer Umwandlung von zB .jpg zu .gif, des Bildes. Wo kommt denn dein Code zum Einsatz ?
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#3
Ich Glaube dem Bild sind die Farben beim verkleinern verloren gegangen.

Schau mal hier ->http://www.php-einfach.de/codeschnipsel_6213.php und hier ->http://www.php-einfach.de/codeschnipsel_932.php. Vieleicht hilft dir das weiter.
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#4
(17.08.2014, 19:12)MrBrechreiz schrieb: Ich Glaube dem Bild sind die Farben beim verkleinern verloren gegangen.

Schau mal hier ->http://www.php-einfach.de/codeschnipsel_6213.php  und hier ->http://www.php-einfach.de/codeschnipsel_932.php. Vieleicht hilft dir das weiter.

http://www.php-einfach.de/codeschnipsel_6213.php

Das sieht ganz gut aus. Aber wie ist da der Ausgang?

echo " $???? ":
Gruß, Micha
=========
Zitieren
#5
Nimm am besten das Beispiel für das Thumbnail, damit haste auch eine echo Ausgabe.

http://www.php-einfach.de/codeschnipsel_932.php

Hier zum Forum
http://forum.php-einfach.de/thread.php?t...32&seite=1
Mit freundlichen Grüßen

MrBrechreiz
Zitieren
#6
Vielen Dank!
Gruß, Micha
=========
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [fertig] Klick auf Bild -> Bild wird vergrößert (s. Doku) modercol 7 1.457 07.04.2007, 17:33
Letzter Beitrag: Michael