Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.13 veröffentlicht (07.11.17)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
MyBB 1.6.15 veröffentlicht
#1
MyBB 1.6.15 wurde veröffentlicht und steht ab sofort zum Herunterladen bereit. Es handelt sich um ein Wartungs- und Sicherheitsupdate. Dies ist das letzte Wartungsupdate für MyBB 1.6.x.

Was ist neu/geändert?
Es wurden 1 Sicherheitslücken geschlossen und 10 Fehler behoben.

Geschlossene Sicherheitslücken:
  • Mittleres Risiko: Mögliche XSS-Lücke im Video-MyCode

Informationen zum Update, zu Template- und Pluginänderungen und zu Änderungen in den Sprachdateien befinden sich in den nächsten Beiträgen.

Für die Aktualisierung auf MyBB 1.6.15 ist die Ausführung des Upgradeskripts nicht erforderlich, da es keine Änderungen in der Datenbankstruktur oder in den Templates gibt. Die Sprachpakete wurden allerdings verändert.

Melden von Sicherheitsproblemen
Solltest du ein Sicherheitsproblem im Code des MyBB finden, poste dieses bitte NICHT öffentlich im Forum. Melde das Problem stattdessen über die E-Mail-Adresse im Impressum oder hier dem Support-Team.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#2
Aktualisierung von MyBB 1.6.14 auf 1.6.15
Bei der Aktualisierung gehen keine eigenen Themes, Plugins und Sprachpakete verloren.

Sichert vorher alle Dateien des Forums und die Datenbank! Führt ein normales Update durch. Optional könnt ihr auch nur ein Paket mit den geänderten Dateien herunterladen:

.zip   changed_files_1615.zip (Größe: 353,13 KB / Downloads: 299)

Aktualisierung von vorigen Versionen auf 1.6.15
Sichert vorher alle Dateien des Forums und die Datenbank! So kann das Forum im Notfall wiederhergestellt werden.

Führt ein normales Upgrade durch.

Geänderte Dateien seit MyBB 1.6.14
  • admin
    • inc
      • functions.php
      • functions_theme.php
    • modules
      • config
        • mod_tools.php
        • plugins.php
        • smilies.php
      • forum
        • management.php

      • tools
        • adminlog.php
        • maillogs.php
        • modlog.php
      • user
        • users.php
    • index.php
  • archive
    • index.php
  • inc
    • datahandlers
      • post.php
    • languages
      • english
        • admin
          • config_smilies.lang.php
          • forum_management.lang.php
        • datahandler_post.lang.php
        • member.lang.php
        • warnings.lang.php
      • english.php
    • tasks
      • massmail.php
    • class_core.php
    • class_moderation.php
    • class_parser.php
    • class_session.php
    • db_mysql.php
    • db_mysqli.php
    • db_pgsql.php
    • functions.php
    • functions_archive.php
    • functions_post.php
    • functions_search.php
    • functions_user.php
  • captcha.php
  • forumdisplay.php
  • global.php
  • member.php
  • modcp.php
  • newreply.php
  • newthread.php
  • online.php
  • printthread.php
  • private.php
  • search.php
  • showthread.php
  • usercp.php
  • warnings.php
  • xmlthttp.php
* Rot markierte Dateien beinhalten sicherheitsrelevante Änderungen.
* Grün markierte Dateien sind neu.

Details können unserer Doku entnommen werden.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#3
Theme- und Templateänderungen
Seit MyBB 1.6.14 wurden keine Templates geändert.

Sprachpaketänderungen
Seit MyBB 1.6.14 wurden folgende Sprachdateien geändert:
  • admin
    • config_smilies.lang.php
    • forum_management.lang.php
  • datahandler_post.lang.php
  • member.lang.php
  • warnings.lang.php
Die deutschen Sprachpakete wurden aktualisiert und stehen in einer neuen Version zum Herunterladen bereit. Eine Aktualisierung ist empfehlenswert, da zudem einige Korrekturen vorgenommen wurden.

Plugins
Plugins ab MyBB 1.6.5 sollten auch unter 1.6.15 funktionieren.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#4
Diskussion zur Ankündigung
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren
#5
Update: Aufgrund eines Fehlers in der Datei modcp.php wurden die Pakete soeben aktualisiert. Wenn ihr euer Forum bereits aktualisiert habt, könnt ihr einfach die genannte Datei austauschen.
Wer sich unsicher ist, kann auch die Datei-Überprüfung im Admin-CP nutzen um zu prüfen, ob die Datei aktuell ist.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
Zitieren