Hallo, Gast! (Registrieren)

Letzte Ankündigung: MyBB 1.8.20 veröffentlicht (27.02.19)


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Fehler beim Hochladen von Attachments
#1
Sad 
Moin moin zusammen,

falls ich mein Problem in den falschen Bereich poste verschiebt es bitte Wink

Ich habe mit meinem Forum folgendes Problem, wenn ich ein Attachment das größer als 25MB ist hochladen will fängt der Upload zwar an ich bekomme aber nach ca. 10 Sek. die Fehlermeldung "Fehler 404, die Datei oder Ressource konnte nicht gefunden werden".

Kleinere Dateien können problemlos hogeladen werden, selbst wenn dies 1-2 Minuten dauert wird der Vorgang nicht abgebrochen Huh

Woran kann das liegen?

Weitere Infos:
-Das Problem ist erst nach dem Update auf 1.6.10 aufgetreten
-Das Forum wird über IIS 7.5 gehostet und liegt auf einem Server mit Windows Server 2008 R2 X64 als System, auf den ich vollen Zugriff habe.
-PHP 5.3 ist über FastCGI in den IIS-Dienst eingebunden
-post_max_size und post_limit sind beide in der php.ini auf 150MB eingestellt
-Die Laufzeit für Uploads ist sowohl in der php.ini als auch IIS auf 3 Minuten gesetzt.
-Die portal.php und die misc.php des Forums wurden mit einem Code der bestimmte Benutzergruppen ausschließt ergänzt.

Portal.php
Code:
$notgroups = array(1,2,5,7,9,13);
if(in_array($mybb->user['usergroup'], $notgroups))
{
    error_no_permission();
}
Misc.php
Code:
if($mybb->user['usergroup'] == "1" && $mybb->input['action'] == "help" && $mybb->input['hid'] == "9")
{
    error_no_permission();
}
Vielen Dank für Eure Mühen im Voraus.

Gruß atriu
#2
Das muss an der IIS- bzw. PHP-Konfiguration liegen. Ich fürchte irgendein Limit wird überschritten, aber mit IIS habe ich leider keinerlei Erfahrungen.
[Bild: banner.png]

Bitte die Foren-Regeln beachten und im Profil die verwendete MyBB-Version angeben.
#3
Vielen Dank, hast mich auf den richtigen Weg geführt Wink

Hatte mich so auf die php.ini und Time-outs in IIS eingeschossen das ich an Größenlimits seitens IIS gar nicht mehr gedacht hatte Ugly

Hab die web.config von IIS angepasst und es läuft.

An einem Beispiel für ein Limit von 100MB.

"httpRuntime maxRequestLength" muss entsprechend in Kilobytes eingefügt werden und "requestLimits maxAllowedContentLength" in Bytes.

Code:
<?xml version="1.0" encoding="UTF-8"?>
<configuration>
      <system.web>
          <httpRuntime maxRequestLength="102400" />
      </system.web>
      <system.webServer>
      <security>
        <requestFiltering>
          <requestLimits maxAllowedContentLength="104857600" />
        </requestFiltering>
      </security>
        <handlers>
            <remove name="AboMapperCustom-1181171" />
        </handlers>
        <directoryBrowse enabled="true" showFlags="Date, Time, Size, Extension, LongDate" />
  </system.webServer>
</configuration>
Manchmal sieht man den Wald vor lauter Bäumen nicht Wink